5:1 Surround Sound..Help.. Totally lost !!!


Badge
  • Contributor I
  • 14 replies

Hi All

I have a Samsung QE55 Q9FN Tv, a Sonos Beam & have just purchased x2 Sonos One Speakers.

I am trying to get 5:1 Surround Sound but to no avail ?! 

Everything is connected through a Samsung One Connect box, my Beam is connected using the HDMI Arc port, then the Tv, PS4 & Sony 4K player using the other HDMI ports.

I have just purchased x2 Sonos One Speakers all paired up connected to my System / Account.

If I play music through the Sonos App thats fine, sound comes through all Speakers, the Beam & both Sonos Ones.

However when watching TV, using PS4 or 4K player sound only comes through the Beam ? I have made sure TV Audio settings, PS4 & 4K player are set to Dolby Digital but still sound only through the Beam. If I go on the Sonos App to My System to check what sound is coming in it says Dolby 2.0 when watching Tv, Dolby 5:1 when on PS4 & just Stereo when on 4K player but sound only comes through the Beam.

So my Q. Is how on earth do I get 5:1 Surround Sound for  my Tv ,PS4 & to watch films on 4K player using Sonos System ?? I was going to purchase the Sub to complete the System but no point if sound only comes through the Beam. 

Do I need to connect using an Optical switch or cable but there is no Optical port on the Beam ?

 

I HOPE SOMEONE CAN HELP !

Thank you

Colin

 

 

 

 

 


30 replies

Userlevel 6
Badge +14

Since Sonos states you have DD 5.1 from your PS4, the only problem areas seem to be the TV itself and the 4k-player. Those seem to be feeding stereo to the Beam, so the rear speakers are silent. The solution to your problems with the TV and the 4k-player can probably be found in the sound set up on both devices. Try to get them to emit DD5.1. 

Badge

Thanks for your reply 106rallye.

Even though when connected to the PS4 & it shows Dolby 5:1 coming in I get no sound whatsoever out of the 2 Sonos Ones which are set up as the rear Left & Right Speakers.

Regards Tv Audio settings I have 3 options PCM linear , Dolby Digital , Dolby Digital + & i've tried them all, likewise on 4K player that is set to Dolby Digital but NO sound comes from rear Sonos Ones ?! 

I am very frustrsted & disappointed thus far as believed this to be a very good System to have as a Wireless 5:1 Surround Home Theater set up.

So if you know how I can get all my Devices Tv PS4 4K player to emit DD5:1, I more than welcome & appreciate the help.

 

Cheers 

Colin

Userlevel 7
Badge +17

Do you have the rear (surround) speakers set up as a stereo pair, or bonded to the Beam as surrounds? Some owners had accidentally set them as as the former, rather than the latter. 

Badge

Hi nik9669a

I already had the Beam configured then added the Sonos Ones after. So do I need to set up everything again from scratch ?

How can I tell if set as a Stereo pair or Bonded to the Beam ? 

Userlevel 7
Badge +17

Under Settings, System, Products do you see the room with the Beam listed as “Lounge (+LS+RS)” or whatever your roomname is? If so, they are bonded as surrounds.  

Badge

Yes  Lounge shows Beam & (+LS & RS) if I click on lounge & scroll down to Tv set up it shows a Pic of the Tv & the Beam with a tick but does not show the rears so should it show them there too ?

Userlevel 6
Badge +14

Even if you use the apps on your smart TV (like Netflix) there’s no surround? TV and media player should be set to DD, no plus.

Badge

No nothing through the Sonos Ones, rear speakers ! only when play music through the App.

I have read somewhere that Sonos is mainly aimed for Music so maybe not for me & looks like i'l have to return the Sonos Ones & get my money back & find a System that gives 5:1 Surround sound cos this just aint working !!

Userlevel 6
Badge +14

The system works perfectly with my Samsung QE65Q90, so if your TV is a recent Samsung model it should just work.

Yes  Lounge shows Beam & (+LS & RS) if I click on lounge & scroll down to Tv set up it shows a Pic of the Tv & the Beam with a tick but does not show the rears so should it show them there too ?

The picture on my app is the same. My surrounds work. Must be your settings.

Userlevel 7
Badge +17

I’m puzzled by what you say you’re seeing. 
 

 

Does your room show something like this? Earlier you said you were seeing & symbols rather than +  


 

My surround works just fine so there must be something about your setup. 

Userlevel 6
Badge +14

This is the screen he mentions (shown in Dutch).

Badge

Yes my My Systen Screen shows 

Lounge

Beam (+LS +RS)

& the other screen shows exactly the same same pic of TV with the Beam on with a tick.

Regards settings I have tried them all on the Tv, PS4 & Sony 4K player & no sound comes from the 2 Sonos Ones. They only work when I play music via the Sonos app with the setting on either Ambient or Full.

The Beam is definitely connected using the ARC Hdmi port on my Samsung One connect box that came with my Tv so that it can't be connected up any other way.

I see you have the Playbase & a Sub so I dont know if that is connected up differently using a Digital Optical cable as I have read alot that 5:1 Surround works / passes the signal far more than just being connected with ARC Hdmi.

Anyhow as my title said I am still " totally lost".  ! 🤔

I would like to thank you for your help thus far.

Badge

Heres my Settings

TV

 

Badge

 

Badge

 

Badge

PS4

 

Badge

Sony 4K player

CB2 ..The TV Settings you have shown, look okay to me, as domthe PS4, but it’s not clear if you are definitely playing a Dolby 5.1 (surround sound) audio source? Have you checked that is the case?

I would stick with the Apps built into your TV (for now, at least) .. try a Netflix movie (marked with 5.1 audio) and then goto the Sonos App “Settings/System/About my Sonos” and scroll the list of devices until you see your main HT product… one of its listed entries will show the Audio In format that is playing.

Badge

Thanks for reply Ken.

When I put my PS4 on I checked Audio in settings on my system & it showed Dolby 5:1 coming in, yet sound only came out of Beam ? And when playing a 4K film on 4K player which is in 5:1 Audio still only sound from the Beam, so how does one explain that.

 

Thanks for reply Ken.

When I put my PS4 on I checked Audio in settings on my system & it showed Dolby 5:1 coming in, yet sound only came out of Beam ? And when playing a 4K film on 4K player which is in 5:1 Audio still only sound from the Beam, so how does one explain that.

 

Have you gone into the films audio options menu, whilst it’s playing on the PS4. I’m thinking it may try to default to DTS audio and then fallback to Stereo… change it to Dolby Digital 5.1, if that is the case.

Userlevel 7
Badge +17

Might it be your HDMI cable? Do you have a spare that you can ty?

Userlevel 7
Badge +17

You’ve not disabled Wi-fi on Beam or the Ones?

Badge

Not signed up to Netflix so can't try a film in 5:1 on there.

Wifi showing enabled on Beam & both Sonos Ones.

Not tried another Hdmi cable but then surely if was faulty I would not get any sound through Beam.

Thanks again.

Userlevel 7
Badge +17

Are you using HDMI or HDMI-ARC? Have you got the Optical adapter, and have you tried that with appropriate change to the TV’s output?

Badge

Yes using Hdmi Arc..what is the Optical adaptor ?? 

Reply