Answered

TuneIn plays wrong radio station


Badge

Hi, first time here.

I have a problem when trying to play a radio station with Google Assistant on a Sonos One.

Trying to play “SR P3” a swedish radio station through the voice command “Hey Google, play P3” and it worked without a problem until 1 month ago but now it only starts a spanish radion show without the text “P3” in the title. It works without problem on my phone and open the right radio station in TuneIn.

I have tried to unlink and link TuneIn and also tried using it with out TuneIn-account synced to my Sonos.

 

Searched the forum but couldn’t find any problem like this, or maybe my search was bad.

Does anyone have som idea what the problem can be?

icon

Best answer by Jamie A 16 June 2023, 11:02

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

12 replies

Userlevel 7
Badge +15

Hi @lhenriksson, welcome to the Sonos Community!

I’ve had a look on TuneIn and, while the station exists, I can’t test it myself as it’s region restricted. 

Because of this, I would suggest you check your profile on Sonos.com as the station wont play if your address is incorrect. If you change your address, give the system a few hours to change over and try again.

If your address is correct, then have a look at your Google Assistant activity page. Check if the command you gave lines up with what was heard by Google Assistant as generally the system playing the wrong station is due to the voice assistant hearing something else. If the command isn’t what you said, clean the area around the microphone of the speaker and try again.

These are the two most common reasons for not being able to play a radio station, however it’s possible you’re running into another error. I recommend testing different radio stations and services with Google Assistant as, if they also aren’t working or are not playing the requested station or song, then it would be worth removing and re-adding Google Assistant to your Sonos system.

If you’re still having issues after following the above, please reach out to our support team for further troubleshooting, as they have the tools available to assist you in resolving this issue.

I hope this information helps!

Badge

Hi @lhenriksson, welcome to the Sonos Community!

I’ve had a look on TuneIn and, while the station exists, I can’t test it myself as it’s region restricted. 

Because of this, I would suggest you check your profile on Sonos.com as the station wont play if your address is incorrect. If you change your address, give the system a few hours to change over and try again.

If your address is correct, then have a look at your Google Assistant activity page. Check if the command you gave lines up with what was heard by Google Assistant as generally the system playing the wrong station is due to the voice assistant hearing something else. If the command isn’t what you said, clean the area around the microphone of the speaker and try again.

These are the two most common reasons for not being able to play a radio station, however it’s possible you’re running into another error. I recommend testing different radio stations and services with Google Assistant as, if they also aren’t working or are not playing the requested station or song, then it would be worth removing and re-adding Google Assistant to your Sonos system.

If you’re still having issues after following the above, please reach out to our support team for further troubleshooting, as they have the tools available to assist you in resolving this issue.

I hope this information helps!

Big thanks @Jamie A, when i checked my sonos account my country whas “se” so i changed it to Sweden and was then prompted to select the correct address. And after one hour i tried to start the radion station P3 againt and it worked like a charm.

Badge

The problem is back, but it’s only affecting the “SR P3” radion channel, all the other from SR (P1,P2 and P4) is working and other swedish radiostations is working. Tried multiple differenct voice commands “Play P3, Play SR P3 and Play Sveriges radio P3” and all of them is working on my phone using google assistant but not on my Sonos (i answers with with “Okay, playing P3 on TuneIn”) instead it plays the station “La Tricolor 99.3 FM” wich looks like to be a radiostation from USA. The one problem i can see is that the both stations using the same frequenzy 99.3 and when i tried to start with “Play 99.3” it answers again with “Okay, playing P3 on TuneIn” but the wrong stations starts. So something must be wrong with the requenzy and Sonos because it’s working fine on my phone.

My profile on Sonos has the right Adress, City, Country and Zip code.

 

I will contact the support team for further troubleshooting, but thought i would post a update here. 😊

Hello 

i live in france and I have the same pb 

In my profile all is in French but when I want for example listen « France Info « with my sonos one (google assistant) I have a wrong station in English launch 

thanks

Badge

Hello 

i live in france and I have the same pb 

In my profile all is in French but when I want for example listen « France Info « with my sonos one (google assistant) I have a wrong station in English launch 

thanks

 @Tomtom53 I contacted the Sonos support and got the information that they have a ongoing problem with Sonos playing wrong radio stations on tunein. So it looks like it is only to wait for them to solve the problem. Just hope they found a solution fast. 🙂

I also have the exact same problem with playing SR P3. It starts the tricolor channel instead. Hope they find a solution soon. 

You could try this, it works for me. If your countries capital doesn’t work, look at info on TuneIn to find out where your station is based, maybe if you add that it works.. 

Same problem. None of the suggested fixes works for me. Only SR P3 that fails to play.

Same problem.

Saw that there were a new TuneIn in the list in the sonos app. Tried to remove the old, see if that helps.

Same problem for me as well. I trust that Sonos can revert with a solution for this.

Same here. Correct address details on Sonos.com and Google Assistant is hearing me perfect well. Very annoying issue and please resolve this asap as the issue is already at least 2 months old.

I have the exact same problem with SR P3.