Google Assistant starting the wrong radio station on TuneIn

  • 26 June 2023
  • 6 replies
  • 432 views

Hello everyone,

I’ve received my Sonos One (Gen 2) yesterday, and overall I’m happy with the product. There’s just an issue I’m having when asking Google to play a radio station (in the Netherlands). I’ll post my findings and my current solution/workaround below.

When asking “Hey Google, speel Qmusic” I get the response “Ok, ik speel Qmusic op TuneIn”. All good you’d say. Next I hear TuneIn starting, but then it starts playing an American radio station. The same problem occurs with any other Dutch radio station.

Findings:

1) Contact with support didn’t help much, but they confirmed it’s an ongoing issue between Google and Sonos. Lately it was working, but reports have started coming in since beginning of June about this specific issue.

 

2) All my locations in Sonos, Google Assistant and my Phone are set to the Netherlands. So the systems should know I’d like a Dutch radio station.

 

3) Qmusic has a FM frequency of 100,7 in the Netherlands. The radio station I hear is ‘Life 100,7’ in America. So the frequency is correct, but the location isn’t. (Radio 538 gives a Canadian station with the same fequency as Radio 538)

 

4) When asking “Hey Google, speel Qmusic Nederland”, the same problem occurs.

 

5) When asking “Hey Google, speel Qmusic Amsterdam”, it plays the correct radio station. Bingo! Adding Amsterdam as an extra command seems to be working for all Dutch radio stations so far. So apparently that adds the missing metadata (besides frequency) to start streaming the correct radio station on TuneIn.

 

My current solution:

 

1) Ask for radio stations and include “Amsterdam” in the voice command.

 

2) I’ve made a routine in the Google assistant app that basically does the above solution for me. When I ask “Hey Google, speel Qmusic” I make Google perform the following “Play radio > Qmusic Amsterdam”. So it works as well when the command is written. Now I can just ask play Qmusic and the software plays “Qmusic Amsterdam”

 

Maybe if you have this issue in another country than the Netherlands, you could try add you own capital in the command. I’m curious if this works abroad.

 

Hope this helps anyone, I’m happy I can fully use my Sonos as intended at the moment.

 

Bas


6 replies

Userlevel 7
Badge +17

Great work around. I personally use the other work around, by making Radio 2 my favorite station on Google and asking Google to play “my favorite station”.

Having to say “Amsterdam” can be troublesome for some. Does naming nicer Dutch cities (Groningen springs to mind) work?

You can try haha 😉 I just used Amsterdam because, according to TuneIn, that’s where the radio station is based. I just kept using Amsterdam for the rest of the radio stations as well and that worked. I figured it works because it’s the capital, so I’m really curious to see if this works for users in different countries when they use their capital city.

Userlevel 7
Badge +17

I tried. You need to name the city the broadcaster is based in.

Hi -

For information I encounter exactly the same issue in France (and had found the same workaround by adding City’s name):

  • When asking to play “France Info” (frequency 105.5), it plays a UK station “Swindon 105.5” 
  • If I ask to play “France Info Paris”, all is OK.

All my locations are set correctly.

Actually this bug appeared few weeks ago. I’ve had my Sonos Move for a couple of years and it used to work correctly.

Happy to see you’ve received confirmation from the support that they are aware of this issue and work on it (not what I’ve been answered on my side...).

cheers

 

Edit: I’ve tried your nice idea of a routine to save adding “Paris” each time (I’m lazy :-) ), but surprisingly it doesn’t work for me … Double checked, the routine is well configured to play “France Info Paris” upon “France Info” trigger, but it launches “Swindon 105.5” :-(

 

Edit2: I’ve found a solution ! If in the routine I use the action “Plays multimedia content” > “Plays Radio” > “France Info Paris”, it launches “Swindon 105.5”, but if instead I use the action “Use personalized command” > “Mets France Info Paris sur TuneIn”, it works ! :-)

Good to hear this workaround works for you 😃 I‘m also too lazy/annoyed to add the city every time I want to listen to the radio, so why not let the software do the work. 

I have exactly the same problem for a couple of weeks now when trying to play my favorite radio station, unfortunately the suggested work arounds didn’t help.

In my case, I’m saying “Hey Google, spiele ORF Radio Wien” (=play Radio Vienna), and in ~90% of the cases, the Sonos Roam is playing “Radio con Vos 89.9 (Buenos Aires)”. The frequency of both radio stations is 89.9, so this fact is definitely the root cause of the issue.

I’ve tried out several things in the Google Home settings, like radio routine, personalized routine, various radio names (with country, frequency, etc.), but no success.

@ Sonos as it is quite obvious that this is a Sonos bug (no issues on my Google Nest devices at all), I wonder when this issue is going to be resolved? Playing radio is our main use case, so at the moment, the Sonos Roam is useless.

Reply