Sonos Arc and Google Assistant: trouble linking

  • 20 August 2021
  • 6 replies

Badge +1
  • Avid Contributor I
  • 16 replies

Hi all,

When I try adding Google Assistant to my Sonos Arc, I encounter the following error messages from the Sonos app and Google Assistant respectively. I tried removing all the music services in my Sonos app and signing out of all my gmail accounts as suggested in some of the other posts, as well as installing (and uninstalling) the Google Assistant first before adding the voice service to the Sonos App. Could someone help me? Sonos support tried to diagnose the problem for an hour but we have yet to resolve it. Thank you. 




Best answer by Ken_Griffiths 21 August 2021, 11:25

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

6 replies

My initial thoughts are it’s perhaps an issue associated with your wireless router, what router is it and did you try wiring the Arc to your LAN to do the setup?

If that’s not practicable, maybe try switching off your 5Ghz WiFi on the router (temporarily) and see if it works when all products are operating on the 2.4Ghz band only.

Also consider trying another mobile device to do the setup. Note that any mobile device you use needs to have the Google Assistant/Home Apps installed and logged into your Google Home Account with a ‘Home’ setup and running in order to add your devices to ‘rooms’ in that Home.

Badge +1

Thank you did your reply. My router is a Linksys Velop  AX4200 ( I will give the LAN connection (and frequency band) a shot to try setting up the Google Assistant.

Noted on trying a different mobile device and installing both of the Google apps first.

Will report back :)



As you are using the Linksys Velop system you may find this thread link below a useful read too:

Sonos on WiFi Mesh

Badge +1

Thank you for link. It was an interesting read. I tried setting Google Assistant using another Android device but that didn’t work. I wasn’t sure how to disable the frequency band as the option was not available. However, by accident after I resetted the router, albeit with LAN cable plugged in, it worked.

Hope you don’t mind me asking but Google Assistant is able to switch off my TV but it is unable to switch it on. I was following your previous suggestion by renaming the Sonos TV Control for Living Room to TV (there is no overlap of names) but that did not work. Do you have any other tips for what I could try? Thank you.


Here are some further suggestions to explore…

Have you installed Google Assistant on the Arc and checked in the Google Home App that the speaker and TV control icons are placed into a room in your home?

Have you checked the Sonos ‘Action/Skill’ and asked it to check for devices (see attached screenshot)?

If the ‘TV’ name isn’t working, then just try another name like “LG TV”, "Sony TV” or ”Lounge TV” etc.

Try toggling off/on HDMI-CEC control option on the TV and see if there is an additional option called ‘auto-power-sync’ (or similar named option) in the TV CEC settings and if so, then enable that.

Badge +1

I went through all the suggestions and the last one worked. Thank you so much. I just had to turn the Power on Link “On” which was “Off” by default.