Google assistant on Sonos one needs to know device to play on

  • 27 February 2023
  • 1 reply

All ot the sudden.  One of my Sonos one devices no longer plays music when I ask it to on the Google Assistant. It says I must tell it what device to play it on. It never did this before and it's obviously kind of stupid since it is obviously the device I want to play it on. I thought the fix would be to pair the Sonos one as its own speaker but I can't find that option in Google home. I can for other rooms where I have legacy Sonos devices paired with Google home devices. But when it's all integrated in one thing I can't seem to figure out how to make it default to playing on itself anymore?


Best answer by Corry P 28 February 2023, 11:50

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

1 reply

Userlevel 7
Badge +18

Hi @Kirkjt 

Welcome to the Sonos Community!

If rebooting the device by removing power for a moment does not help, please try the following:

First, please remove Google Assistant from that particular Sonos One. Settings » Services & Voice » Google Assistant » [room name] » Remove Google Assistant.

Next, follow these steps to unlink that particular device from Google Assistant:

  1. On your iOS or Android device, open the Google Assistant app. (Google Home app can also be used, though steps below will differ slightly)
  2. Tap the user icon in the top right hand corner.
  3. Scroll down and select the Devices option.
  4. Tap on the relevant Sonos device listed and select Unlink at the bottom of the options.

Now, in the Sonos app once more, add Google Assistant to the speaker. Settings » Services & Voice » Add a Voice Assistant » Google Assistant and follow the on-screen prompts.

When finished, please test implicit commands (where you don’t reference the room name). If they still don’t work, there is a more involved process whereby we would unlink all Sonos devices and also remove your Sonos account from Google, then set it all up again. Repeat the above steps, and at step 4 of unlinking devices, unlink all Sonos devices then follow these steps to remove the Sonos account:

  1. Open a Web Browser and visit
  2. Click the user's picture in the top right, and select Manage your Google Account. If the account is not signed in, first sign in, then attempt this step.
  3. Ensure you see the Home tab on the left, then select Security from the options.
  4. Select Linked Accounts under Signing in to other sites.
  5. Look under Linked accounts and see if there is a selection called Sonos. If there is, click on the Unlink button to remove the access.

Once all Sonos devices and the account are unlinked from Google, add Google Assistant to the Sonos One once more (as described above) and that process will automatically link your Sonos account back to Google.

I hope this helps - if not, or if you require guidance, I recommend you get in touch with our technical support team for assistance.