Answered

Cannot enable Microphone on two Sonos Beams

  • 6 February 2022
  • 7 replies
  • 79 views

Badge

Hi,

I've been trying to set up Google assistant on my two Beams.

Neither of them allow me to turn the Microphone on.

I have successfully added Google assistant to my Sonos One.

Although I can turn the Microphone on for my Move, I cannot add the Google assistant to it either.

Any tips would be greatly appreciated before I submit a support ticket.

All of my speakers software have been updated.

Thanks.

icon

Best answer by Doovy 6 February 2022, 02:26

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

7 replies

Switch off auto-TruePlay on your portable Sonos device before adding your Google Assistant and see if that works for you. Then try the two Beams aswell.

Badge

Switch off auto-TruePlay on your portable Sonos device before adding your Google Assistant and see if that works for you. Then try the two Beams aswell.

There is no Treuplay option for the two Beams…
It did not work for the Beam unfortunately...

Did it work for the Move?

I would check for any Sonos updates and then try a power off/on for the Beam (leave them off for a minute or two) and if practicable, maybe even cable them to the LAN temporarily to see if that solves the GA setup issue. If not try a reboot of the router/network and then try again.

Badge

Ok, found out that the issue was to do with Google Home settings - I have not used Google Home for years and there were old settings/rooms that probably conflicted with the new speakers.

They are all working now as far as Mic button and Google assistant is concerned…

However I will now try to troubleshoot why when I say “Hey Google, play music”, it opens Spotify but then replies to say that the media service is not connected...

Ok, found out that the issue was to do with Google Home settings - I have not used Google Home for years and there were old settings/rooms that probably conflicted with the new speakers.

They are all working now as far as Mic button and Google assistant is concerned…

However I will now try to troubleshoot why when I say “Hey Google, play music”, it opens Spotify but then replies to say that the media service is not connected...

Ah glad you’re getting there 👍 - it sounds like you need to next ensure that your chosen default music service (presumably Spotify) is set as the default service for the Google Home and that the same Spotify service/login-credentials are also added to your Sonos App. Note it requires a paid subscription service to work on Sonos. Spotify free will not work for playback using GA.  

Badge

yes Spotify (paid sub) is set as the default, this was working before the fix ironically haha