Answered

Cannot add google assistant anymore.

  • 26 December 2019
  • 20 replies
  • 10183 views

Userlevel 2

I have tried to add Google Assistant to my Sonos One’s, but it gets stuck trying to link the account in the mobile ios app.  I used to be able to set it up easily, but it is no longer the case.  I switched to Alexa for a time, but I would now like to go back to using google on my Sonos speakers. It appears the Sonos app will no longer directly communicate with the Google assistant app when trying to set up the voice assistant.  It will link over to the app store to open the app, but never affects any change to the google assistant app when you open it.  Meanwhile, the sonos app gets stuck in an endless loop waiting for authorization and finally times out and gives an error message: “There was a problem adding Google Assistant” with an option to “Try again”.  I can link the Sonos speakers directly in the Google Assistant app, but Sonos does not seem to recognize it.  I have tried every combination of work arounds I can think of, linking and unlinking, but it currently will not add.  I read another discussion, which stated that unlinking all music accounts would help, but it made no difference.  Another discussion stated it may be ios 13 changes, which makes sense to me.  I did not see any resolution for the issue though.  I tried using the windows controller app, but it does not seem to be able to have the functionality to add GA.  I do not have any Android mobile devices.  Has anyone else had this problem.  Does anyone know how to resolve this?

icon

Best answer by Lefty777 26 December 2019, 16:23

I got it to work finally!  If you copy the linking address from Safari and change it, it works. 

This was a solution on another discussion:

 

Copy the URL from safari and edit it somewhere else.

If you have it like this:

https://assistant.app.goo.gl/?ibi=com.google.OPA&isi=YYYYYYYYY&ius=googleassistant&efr=1&link=https%3A%2F%2Fassistant.google.com%2Fdevice%2Fhelp%3Fprovider%3Dsonos-XXXXXXX%26unlink%3Dsonos-XXXXXX%26music%3Dtrue%26return_url%3Dhttps%3A%2F%2Fwww.sonos.com%2Fapp%2Fpartners%2Fgoogle%2Fservices%2Fvoice%2Fsetupcomplete

 

Change it to: 

googleassistant://device/help?provider=sonos-XXXXXXXX&unlink=sonos-XXXXXXXX&music=true&return_url=https://www.sonos.com/app/partners/google/services/voice/setupcomplete

 

Replace XXXXX with whatever the numbers/letters you have on your end.

View original

20 replies

Try uninstalling and reinstalling the Google Assistant App on your mobile Controller device and after logging back into the Google Home, give it a try again through the Sonos App “Settings/Services/Voice”.

Userlevel 2

I tried doing that.  I also tried using the Google Home App as well.  Did not work.  Thanks though.

Userlevel 2

I got it to work finally!  If you copy the linking address from Safari and change it, it works. 

This was a solution on another discussion:

 

Copy the URL from safari and edit it somewhere else.

If you have it like this:

https://assistant.app.goo.gl/?ibi=com.google.OPA&isi=YYYYYYYYY&ius=googleassistant&efr=1&link=https%3A%2F%2Fassistant.google.com%2Fdevice%2Fhelp%3Fprovider%3Dsonos-XXXXXXX%26unlink%3Dsonos-XXXXXX%26music%3Dtrue%26return_url%3Dhttps%3A%2F%2Fwww.sonos.com%2Fapp%2Fpartners%2Fgoogle%2Fservices%2Fvoice%2Fsetupcomplete

 

Change it to: 

googleassistant://device/help?provider=sonos-XXXXXXXX&unlink=sonos-XXXXXXXX&music=true&return_url=https://www.sonos.com/app/partners/google/services/voice/setupcomplete

 

Replace XXXXX with whatever the numbers/letters you have on your end.

Hey There,

 

Having the same problem. Every time I click on “Go to Google Assistant app” it takes me to the app store instead of directly to the app. I’ve already downloaded the app so I would think it would go directly to the app and open it up. 

 

Any help would be greatly appreciated.

Badge

I got it to work finally!  If you copy the linking address from Safari and change it, it works. 

This was a solution on another discussion:

 

Copy the URL from safari and edit it somewhere else.

If you have it like this:

https://assistant.app.goo.gl/?ibi=com.google.OPA&isi=YYYYYYYYY&ius=googleassistant&efr=1&link=https%3A%2F%2Fassistant.google.com%2Fdevice%2Fhelp%3Fprovider%3Dsonos-XXXXXXX%26unlink%3Dsonos-XXXXXX%26music%3Dtrue%26return_url%3Dhttps%3A%2F%2Fwww.sonos.com%2Fapp%2Fpartners%2Fgoogle%2Fservices%2Fvoice%2Fsetupcomplete

 

Change it to: 

googleassistant://device/help?provider=sonos-XXXXXXXX&unlink=sonos-XXXXXXXX&music=true&return_url=https://www.sonos.com/app/partners/google/services/voice/setupcomplete

 

Replace XXXXX with whatever the numbers/letters you have on your end.

This worked for me, thanks! Brilliant detective skills there. It’s an impressive fail for Sonos to break the ability to set up Google Assistant right over the Christmas period 😂

I got it to work finally!  If you copy the linking address from Safari and change it, it works. 

This was a solution on another discussion:

 

Copy the URL from safari and edit it somewhere else.

If you have it like this:

https://assistant.app.goo.gl/?ibi=com.google.OPA&isi=YYYYYYYYY&ius=googleassistant&efr=1&link=https%3A%2F%2Fassistant.google.com%2Fdevice%2Fhelp%3Fprovider%3Dsonos-XXXXXXX%26unlink%3Dsonos-XXXXXX%26music%3Dtrue%26return_url%3Dhttps%3A%2F%2Fwww.sonos.com%2Fapp%2Fpartners%2Fgoogle%2Fservices%2Fvoice%2Fsetupcomplete

 

Change it to: 

googleassistant://device/help?provider=sonos-XXXXXXXX&unlink=sonos-XXXXXXXX&music=true&return_url=https://www.sonos.com/app/partners/google/services/voice/setupcomplete

 

Replace XXXXX with whatever the numbers/letters you have on your end.

Thanks - very useful and work for me 👍

Userlevel 2

Thanks! It now worked for me.

However, I got different XXXXX when connecting on my Iphone and Ipad (Iphone added XXXXX%26), and it was only the shorter XXXXX from the Ipad that worked.

Userlevel 1

Clear your browser's catche and cookies, that happened to me trying to link spotify and that worked, it may work that way too 

I got it to work finally!  If you copy the linking address from Safari and change it, it works. 

This was a solution on another discussion:

 

Copy the URL from safari and edit it somewhere else.

If you have it like this:

https://assistant.app.goo.gl/?ibi=com.google.OPA&isi=YYYYYYYYY&ius=googleassistant&efr=1&link=https%3A%2F%2Fassistant.google.com%2Fdevice%2Fhelp%3Fprovider%3Dsonos-XXXXXXX%26unlink%3Dsonos-XXXXXX%26music%3Dtrue%26return_url%3Dhttps%3A%2F%2Fwww.sonos.com%2Fapp%2Fpartners%2Fgoogle%2Fservices%2Fvoice%2Fsetupcomplete

 

Change it to: 

googleassistant://device/help?provider=sonos-XXXXXXXX&unlink=sonos-XXXXXXXX&music=true&return_url=https://www.sonos.com/app/partners/google/services/voice/setupcomplete

 

Replace XXXXX with whatever the numbers/letters you have on your end.

 

 

VERY helpful!  Thanks!!!!  This worked!

I got it to work finally!  If you copy the linking address from Safari and change it, it works. 

This was a solution on another discussion:

 

Copy the URL from safari and edit it somewhere else.

If you have it like this:

https://assistant.app.goo.gl/?ibi=com.google.OPA&isi=YYYYYYYYY&ius=googleassistant&efr=1&link=https%3A%2F%2Fassistant.google.com%2Fdevice%2Fhelp%3Fprovider%3Dsonos-XXXXXXX%26unlink%3Dsonos-XXXXXX%26music%3Dtrue%26return_url%3Dhttps%3A%2F%2Fwww.sonos.com%2Fapp%2Fpartners%2Fgoogle%2Fservices%2Fvoice%2Fsetupcomplete

 

Change it to: 

googleassistant://device/help?provider=sonos-XXXXXXXX&unlink=sonos-XXXXXXXX&music=true&return_url=https://www.sonos.com/app/partners/google/services/voice/setupcomplete

 

Replace XXXXX with whatever the numbers/letters you have on your end.

I’m shocked this bug popped up in a recent update of Sonos controller (QA?). But thank you for the tip! 
 

I found it easiest to pre-copy the “good” url above to Notes, then replace the XXXXXX values with the numbers found in the “bad” url Sonos pushes into Safari, then copy/paste the new “good” url from Notes to Safari. 
 

Note this has to be repeated for each speaker being activated with Google Assistant, even if “select all” was used to activate all at once. Which means repeated pasting of the good url into safari. BUT, it DOES work! Thank you again!

Userlevel 1
Badge

For me the solution was to use my wife’s phone and google account to register the Sonos with Google Assistant. It allowed me to then still login with my Sonos Account. When I tried my own Google Account it wouldn’t let me proceed. 
 

These two speakers already had google assistant at one point but randomly lost connection to google assistant one day without any discernible cause. I tried for months to get them connected back to Google Assistant with no success. Finally when I tried from my wife’s phone and google account it let me do it! 

Hey guys, I may be missing someting here, however, I’m not sure where to find the numbers which should be included in the URL string? 

 

I’m usng an iPhone10 and chrome. When in the app, it sends me directly to google assistant, not to the browser…. 

Hey guys, I may be missing someting here, however, I’m not sure where to find the numbers which should be included in the URL string? 

 

I’m usng an iPhone10 and chrome. When in the app, it sends me directly to google assistant, not to the browser…. 

Same here. The solution is so close! 

Hey guys, I may be missing someting here, however, I’m not sure where to find the numbers which should be included in the URL string? 

 

I’m usng an iPhone10 and chrome. When in the app, it sends me directly to google assistant, not to the browser…. 

Same here. The solution is so close! 

On iOS, it does send you to the browser but you might not have noticed. Once the google assistant app opens, just browse through your open apps to see your browser with the URL in it. Every time I went to the browser it triggered the google assistant app to open - but after 3 times it gave up on me and I could copy the URL from the browser URL bar. 

I e-mailed the URL to my PC, changed the "xxxxx” numbers described above, e-mailed it back to my phone and clicked it. It then continued via the google assistant app but this time finished successful, yay!

Badge

Is this so called integration between Sonos & Google Home devices s joke?  

IT DOES NOT WORK - Waste of time & effort, easier to use a middle man service like IFTT to get something working between the two.

Badge

I have the same problem, it works fine to set up my Beam, but NOT my Move. I’ve tried everything. I’m furious, this should be simple!!

Badge

Total nightmare - never been able to add Google assistant, it just seems like everything is hard work with Sonos, even initial setup of up speakers over wifi can be right royal pain in the arse.

Hardware great, software and integration lacking IMO

For anyone still having this issue if you install Chrome on your phone/iPad it will work !

The solution for iOS users are to not let google assistant take you back to Sonos as the internal link used is broken (yeah, over year and a massive rewrite Requiring a whole new app installed and this is still not fixed. Very concerning).

 

So from Sonos, start the install and it takes you to google assistant. There walk through the whole setup and when it gives you the demo page and you can press done then double click on home button to bring up all active apps, locate Sonos and swipe it up to force exit. Now google assistant have registered Sonos and the Sonos app too next time you start it. When you go back from google to Sonos by link it gets a broken code and then rolls back the setup despite it having been successful. 
 

it’s a shame the software part of Sonos is so mismanaged given that the speakers are so nice. 

The solution for iOS users are to not let google assistant take you back to Sonos as the internal link used is broken (yeah, over year and a massive rewrite Requiring a whole new app installed and this is still not fixed. Very concerning).

 

So from Sonos, start the install and it takes you to google assistant. There walk through the whole setup and when it gives you the demo page and you can press done then double click on home button to bring up all active apps, locate Sonos and swipe it up to force exit. Now google assistant have registered Sonos and the Sonos app too next time you start it. When you go back from google to Sonos by link it gets a broken code and then rolls back the setup despite it having been successful. 
 

it’s a shame the software part of Sonos is so mismanaged given that the speakers are so nice. 

This actually worked guys, spent like the whole afternoon trying to figure this out.

Reply