Answered

Sonos unable to play podcasts imported from Google podcasts to You Tube Music library

  • 12 February 2024
  • 3 replies
  • 72 views

Google is closing Google Podcasts April, 2024. Google suggests moving your podcast subscriptions to You Tube Music. So I did.
Now, my podcasts are in my You Tube Music library, and I can play them from there. The podcasts also show up in YTM library on the Sonos app. But the Sonos app can not play them. When I try to play one, the Sonos app balks, and a slide-up message says “Unable to play [name of podcast episode] -the connection to You Tube Music was lost.” 
Other YTM  items - songs, playlists, etc., play through fine. And Sonos plays podcasts which were added to my YTM library from within YTM. Only the podcasts imported from Google Podcasts to my YTM library are affected. I suspect this is a Google problem, although it is unclear why the podcasts play in YTM but not in Sonos. Any insights?

icon

Best answer by Jamie A 13 February 2024, 15:42

View original

3 replies

Userlevel 7
Badge +15

Hi @verivali,

I’ve seen another user mention a similar issue, which I raised with our internal team. After a quick test, they are able to play Podcasts from YTM, so this may be another issue or it could be with specific YTM music accounts or a regional issue.

I would recommend reaching out to our support team for further testing and troubleshooting, as they have tools available to look into your system to see why Podcasts aren’t playing.

I hope this helps!

Google is closing Google Podcasts April, 2024. Google suggests moving your podcast subscriptions to You Tube Music. So I did.
Now, my podcasts are in my You Tube Music library, and I can play them from there. The podcasts also show up in YTM library on the Sonos app. But the Sonos app can not play them. When I try to play one, the Sonos app balks, and a slide-up message says “Unable to play [name of podcast episode] -the connection to You Tube Music was lost.” 
Other YTM  items - songs, playlists, etc., play through fine. And Sonos plays podcasts which were added to my YTM library from within YTM. Only the podcasts imported from Google Podcasts to my YTM library are affected. I suspect this is a Google problem, although it is unclear why the podcasts play in YTM but not in Sonos. Any insights?

I have exactly the same problem. Premium member from Norway 

Not sure what a ’premium member’ means, is that in reference to YouTube, or in reference to Sonos? More importantly, what did Sonos Support say, when you contacted them?

Reply