Answered

Sonos Desktop Issues with Sophos


Userlevel 1

Since I’ve tried customer service with both Sonos and Sophos, I thought I’d put this out there for any suggestions/wisdom.

Macbook Pro, running 10.13OS, Sonos 1 Desktop App and Sophos Home Premium 10.0.4 (and have had the same setup for some time with no issues).

While the Sonos desktop app will show connection to the system when checking “connect to existing Sonos system”, it never gets past the main screen error message “Sorry, we can’t connect to Sonos”.  Mobile apps work fine (all on the same wi-fi network).

Turning off Sophos does not change anything, but uninstalling it brings Sonos back (and reinstalling permits it for a day, then the issue returns).

Obviously, these two aren’t playing nicely together - again, I’ve been trying to get help on both ends. Any thoughts appreciated.

 

icon

Best answer by carbmac 7 May 2021, 15:03

UPDATE : Solution I got from Sophos works.  So here are the steps (as per Sophos email) :

 

==//==

 

Thank you for contacting Sophos Home support. 

I understand you are having difficulty connecting to your Sonos wireless speakers.

We recently saw this issue with another customer and found the following resolution.

1. Locate the IP address of the speakers
2. Add the IP address as a Web Exception by
- Log in to your Sophos Home Dashboard
- Navigate to the "Protections" tab and the "Web"
- Add the IP of the speakers as a web exception
- Add the local loopback address (this is essentially your computer IP address from the computer's perspective) of

  127.0.0.1

3. Wait for a few minutes for the software to sync and test.

==//==

The IP of each of your speaker can be found on your gateway management software (could be an iOS or other app, or a website).  

If you have an xFinity or Helix gateway, goto the web page management, under connect, scroll to your Sonos speaker, click on the first one and then, at the bottom, click on device details.  The IP address is in the popup.  That’s the IP you have to add along with 127.0.0.1.  Do that for each and every speaker in your Sonos setup.

 

 

I hope this helps you and others !

 

Ray

View original

28 replies

Honestly, no experience at all with Sophos, but it sounds to me like your Mac may occasionally be on a different network/node than your main Sonos connection is. Do you happen to be running any WiFi extenders, a mesh network, or anything equally unusual in your your network? And what is the make and model of your router? How are  both the Sonos and Mac connected to your network?

Userlevel 1

Both devices are connected via wi-fi to a Deco TP-Link router (no mesh network).

Huh. Nothing springs immediately to mind, so a few suggested tests, to see if the issue can be more accurately identified. 

These are all up to you, and whether you can do them…. first, check to be sure the Router’s firmware is up to date. Next, try linking both the Mac and the Sonos to the router with Ethernet cables, and see if the error continues to be reproducible. That will certainly go a ways to identify if there could be some wifi interference , although not a duplicate IP address. In fact, that, while being an extremely slight possibility, wouldn’t hurt to check. Just unplug all Sonos devices from power, then reboot the router. Once the router comes back up, plug the Sonos back in.

But there’s no guaranty here, it still could be some sort of intermittent wifi interference while they’re not wired, so it’s certainly worth reading the linked FAQ.

But if it continues, after checking those possibilities, I would recommend that you submit a system diagnostic within 10 minutes of experiencing this problem, and call Sonos Support to discuss it.

There may be information included in the diagnostic that will help Sonos pinpoint the issue and help you find a solution.

When you speak directly to the phone folks, there are more options available beyond just the diagnostic analysis.

Userlevel 1
Badge

Since yesterday morning, I’ve started to have the same problem.  I also am running Sophos on my iMac and Macbook.  Both of which now can’t connect to my 3 Sonos speakers from the desktop app.

 

Tried the usual, with no success :

  • Reboot Gateway (xFinity XB6)
  • Uninstall Sonos 2 controller app (with App Cleaner) and reinstalled it, no success
  • Verified the Firewall settings on my to make sure Sonos is a recognized and authorized app (was there already)
  • Rebooted my iMac, Macbook. No luck.
  • Checked on my partner’s Macbook : it worked there. He’s running macOS Big Sur, I’m on Catalina (10.15).  Both with Sophos, however.
  • Checked on a Dell laptop.  Worked there as well.

 

Went to Sophos and deactivated Web Protection and after that, Mac desktop controller worked again.  Re-enabled Web Protection, stopped working.  Something is wrong with Sophos, but it would seem to be on at specific user level - meaning it’s blocking me, but it’s allowing my partner (we’re living in the same house). 

This needs further investigation.  I will try to contact Sophos with my findings.
 

 

Userlevel 1
Badge

Follow up : I’ve opened a ticket with Sophos, detailing my findings.  I will update again once I get an answer from them.

Userlevel 1
Badge

UPDATE : Solution I got from Sophos works.  So here are the steps (as per Sophos email) :

 

==//==

 

Thank you for contacting Sophos Home support. 

I understand you are having difficulty connecting to your Sonos wireless speakers.

We recently saw this issue with another customer and found the following resolution.

1. Locate the IP address of the speakers
2. Add the IP address as a Web Exception by
- Log in to your Sophos Home Dashboard
- Navigate to the "Protections" tab and the "Web"
- Add the IP of the speakers as a web exception
- Add the local loopback address (this is essentially your computer IP address from the computer's perspective) of

  127.0.0.1

3. Wait for a few minutes for the software to sync and test.

==//==

The IP of each of your speaker can be found on your gateway management software (could be an iOS or other app, or a website).  

If you have an xFinity or Helix gateway, goto the web page management, under connect, scroll to your Sonos speaker, click on the first one and then, at the bottom, click on device details.  The IP address is in the popup.  That’s the IP you have to add along with 127.0.0.1.  Do that for each and every speaker in your Sonos setup.

 

 

I hope this helps you and others !

 

Ray

Userlevel 7
Badge +15

Nice one @carbmac, thanks for following up and sharing your findings! 

 

I’ve gone ahead and marked your steps as the best answer to the topic so people experiencing similar issues can find the solution easier :slight_smile:

Userlevel 1
Badge

Glad I could help :)

 

Have a great weekend (mine will be full of music.. hehe!)

If only I had stumbled across this post a few hours earlier it would have saved me a lot of time and pounding of my head on my desk. I tried everything imaginable from rebooting my router, my Sonos speakers, disabling LittleSnitch and pf firewall on my Mac, etc. to try and fix why, literally overnight, my Desktop Controller suddenly could not see “the system” anymore. At one point I too ran it from another machine running 11.0 (Big Sur) and discovered the app ran fine. So I knew -something- had to be suddenly causing this on my desktop running 10.15 (Catalina). Finally on a whim I decided to disable Sophos Home’s web filtering option and nearly fell out of my chair when it started working.

To say this -shouldn’t- be happening is an understatement. Especially since these two apps have been co-existing for years. Clearly Sophos pushed some kind of functionality update (this isn’t likely a “signature” problem) and changed (I say “broke”) something with its proxy/filter service related to local /non-routable network addresses. 

Thanks to carbmac (Ray) for posting their suggested “solution” which should really be a work-around until they fix their damn code. >:-(

Userlevel 1
Badge

UPDATE : It’s been almost a couple of weeks and it’s still working for me.  Though, occasionally, you’ll notice that when launching Sonos desktop client, the interface will show up but it’ll take a long time before it actually connects to your speaker or speakers.  9 out 10 times, it takes only 2-4 seconds.  But on that 10th time, it can take up to 30-40 seconds.

Badge

I spent over an hour with Sonos Support and eventually worked out that it was Sophos Home, Web Protection that was stopping the Sonos Controller (Apple Mac OS 10.15.7) from connecting to my Sonos speakers.  I have now added the IP address of all my speakers to the web exceptions and everything is working once again.  Thank you for the guidance.  I have emailed Sonos support and suggested they add this to their diagnostics/troubleshooting database.  

Thanks carbmac. I’m sorted and happy boy.

Running Mac OS Catalina and Sophos Home. My Sonos S1 Controller app has suddenly stopped working. I have installed all the IP Addresses for the Sonos speakers in Sophos, but still not working. 

I have followed all the ideas here, but still not working.

Can anyone help please.

Userlevel 1
Badge

Running Mac OS Catalina and Sophos Home. My Sonos S1 Controller app has suddenly stopped working. I have installed all the IP Addresses for the Sonos speakers in Sophos, but still not working. 

I have followed all the ideas here, but still not working.

Can anyone help please.

Can you use the Sonos app on a smartphone or tablet ?  If so, continue trouble shooting, but at least, you’ve a workaround now.

Is your system compatible with Sonos S2 ?  Try to download and configure that version, see if this fixes your issue.

Else, you could try to disable Sophos for a brief moment, then check if your Sonos S1 can control your Sonos speakers.  If so, then first enable Sophos again and contact them.  They might have a few more tricks up their sleeves they could offer you.

 

Cheers,

 

Ray 

Happy I found this thread. Big thanks to  @carbmac for the information.  Sophos Home was the blocker and the fix worked for me.

Tip: start by just turning off the Sophos Web Protect setting (“Block websites that are known to have malware.”) and see if this resolves the problem.  I did and lo and behold the controller instantly connected. 

Then add the IP addresses as exceptions as per the post (but be aware that as they may be assigned by DHCP they might change over time) and turn protection back on.  

Then exit Sonos controller and re-open.  As stated it may take longer than usual to connect but wait a bit.  It should all then connect OK.

Thanks again.

 

Userlevel 1
Badge

 

Happy I found this thread. Big thanks to  @carbmac for the information.  Sophos Home was the blocker and the fix worked for me.

Tip: start by just turning off the Sophos Web Protect setting (“Block websites that are known to have malware.”) and see if this resolves the problem.  I did and lo and behold the controller instantly connected. 

Then add the IP addresses as exceptions as per the post (but be aware that as they may be assigned by DHCP they might change over time) and turn protection back on.  

Then exit Sonos controller and re-open.  As stated it may take longer than usual to connect but wait a bit.  It should all then connect OK.

Thanks again.

 

Another satisfied customer ;-)

 

Disclaimer : I don’t work for either Sophos or Sonos.  

Thank you for all the advice. Having tried all suggestions, I took the drastic step of deleting the Sophos software, and have now installed a new anti-virus software (TotalAV). Sonos S1 Controller on my MAC is now working again. Problem solved.

DavceTheSave

 

Many thanks for sharing that….been driving me nuts for too long! 

I’m sure none of the logs flagged it up!

Userlevel 1
Badge

I was hopeful the above would work for me as this issue has been plaguing me for last couple of months.  Unfortunately, this fix did not work for me.  I’ll have to reach out to Sophos.  For now, I just have to disable all protection with Sophos when I want to use controller on my Mac.  Very frustrating.  I have a Sonos Bridge and wondering if that is impacting this work around. Hope they fix this soon :(

Userlevel 1
Badge

I was hopeful the above would work for me as this issue has been plaguing me for last couple of months.  Unfortunately, this fix did not work for me.  I’ll have to reach out to Sophos.  For now, I just have to disable all protection with Sophos when I want to use controller on my Mac.  Very frustrating.  I have a Sonos Bridge and wondering if that is impacting this work around. Hope they fix this soon :(

I know nothing about the Sonos Bridge, but it makes sense to have to add its IP address as well in Sophos.

Userlevel 1
Badge

Thanks for the reply carbmac.  I am still struggling with this.  After not being able to enter in the IP addresses in Safari for some reason I had luck with Chrome.  On the positive, the app does now open but  functionality is clunky.  Volume control not working for  some speakers in a group, master play/pause is greyed out at top of controller and “now playing” shows nothing when I choose a Sirius channel to play to name a few issues now.  I am actually considering removing Sophos home at this point and trying an alternative (any ideas).  I reached out to Sophos and they are trying to help but going slow.  They also indicated they do not know when this is going to be fixed.  Any help or thoughts always appreciated.

Userlevel 1
Badge

Thanks for the reply carbmac.  I am still struggling with this.  After not being able to enter in the IP addresses in Safari for some reason I had luck with Chrome.  On the positive, the app does now open but  functionality is clunky.  Volume control not working for  some speakers in a group, master play/pause is greyed out at top of controller and “now playing” shows nothing when I choose a Sirius channel to play to name a few issues now.  I am actually considering removing Sophos home at this point and trying an alternative (any ideas).  I reached out to Sophos and they are trying to help but going slow.  They also indicated they do not know when this is going to be fixed.  Any help or thoughts always appreciated.

Just to make sure, in the list of exceptions, you do see all your Sonos speakers and the Sonos bridge, and 127.0.0.1, is that it  ?

Just to rule out any other cause, have you tried to temporarily disable Sophos ? From Sophos Dashboard, pick your device, then Protection / General and turn Real Time Protection OFF.  Wait for a minute or two, then launch Sonos app again.  Then, see if this is working (or not).  If it’s working, then you know something is wrong with Sophos and your Sonos setup.  If it’s still doesn’t work, issue might on the Sonos side of the equation.

As for other antivirus, I was using BitDefender prior to moving to Sophos.  But every now and then, one of its process will spike usage of the CPU and either bring my iMac (2019) to a crawl, or make the fan run like mad.  Tried to find a solution with BitDefender, didn’t get any (it’s a know issue and let it run, it’ll eventually stop…  is not a satisfactory answer).  That being said… BitDefender is working wonderfully for others.  YMMV.

Userlevel 1
Badge

Hello - So I did disable just “web protection” and everything worked fine.  I then went back into my fios gateway to compare my web exception listing in Sophos to the “sonos zp” ip addresses and sure enough I had 2 that were missing. I added those to “web exceptions” listing in Sophos and re-enabled “web protection”, closed and then opened Sonos controller and things seem to be working well now but want to give it a couple of days.  Thank you carbmac

Userlevel 1
Badge

Woohoo!!  Another satisfied customer :)

 

Have a good day and Happy 4th of July (if this applies to you)

Userlevel 1
Badge

Woohoo!!  Another satisfied customer :)

 

Have a good day and Happy 4th of July (if this applies to you)

Thank you again carbmac.  Two weeks in and rock solid now.  Side note - Sophos customer service was

very attentive throughout my case so I have to give

them kudos for customer service.  Unfortunately,

they do not know when a permanent fix will be available for this.  

Reply