Phone no longer reconnects to Sonos when in range

  • 4 December 2018
  • 22 replies
  • 301 views

Badge
Recently I've noticed that my phone (android) no longer reconnects to Sonos when in range. (eg, when I come back home). I noticed it a couple of updates ago, hoping it would be fixed, but not yet - hence the post:

Basically, in the past, with the android app, the controls are persistently in the notification area (or the lock screen), allowing you to control the speakers as expected. Even if you went out of range, it would pick up where you left off when returning home.
Not any more.
Now you have to load up the app back up each time to get the controls to show up in the notification area. Very annoying.

Sonos Bridge, 2x Play1, 1x Play3
Sony Xperia Z5 compact
Everything is up to date.
I've tried a reinstall, and resetting my Sonos set up.

Anyone else experiencing this?

22 replies

Userlevel 7
Badge +18
Hi, Rudie. I'm not sure if it's so much an issue of the controller not reloading in general, as it is the notification display not updating to reflect what's going on in-app. Something may have changed in that regard. How long has this been going on? Have you tried uninstalling and reinstalling the application?
Badge
Hi Edward
It's been going on I'd say for a couple of months or so.
I've tried reinstalling the app.
Badge
Bump

Another app update today, still not fixed
Userlevel 7
Badge +22
Are you on the latest Android version? Android: 5.0 and higher
Badge
Yes
Version 7.1.1
I guess the thing that's striking me as a possibility is more that the phone isn't connecting to your wifi... The phone shouldn't be connecting to the speakers, they're connected to your wifi. Might be worth trying a delete of your wifi credentials in the phone, then a hard reboot, and add connect the phone back to your wifi signal.
Badge
Thanks for your reply.
The problem isn't with the WiFi, it is the fact the app doesn't automatically kick back in when the phone reconnects to the WiFi.

Nevertheless, I have tried what you said just to be sure, but still no luck.
Userlevel 4
Badge +10
I have noticed the same issue. On a Samsung Galaxy S7. When returning home the lock screen would display the simple Sonos controls and the currently playing info. Now it doesn't.

To be honest, I changed my power settings at about the same time, so I just assumed it was the phone shutting down the app when I left home.
Sorry I can't be of any particular help, then. I can't make any logical conclusions on the process failing.
Badge
The phone is really not getting connected to the Sonos in the range and that is also happening because the system is not verified as I have to make the syncing process of the email and I had to recover gmail password then the system will get connected to the Sonos.
Badge
The phone is really not getting connected to the Sonos in the range and that is also happening because the system is not verified as I have to make the syncing process of the email and I had to recover gmail password then the system will get connected to the Sonos.

Sorry, this makes no sense :?
Badge
bump
Userlevel 7
Badge +21
Although I don't think this is the problem, I'd check the notification settings on your phone.

I have an android phone, and I think I also see the issue that you're talking about, but it honestly doesn't bother me much, and I've never really depending on the functionality. When it's there, I use it. When it's not, I don't. There have definitely been times where it automatically showed up (after starting music elsewhere) and times where I wanted to make an adjustment and it wasn't there. I've never spent to much time looking into it.

Just guessing, but did your usage patterns of your phone change at all. Perhaps you're using another music app on your phone more frequently? Although I have seen 2 music apps in the notification display at the same time, I've never seen Sonos and a music app at the same time. I could see where Google decides not to display the Sonos playback notification if a different app currently 'has the focus', or priority. It would make sense if changing the volume using the phones volume buttons is currently sent to change the volume in the music app.

I'm totally guessing here, but I suspect the reason has more to do with how you're using other apps on your phone that may interfere, or perhaps an android update changed how the operation works slightly.
Badge
I appreciate you taking time to reply Danny.

I am really not a prolific phone user, I only have the bare minimum apps on my phone, and certainly cannot think of any apps that may be causing conflict. (tbh, I can't even remember the last time I installed a new app on my phone).

Therefore, I don't think the way my I use my phone is a factor. It's also worth noting that all hardware involved, including the location of the speakers and router, remains unchanged.

This is maybe why it is so frustrating for me, that every day I need to load up the Sonos app to get the notification controls to show.

😠
This is maybe why it is so frustrating for me, that every day I need to load up the Sonos app to get the notification controls to show.
Running the Sonos app in the background all the time is required for the notification to show up when the phone gets reconnected with your WiFi. At the cost of potentially draining the battery.
Rudie,

You could perhaps try the IFTTT App and set a trigger to either simply start an action to set a volume on one of your Sonos Speakers to see if that causes the Sonos App to spring back to life. (See screenshot which shows that is possible), or you can even create an IFTTT action to play some music on one of your Sonos speakers as you arrive home. This is providing you use location services on your mobile device. There are lots of IFTTT Sonos Applets for you to explore with a variety of triggers and actions for your Sonos speakers.

That will save you draining your battery as described above by Smilja.
Badge
Once the Sonos app is loaded, it can be immediately closed, and the controls will remain in the notification area.
This is expected behaviour, and has been in the many years since I've owned the system.

99% of the time I listen to the radio, so opening the app isn't something I do often. Hence the play/pause/volume from the notification or lock screen is sufficient.

The point is, that when I go out of range and return, the notification controls should show back up.
Unless the Sonos app no longer works in this way...

This is precisely why in my initial question, I wanted fellow android users to confirm if this is a common issue.
Maybe a Sonos member of staff can shed some light?
Userlevel 4
Badge +10
It would be nice to know. My phone is still operating in exactly the same way as Rudie is describing. If I lave the house, when I return the phone is not automatically connecting to Sonos. This is slightly annoying as I often just hit play or pause on my phones lock screen controls, now I have to unlock the phone, start the app, then hit the control. Before the basic controls were always there. It's definitely a first world problem, but I would be a smidge happier if it still reconnected like it used to.
Badge
Bump
^ Legnum Nick gets it ^

Although it wouldn't say it's a first world problem – anything relating to smart speaker system is first world. IMO it's part of the basic functionality of the system that I am (was) used to.

Anyone from Sonos care to comment?
Badge
bump
Userlevel 7
Badge +20
Bump
^ Legnum Nick gets it ^

Although it wouldn't say it's a first world problem – anything relating to smart speaker system is first world. IMO it's part of the basic functionality of the system that I am (was) used to.

Anyone from Sonos care to comment?


Hi Rudie,

I'm not aware of any known issue around this, but I think it would be best to have our phone team take a look, and escalate the case if needed. Please give us a call, you can find our number here.
Badge
i've had sonos a few years now, and presumed this was the way it was supposed to be.. always been like this for me. Once i've left my wifi I have to open the app to gain control again on returning home. Frustrated now I know it doesn't have to be this way.

Reply