fixed - iPhone not recognizing system on S2 app after iOS14 update

  • 27 October 2020
  • 14 replies
  • 358 views

I’ve managed to resolve my issue with the Sonos app not finding the system over WiFi after updating iPhone to IOS14. Posting it in case it helps anyone else struggling with this issue. All other solutions I found online ie rebooting router, changing network privacy setting, unplugging speakers, uninstalling and reinstalling app etc all failed for me.  

Apparently an additional privacy feature introduced by IOS14 was the use of a private address when connecting your iPhone to a WiFi network. This option can be found by selecting your WiFi network on your phone.  I turned this off and the Sonos app immediately worked. 


14 replies

Userlevel 5
Badge +16

Hi @pjseps.

We highly appreciate your time and effort to let us know the steps you did to resolve the issue.

This is definitely going to be very helpful to those community members that might encounter the same situation.

If in any case that you may have questions or run into any issues,  please do not hesitate to reach out, we are always here to help.

You are always welcome here in the community.

Cheers!

Userlevel 7
Badge +21

This only makes sense if you had previously “blocked” unknown MAC addresses from attaching to your router, so that disabling the private address option switched you back to the original MAC address. However if the “new” MAC address had been blocked, all of WiFi would have not worked, not just Sonos. Weird.

I am not aware of any piece of Sonos software that gives a rip about the MAC address of a device running the controller app.

This helped me.

 

After trying to use airplay, the S2 app on my iPhone lost connection to Sonos and could not discover it on the network after a reset. I disabled this ‘private address’ option for the wifi network and was able to discover Sonos on the network straight away.

Hello, do we know a fix for this without turning off private address? It’s a huge security concern and I don’t want to turn off this security feature. Thnx 

Userlevel 7
Badge +21

Hello, do we know a fix for this without turning off private address? It’s a huge security concern and I don’t want to turn off this security feature. Thnx 


Use a router which handles multiple frequencies correctly.

And this is hardly a “huge security concern”.

Right and I agree but this isn’t about someone hacking your network but stopping other third party applications tracking you on your own network.

 

link:  https://support.apple.com/en-ca/HT211227

Userlevel 5
Badge +15

Right and I agree but this isn’t about someone hacking your network but stopping other third party applications tracking you on your own network.

 

link:  https://support.apple.com/en-ca/HT211227

Thanks for the link - I had a quick read, and it seems clear that changing the MAC address is all that happens (which isn’t much).

After enabling Private Address, your iPhone will consistently use the same “fake” MAC address on your network. Please now reset the Sonos app and select to “connect to existing system” after restarting it. Settings » System » App Preferences » Reset App » Reset.

Are you now able to connect, with Private Address enabled?

I will try to do a reset and set it up from scratch since it won’t connect while the private address is on but as soon as I turn it off Sonos app connects. Thank you

Userlevel 5
Badge +15

Hi @ChaliaF 

Did that help at all?

Hey Cory yes it did !! Thank you again 

Userlevel 5
Badge +15

@ChaliaF 

Excellent! You’re very welcome!

Just had a lot of problems with all my Apple devices which use iOS 14, the solution was to create a Sonos net by connecting one of my speakers to the router. Everything seems to work now, but I did have a convenient network point next to a speaker and I suppose many people won't have the option to hard wire a speaker. But if possible, this does work.

Userlevel 5
Badge +15

Just had a lot of problems with all my Apple devices which use iOS 14, the solution was to create a Sonos net by connecting one of my speakers to the router. Everything seems to work now, but I did have a convenient network point next to a speaker and I suppose many people won't have the option to hard wire a speaker. But if possible, this does work.

Thanks for sharing Chris!

I rather suspect the issue you had was something else, however, which using SonosNet has fixed. This whole Private Address issue is quite new, however, so I could be mistaken.

The problems did only begin a few days ago, and only on Apple devices, a windows tablet worked perfectly. I would try the Private Address fix, but at the moment SonosNet is working well and there is no need to change it.

Reply