Update to Controller for Mac

  • 23 February 2023
  • 11 replies

Badge +4

I had the same issues before when updating the Controller for Mac, before.  Using macOS Ventura 13.2.1.

Tried to update from the software itself, always stops saying error, try again. After 3x the same happens. Found a direct link from Sonos and downloaded 15.1 to my mac. But will not open and function.

Grateful again for help please? I can not use my Controller for Mac at present.




Best answer by Jamie A 24 February 2023, 11:22

View original

11 replies

Userlevel 5
Badge +12

Hi @mikegunnill,

It’s possible that there may be processes running in the background preventing you from running the installer. I’d suggest uninstalling the Sonos App from your Mac, then rebooting your Mac to ensure it has been fully removed. After doing that, head to our download page and attempt to download the S2 app and run it.

If you’re still not able to run the installer for the Sonos app after that, I’d suggest reaching out to our support team for live troubleshooting and assistance.

I hope this helps!

Badge +4

Thx Jamie:


That's is basically what I did and the second time it worked.  I deleted everything Sonos from my system and reinstalled. I downloaded from official download page and not via the application.


There is something wrong here, as I mentioned this is the same as the last time downloading an update. I am bringing to dread needing to do this again.



Mmm...I have this issue too for the first time ever.  I haven’t tired this fix but I would be sad if that is what is required going forward.  All my updates up to now have worked flawlessly (for years!) without any “extra” effort so I would hope that Sonos would figure out what is causing this and develop a fix for the update process.  Maybe a better error message would be helpful too.



I have the same problem but when I tried to update the first time Ventura was prompting me there was a Privacy and Security issue. I have to change my settings but don’t know what to add. It seems that an app has to be added in the System Settings → Privacy and Security → App management of Ventura 13.2.1

The screenshot is in Dutch but I’m sure you guys will understand it.

Just adding the Sonos app did not help.

Anyone any idea? 
At least I hope that someone will have a bright moment 😀

Thanks and best whishes!

I finally did as was suggested above.   I deleted the Sonos application from my laptop and reinstalled.  After that the update worked fine.  I too was considering the security update that you mention but decided to try the application delete and reinstall first so I never made the security change.


Doesn’t seem like something that you should have to do and it’s the first time I have ever had to do it after many years of installing updates.  I would expect the error message that is generated to be more descriptive about what to do than just saying that  some unknown error has occurred but I am moving on now….😎





Worked for me as well…


Badge +4

Glad that you have got the software working, as it should do. Sonos are aware of the problem but seem slow moving forward. I expect better Sonos.



I updated two Macs on Monday with 15.1, one an older MacBook Pro running an Intel core, Ventura 13.2.1 and an M1 MacBook Air, also running Ventura 13.2.1 and had no issue updating either of them, from inside the Sonos controller. No need to delete anything. 

Badge +4

Airgetlam:  Well done, from the last two updates I had problems. Which Sonos are aware of. I have exactly the same MacBook Pro M1 running the latest Apple software. For me, the Sonos-update system does NOT work. Again Sonos are aware of this. To make my system useable, I had to delete and start again, as a Sonos suggested work around.

I was having the same issue, and determined it was a Privacy & Security setting issue.

Here’s how I was able to fix it: Settings > Privacy & Security > App Management then make sure the Sonos Installer is toggled on


Thanks for this.  Cured my most recent issues with the installer.  Nice to have this information somewhere “up front” or maybe the error message you get when this happens could be more descriptive about things to try.

I get why the installer might need the rights to update/delete but any thoughts about why the Sonos app itself would need those rights? I try to change as few settings as possible cause Apple updates come through and seem to mess with stuff that I had set instead of preserving my settings. I haven’t had any other issues except for the last two Sonos installer “fails”.