"unable to play…song is not encoded properly"

  • 21 October 2020
  • 4 replies

I see that other people have been having this problem but haven’t seen any fixes or even reasons why this problem occurs. For a long time I’ve been listening to my Mixcloud uploads on my Sonos 5 Gen 1 without any problems, but now I get the “unable to play song is not encoded properly” and nothing to listen to, unless I switch to a radio station. Are you aware of this problem? There’s nothing wrong with my internet connection and the radio station can play okay. Is this a problem with MixCloud, or is it Sonos? I have the Sonos S1 Controller installed and it was working fine until recently.

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

4 replies

Userlevel 5
Badge +16

Hi @drümmkopf.

Thanks for reaching out and welcome to the community!

I appreciate your detailed post outlining your concern, let me help and try to figure this out.

To verify, this is only happening specifically with Mixcloud and not on other music services?

Kindly submit a diagnostic report through the Sonos app when the issue occurs, and reply with the confirmation number. I'd start by reviewing your system as well as the status of the devices, it will also help in identifying what's possibly causing the issue.


I’m looking forward to assisting you further from here.

If you have any other questions or run into any issues,  please do not hesitate to reach out,  we are always here to help.

Basically I just listen to my own Mixcloud uploads with my Sonos, so I haven’t tried it with other sources, except when the Mixcloud uploads don’t play I am able to listen to a radio station without any problem. My Mixcloud uploads wouldn’t play last night but this morning I tried again and they seemed to be working okay. Whether that will still be the case tonight when I really want to listen, we’ll see. are my Mixcloud uploads that I have in my play queue, sorted randomly. I’m hoping I’ll be able to keep listening to them without the “not encoded properly” error recurring. I’m wondering why that even happens in the first place. It could quite possibly be something coming from Mixcloud. They’ve certainly had their share of glitches over time, but they’ve usually been worked out, at least temporarily. Hopefully this will be worked out as well, and hopefully not just temporarily.

It’s still doing the “not encoded properly” thing and failing to play my Mixcloud queue. I sent diagnostic report. Your confirmation number is: 687554308.

Userlevel 5
Badge +16

Hi @drümmkopf.

Thanks for your responses and effort in submitting the diagnostic.

Upon checking on the diagnostic report, the system detected a transport error caused by a corrupted file.

Currently, there is no outage report showing on Service Status Page, and Mixcloud should be operational.

Is this happening when you’re using another controller?

I noticed that the MAC controller seems to be connected to a different WiFi network from where your Sonos system was set.

Please ensure that the controller and Sonos are connected on the same home WiFi network and both on the 2.4Ghz band.

Then, test the music source again.

You may also refer to this article that provides common fixes for audio interruptions while playing music services on Sonos.


If the above advice was followed and the issue persists, please submit a new diagnostic report, and reply with the confirmation number so I can review your system further and see if there’s anything else causing this issue.


Let us know how it goes and if you have any questions feel free to reach out, we’re always here to help.