Answered

Unable to play music from NAS

  • 21 May 2023
  • 6 replies
  • 633 views

Userlevel 1
Badge

I’m currently having terrible trouble playing music stored on my NAS drive through my Sonos system. If I  go through the ‘Music Library’ via the app I get the screen no selections are available (see screen shot). However if I go through the NAS option on the Browse menu it lets me go right through to the songs on the albums that are stored on the NAS drive but then won’t allow me to play the song, I get the ‘An error occurred while adding tracks to the Queue (701)’ issue. 

What then makes it even stranger is that if I find that track in my Apple Music Library that is looking at the same NAS drive then it plays the track without an issue and allow me to airplay the track to my system without any problems i.e. skipping, jumping, missing tracks.

I think I’ve tried all the resolutions posted on various posts on this site but still no joy so if anyone has any bright ideas I’d really appreciate it.

icon

Best answer by Airgetlam 21 May 2023, 19:19

View original

6 replies

Not enough information to really hazard a guess.

Are you using S1 or S2? What NAS device is in use? 

There’s two different access methods being used in your comparisons, your desktop machine and Apple Music is using one, but the Sonos device, since it is an external connection to your NAS using Linux, is using another, specifically SMB. If the Sonos controller app was just a ‘player’, sending music from your desktop’s OS, there wouldn’t be this issue. However, the controller you’re using is only a remote control, to tell the system running in Linux on the Sonos system where to reach out to in order to play the music. 

There are a lot of threads about SMB issues, particularly most recently with some changes Synology has made that is affecting users of S1. There’s lots of good information in those threads, either way, I’d suggest searching for the term ‘SMB’ and reading up, I suspect you’ll find the answer to your specific issue. 

Userlevel 1
Badge

Not enough information to really hazard a guess.

Are you using S1 or S2? What NAS device is in use? 

There’s two different access methods being used in your comparisons, your desktop machine and Apple Music is using one, but the Sonos device, since it is an external connection to your NAS using Linux, is using another, specifically SMB. If the Sonos controller app was just a ‘player’, sending music from your desktop’s OS, there wouldn’t be this issue. However, the controller you’re using is only a remote control, to tell the system running in Linux on the Sonos system where to reach out to in order to play the music. 

There are a lot of threads about SMB issues, particularly most recently with some changes Synology has made that is affecting users of S1. There’s lots of good information in those threads, either way, I’d suggest searching for the term ‘SMB’ and reading up, I suspect you’ll find the answer to your specific issue. 

Thanks for the feedback. I’m using S2 on a QNAP TS-431P.

I’ll do a search form SMB and see what I can find

Thanks 

DJ

Userlevel 7
Badge +22

Look for unix extensions = no as that seems to be a popular fix for folks using newer versions of Samba software.

https://www.samba.org/samba/docs/current/man-html/smb.conf.5.html

Userlevel 1
Badge

I may have fixed it.

Not sure how but it seems to be working for the moment. All I did was turn the DLNA Server option off in the NAS drive settings and removed the library link. I then set the library up again but kept the DLNA option off. It loaded the library and seems to have maintained it.

I’m not super technically minded so I’m not sure if this was a fluke or not but it worked and it’s still working so fingers crossed.

So I have the same problem. It has worked before, but for a long time, it is just listing the files, but cant play them…

What else services are you running? Medialibrary? Itunes server?

/Andréas 

I created the Error 701 issue between my Sonos app and my QNAP DNLA Server.  All was working well untilI disabled a user account on the QNAP - introducing a conflict between the SONOS setup and the QNAP.  Did this after a security breach,

On the QNAP - DNLA Media Server config in Control Panel - set up your NAS share and the default user account.  Then in the Sonos app - add the Music Library via the System option using the same NAS Share (eg. \\MyNAS\MyMusic, then specify the user account you specified on your QNAP DNLA Media Server.  

FWIW … use a QNAP user account with limited access on your NAS, eg RO priv.

 

hope that helps 

Reply