Answered

Unable to index Music Library unless it has a limited number of entries

  • 22 February 2023
  • 4 replies
  • 276 views

I have a Sonos 5 Gen 2 and a QNAP NAS drive with a music library on it. For many years it’s been happily operating as a Sonos S1 system, connecting through SMB1 to the QNAP media streaming service. A few months ago a QNAP update pushed SMB2 onto the NAS drive, and the S1 system wouldn’t talk to the NAS drive. I’m using the Sonos interface on a PC and I’ve uninstalled S1 from the PC, so only S2 is present. I’ve updated the Sonos 5 to S2 to try to get is working with the SMB2 on the NAS drive. It would start indexing the music library folder on the NAS drive, but bomb out quickly with the message “musicserverpath is no longer available. The device where the music files are stored may not be powered on, or the path may have changed”. I eventually tried emptying the media folder on the NAS drive, adding just a couple of folders of music, and then it would index OK. I added about 20 more  folders, and it would index OK. Added a further 20 and this message appears again when I try to index. The music files are the same as worked on S1. There seems to be some timeout or file limit issue going on. I have no problem playing any of the music which does index OK, or using a streaming service. Any suggestions?

Thanks,

icon

Best answer by Airgetlam 22 February 2023, 16:20

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

4 replies

I’m not sure I am aware of the restrictions Sonos has on number of folders, just ‘size’ of data (combined data between number of tracks and other metadata), perhaps you might call Sonos Support directly to discuss it?

When you speak directly to the phone folks, they have tools at their disposal that will allow them to give you advice specific to your Sonos system and network.

The system is somewhat impatient and will time-out at awkward moments. The system is more sensitive to number of tracks and size of the metadata (track names, artist names, etc.) than the number of folders. Intermittent network congestion can add a variable.

A possible work around is to redefine your library somewhat. Instead of one large library, perhaps ‘\music’, break it out into a few separate shares:

\music\pop
\music\classical
\music\jazz

SONOS will deal with up to 16 shares. This will probably not require much, if any, reconstruction of your library. Sonos will work with each share individually, reducing the memory footprint and processing times along the way because of the smaller share(s). Breaking out into multiple shares has no impact on the controller user interface (unless you use ‘Folders’ view).

Thanks for your suggestions Bruce and Buzz. As it turned out there was a Sonos update which came through about a week ago. After that was applied the reduced-size library which didn’t previously index managed to index OK. I’ve since added all the remaining library files to the original single folder, and again it indexed OK first attempt, so I’m presuming the update contained something significant.

Cheers.

Userlevel 1
Badge +1

I have a Qnap NAS TS-453 Pro with a 22K track library. I get the same issue as described above, it fails to index and throws an error after a few minutes “musicserverpath is no longer available”. This was previously working on my S2 system and is still working fine on my S1 system (i have both S1 and S2 in my house). I have an open case with Sonos and whilst their helpdesk have been very courteous they do not yet have a root cause or solution and I’m hence unable to access my music library from my S2 system. My workaround is to use BubbleUPNP which can read the NAS library via Asset UPnP server and send the stream to the S2 Port. THis however isn’t ideal since Bubble UPnP doesn’t integrate with my streaming services (Amazon and Spotify) so i can’t build a playlist that combines tracks from my music library with tracks from Spotify for example.