TruePlay simply does not work in the new App


Userlevel 7
Badge +4

I tried to TruePlay Arc / Sub / Ones but the tuning is simply stuck on “Continue” step.

I’ve updated to the latest version 80.00.04. 
 

@Corry P do u guys are aware of this?

 


357 replies

I just tried again (iPhone) and was able to TruePlay all of my rooms finally. Various combinations of Play:1’s, Play:3’s, One’s, Five, Arc.

Still no dice for me. 

Didn't work for me on iPhone 13 pro either. 

Userlevel 2
Badge +3

I just tried again (iPhone) and was able to TruePlay all of my rooms finally. Various combinations of Play:1’s, Play:3’s, One’s, Five, Arc.

Still no dice for me. 

Didn't work for me on iPhone 13 pro either. 

I’m on a 14, not sure if it matters.

I just tried again (iPhone) and was able to TruePlay all of my rooms finally. Various combinations of Play:1’s, Play:3’s, One’s, Five, Arc.

Still no dice for me. 

Didn't work for me on iPhone 13 pro either. 

I’m on a 14, not sure if it matters.

Like my iPad Mini, my brother's iPhone doesn't even show TruePlay as an option. It's not there whatsoever. Nothing to click on to tune or toggle. So odd. 

Userlevel 2
Badge +3

I just tried again (iPhone) and was able to TruePlay all of my rooms finally. Various combinations of Play:1’s, Play:3’s, One’s, Five, Arc.

Still no dice for me. 

Didn't work for me on iPhone 13 pro either. 

I’m on a 14, not sure if it matters.

Like my iPad Mini, my brother's iPhone doesn't even show TruePlay as an option. It's not there whatsoever. Nothing to click on to tune or toggle. So odd. 

Yeah, for me, under each speaker in settings, I have this option.

 

I have Arc connected  to 2 Era300's as surrounds. Trueplay won't work since I added the 2 Eras on the new app. Absolute rubbish given the cost of the speakers. Stuck on screen below on ipad air and iPhone. 

 

After many weeks without TruePlay being visible, my iPad Mini 6 finally had the popup up top of the system page to try TruePlay tuning on my system and it worked. Nothing changed for me other than to check the app every several days and now all of a sudden it showed up and went all the way through tuning. So weird. 

Userlevel 2
Badge

New app update/system today did not resolve trueplay for me. Trueplay completes but still no toggle so trueplay is not applied. 😤

 

version: 80.03.07

arc + 2xsubs + 2xera300

iphone 14 pro max

Userlevel 4
Badge +3

Finally got it to work on iPad. Wish the rest of you luck. 

Given how restrictive user equalizer configuration already is, this whole episode has been another avoidable low point that was remarkably disrespectful to users.

Userlevel 2
Badge

Finally got it to work on iPad. Wish the rest of you luck. 

Given how restrictive user equalizer configuration already is, this whole episode has been another avoidable low point that was remarkably disrespectful to users.

Thank you! Decided to try it with my iPad and it worked!! Toggle is now present and I can hear the difference in acoustics! Finally after months of trying to get true play to work! You bet I won’t be getting Sonos for my next home theater project.

Just to help others, here’s my setup that worked. 

 

App version: 80.03.07

arc + 2xsubs + 2xera300

Working Device: iPad Pro 12.9” 3rd generation 


Device that previously failed trueplay: iPhone 14 pro max 

Finally got it to work on iPad. Wish the rest of you luck. 

Given how restrictive user equalizer configuration already is, this whole episode has been another avoidable low point that was remarkably disrespectful to users.

Thank you! Decided to try it with my iPad and it worked!! Toggle is now present and I can hear the difference in acoustics! Finally after months of trying to get true play to work! You bet I won’t be getting Sonos for my next home theater project.

Just to help others, here’s my setup that worked. 

 

App version: 80.03.07

arc + 2xsubs + 2xera300

Working Device: iPad Pro 12.9” 3rd generation 


Device that previously failed trueplay: iPhone 14 pro max 

Mine randomly started to work yesterday on my iPad Mini. TruePlay finally showed up as an option and I didn't do anything to cause it to appear. 

With the latest app (80.03.07) Trueplay still doesn't work on my system(s). System 1...2 Sonos 1’s and a subwoofer mini. System 2...2 Sonos 300’s and 1 Arc. I have tried Trueplay with 2 iPads but don’t have an iPhone.

Userlevel 7
Badge +4

Jesus, i did not expecy so many replies. Its sad to hear that even after 2 months, there are still so many issues with TruePlay. Sonos really did drop the ball on the new app.

Userlevel 1

I've been trying to get Trueplay to work for a.Beam 2nd gen to no avail. Using an iPad 10th gen to do this. Never plays the test tones.

Userlevel 2
Badge

I've been trying to get Trueplay to work for a.Beam 2nd gen to no avail. Using an iPad 10th gen to do this. Never plays the test tones.

I don't think Trueplay has ever been compatible with iPad 10th gen.

Userlevel 2
Badge

Good news, TruePlay finally works on my iPad Air 5th gen. I have a Sonos Arc and Sub 3rd gen. I made sure I updated the Sonos app in both the app store, and within the Sonos app as well. It works perfectly now without having to resort to any workarounds.

Latest version of the app 80.04.04 has still not resolved my issues from iPhone 14 Pro.

I had this issue since the update. Non of the advice of fixes in here worked for me. However today’s cycle of deleting and reinstalling the app made everything work. Just in case it helps someone here are the steps I took:

Arc + 2x era300s. App + system are at latest versions (from memory it was the 7th June app release, I think).

  1. Removed the surrounds, just Arc in the room, tried truplay and got the usual stuck flow where “continue” doesn’t work
  2. Deleted app from iPad (9th gen)
  3. Reinstalled app
  4. Opened app and couldn’t get to my system without logging in
  5. Reset password as I’d forgotten it
  6. Logged in to app
  7. Re-authorised all the mic/location access permissions
  8. Tried truplay and it worked first time (just the Arc in the group)
  9. Added the surrounds back in
  10. Tried truplay and it worked again (Arc +2 era300s)

Additionally, I had a power-cut the week before, so the hardware (and wifi router) was completely unpowered. Since then I’ve used the system normally for TV etc but hadn’t changed any settings. 

Hopefully this helps someone else stuck out there.

So Truplay does not work at all in a newish ipad pro for a beam gen 2. I feel the pain of all those comments about the new app now. Only bought the beam to month. Jot very impressed by this tbh

Just got my Beam 2 yesterday and very disappointed with this inability to use Trueplay. Tried everything and no matter what just stuck on “Continue”. 

I'm having thesame issue an all my sonos producs
My Arc ,my bean, Sonos 5.this new update sucks.

Some one definitely should get fire for releasing garbage sofware.

Brand new speaker this is as far as it gets. Same is happening on all other products I tried everything. Guess I will returning this one to the store. Can't believe Sonos has gotten so bad they even took away the network folder  

Just got my Beam 2 yesterday and very disappointed with this inability to use Trueplay. Tried everything and no matter what just stuck on “Continue”. 

Same with me. I purchased beam gen 2 yesterday and teied tonsetup today. Nothing happens after that screen. Hooe they release an update soon?? 

Userlevel 1

Have Sonos said anything at all about this? Like 'we are away of an issue and are investigating'?

Userlevel 7
Badge +18

Hi @Trubbabubba 

We were aware of an issue, and fixed it. Please ensure that both your Sonos system and your Sonos app are fully up-to-date. To ensure the app is up-to-date, please go to your App Store (iOS) or Play Store (Android) and manually check.

Please be aware that iOS 18 is not yet supported - TruePlay will not work on iOS 18.

If you are fully up-to-date and still having issues, please consult our Error during Trueplay tuning help page, then finally get in touch with our technical support team who have tools at their disposal that will allow them to give you advice specific to your Sonos system and what it reports.

I hope this helps.

Userlevel 1

iPad 10th gen (iOS 17), Arc (connected by ethernet), Sub mini (wifi), and two Era 100s (wifi). Trueplay will just not work. It keeps getting hung up on the “Face your TV” step.

I tried to go through all the steps with technical support and ended up losing my whole system. It took me an hour to get set up again and the problem still did not resolve. Everything is up to date.

I do wonder if it’s something to do with the fact that my system was initially set up on an Android device and I am using an iOS device to try to set up Trueplay.

Reply