Answered

Trouble using radio channel as alarm - get chime

  • 20 January 2023
  • 9 replies
  • 89 views

Badge

The past two weeks I have been (mostly) unable to use a radio channel as source for alarm in the morning (from the Danish national radio “DR LYD”, but also using the same channels from TuneIn). I thought of connection issues, although most of my speakers are wired, but even after connecting the affected zone directly to a switch the problem persists. Other zones using playlists as source (Apple Music) works fine on both wired and wireless zones. 
 

I suspect that the stream will timeout and give me the chime so I would guess that the issue lies with the connection to the source as connection to the speakers looks solid (diagnostic 111600515) when looking at the connection matrix in the speaker diagnostic on its IP. 
 

I can also see the trying to plays the source manually takes a while to start - maybe the alarm is less patient and cuts to chime faster?

could someone from Sonos maybe check if the connection to “DR Lyd” has an issue or if the alarm feature is a tad to fast to call timeout?

icon

Best answer by TorbenRasser 30 January 2023, 06:34

View original

9 replies

Userlevel 7
Badge +18

Hi @TorbenRasser 

Thanks for your post!

The speaker was unable to reach the station’s server at the time, so played a chime so that there was still an alarm, yes. It spent 7 seconds trying a fast start with various options, which failed. It then spent 10 seconds trying two normal starts, which also failed. Finally, it started playing the chime after 27 seconds of failed attempts in total.

There are a few possible explanations for why this happened:

  1. The CPU usage is quite high - please reboot the speaker by removing power for a moment.
  2. The station may get a multitude of requests on each hour/half-hour in the morning due to alarms - setting the alarm(s) for a minute or two earlier/later may result in better reliability.
  3. Badeværelse Sovev. gets it’s connection via “Kontor”. The error rate for the transmissions between the two is a bit high for my liking, but the signal strength is good - this leaves interference as the likely reason for the error rate. Please ensure both speakers have 1m space from any other WiFi devices. This includes not putting your phone near the speaker at bedtime.
  4. General network health - please reboot your router by switching it off for at least 30 seconds. I recommend doing this several times a year. You may also want to try configuring a different DNS server in your router’s configuration pages (like Google’s 8.8.8.8). If you change this setting, reboot the router afterwards.

Number 3 is the most likely, in my opinion. I hope this helps.

Badge

Thank you for the insightful reply. 
 

I have multiple access points for my wifi (UniFi) so moving stuff away from “the router” is not really possible - there will always be an AP nearby. AP’s are scattered around the entire house, but they are running on channels 1 or 11 whereas Sonos is using 6 for Sonos mesh. This configuration has been used for the past year with no change other than now wiring the speaker in question to ensure that connectivity wasn’t the issue. “Kontor” is about 2 m from nearest AP, but other speakers are closer to an AP - the Arc and the paired set of One SL are very close to an AP. These aren’t the troublesome zones though :-/ 

I will try changing the time of the alarm to maybe steer clear of “peak hours”. Manually trying to play the channel at 6 AM can also feel really sluggish whereas playing anything else is snappy as expected. Manually starting the channel on any other zone during the day has never failed so far. 

Userlevel 7
Badge +18

Hi @TorbenRasser 

Apologies - I misinterpreted some information I was seeing. The link between “Badeværelse Sovev.” and “Kontor” is relatively free of errors, but “Badeværelse Sovev.” is receiving quite a lot of signals on it’s antenna that it classifies as garbage (not proper WiFi).

So, this will be a non-WiFi source of 2.4GHz interference that I’m seeing. If the speaker is on or very near a metal or glass surface, it’s own transmissions can bounce back at it, causing interference, but I’m not convinced this would be interpreted as non-WiFi. Do you have wireless CCTV cameras, perhaps? Or maybe your phone is Bluetooth-linked to another device (AirPods, etc.) nearby? Maybe you have a baby monitor? If the speaker is near a wall, please also consider what might be on the other side of the wall.

Working now on the premise that interference - although present - is not the cause, what is “Kontor” wired to? If it is to a wireless AP, it may be better not to have it wired at all - both “Kontor” and “Badeværelse Sovev.” have sufficient signal strength to other wired units that they do not need this wired connection to exist, and none of the rest of the system depends on that link.

Hopefully, it’s just a matter of changing the time a little.

I hope this helps.

 

Badge

Really appreciate the answers and I understand that it is an ungrateful task to troubleshoot in the blind, so I have tried to draw a picture of my setup in my house to make things easier. See below.

My home has wired connetivity in all rooms to my central PoE switch in the utility room where it feed both access points and remote switches through PoE. So when I wire a speaker it is directly connected to the central switch - maybe through an intermediate remote switch, but still connected directly to my Unifi Dream Machine. Some rooms only have one LAN socket, and some have the socket placed stupidly relative to where I have speakers, so there I rely on Sonos mesh instead. I try to wire a Sonos speaker in central places to make sure the mesh always have a strong source nearby. I have indicated wether a unit is acting wirelesly or hardwired. Also noted what 2.4 GHz channel the AP’s run on.

You will find the troublesome room (“Soveværelse” = bedroom) to the far right, where I have now wired the Sonos Play:1. The bathroom above it is the one that connects to “Kontor” (office) to its left and it plays along with the bedroom through grouping. Walls are made of aerated concrete on all inner walls - they are a b**** for wireless which is why I have so many AP’s scattered around. As you can see “Soveværelse” (bedroom) doesn’t really have anything around it, but is does sit on a cabinet that houses an apple TV (which is wireless) and above it there is a wallmounted non-smart TV without any WiFi capabilities.

I really can’t tell why the bathroom on the right should receive so much garbage. It is the most remote room and there is absolutely nothing outside the house. It could perhaps be the AP in the office, but that should reflect equally on the “Køkken” unit. I have a couple of Hue light strips and a motion sensor in the bedroom, but could the Zigbee network interfere with Sonos? The rooms “Patrick” and “Julia” also have a Hue lightbulb, but otherwise no rooms use these bulbs.

Other wireless stuff would include cameras mounted on the outside of the house (Eufy) and an alarmsystem (Ajax). The latter has a ton of units, but I have never heard of these things interfering with Wifi. I believe they run at 868 MHz, but Eufy runs on 2.4 GHz and connects back to a hub. The camera closest to the bedroom is however sitting further away than the office Play:1.

PS. There is a Sub hiding in the room that has the Arc, but my wife hasn’t found or noticed it yet and she might stumble across this drawing, so let’s keep this a secret between us… It sits near the back right surround speaker in the living room (“Stue”) if this should matter - “right” as in “right channel” relative to Arc and the TV.

 

Userlevel 7
Badge +18

Hi @TorbenRasser 

Thanks! Some nice work has been put in there - I appreciate it!

I had assumed the definitions of Badeværelse and Soveværelse the wrong way round and this was admittedly confusing me. Now I know which is which, things are clearer!

To make the path that the music takes more efficient, please disband the Badeværelse Sovev. and Soveværelse group. Next, select Soveværelse, and group Badeværelse Sovev. to it. This step alone may actually be enough to improve matters.

I think the “garbage” we see might be due to the Badeværelse Sovev. speaker being in the corner of two external walls. There may also be nearby water pipes that signals are bouncing off of - can you relocate the speaker within that room? I understand that options might be limited in a bathroom, but it’s worth trying if you can.

I would also suggest moving Soveværelse away from the surround speaker in Stue on the other side of the wall, if things haven’t already improved, or if it’s easier than the above step. Maybe place it at the corner of the walk-in so it’s mid-way between the surrounds? They will be on different bands (2.4 and 5GHz), however, so I’m not entirely convinced about this tip.

With Stue and Kontor both wired, I think having Soveværelse wired is superfluous. Having said that, having Kontor so close to an AP, it might be better to have it on wireless instead of Soveværelse. Plus, I might be seriously underestimating your wall’s ability to block signals (two wired speakers don’t communicate over WiFi at all, so can’t report the signal strengths they would have to each other if one were wireless). Whatever works best, ultimately.

I hope this helps.

Badge

thank you for the reply!
Music started today. I displaced the time with 2 minutes to let it start a bit early. I will benchmark during the week. 
Moving the speaker in the bathroom is impossible. Not a whole lot of sockets in there and I had to ask the electrician to drill in extra ones already. 

Userlevel 7
Badge +18

Hi @TorbenRasser 

Music started today. I displaced the time with 2 minutes to let it start a bit early. I will benchmark during the week.

Promising - let’s see!

Moving the speaker in the bathroom is impossible. Not a whole lot of sockets in there and I had to ask the electrician to drill in extra ones already. 

I suspected as much. The Roam or Move might be a better fit for a bathroom, seeing as Denmark has 230v mains electricity - I’m surprised the electrician agreed to do it. Not that I am suggesting you should buy a new speaker to get things working - they should work as they are.

Badge

Following up the radio has gone off with no issues the past week now. Set the alarm to start two minutes to six, changed the main speaker to be bedroom and re-made the grouping to the bathroom as suggested, and kept the wiring of the bedroom speaker (it is easy, so might just keep it like that).

 

thank you for assisting in troubleshooting. 

Userlevel 7
Badge +18

Hi @TorbenRasser 

Thanks for reporting back and updating the thread! I’m glad to hear things have improved!

You are very welcome!

Reply