Answered

Tried everything to troubleshoot Spotify issues

  • 20 November 2022
  • 7 replies
  • 181 views

Hi all,

I’ve had this issue for some time: Spotify drops music regularly, Apple Music works perfectly. 

Things I’ve tried:

  • Change SonosNet Channel
  • Run ethernet cable from router to Boost
  • Position Sonos products as close as possible to main Boost (including another Boost). There is roughly 20-25 ft between the main Boost and the next product. All other products are about 10 ft away from each other.
  • Reboot system
  • Re-authorize Spotify service
  • Move wireless devices like cordless phone away from speaker
  • Confirm sufficient download speeds
  • Set up a speaker in same room as main Boost to see if it improved the issue (it still skipped, though maybe not as often?)

Things I cannot do:

  • Change my wifi network channel. I use Eero, which prevents users from changing the channel manually. 
  • Remove Eero extenders, which lets the wifi network reach the basement office. While not listed by Sonos as unsupported devices, I understand this may be an issue.

Things I haven’t tried, but am skeptical:

  • Change ethernet cable between router and boost 

I’m about out of ideas and tech support hasn’t been able to help. Any suggestions? Has anyone tried changing the ethernet cable and found it helped?

Thank you!

 

 

icon

Best answer by Corry P 21 November 2022, 11:42

View original

7 replies

Userlevel 7
Badge +18

Hi @salejan 

Welcome to the Sonos Community!

Given that Apple Music plays without issue, it seems likely that the issue is not due to local conditions on your network. I recommend you get in touch with our technical support team, who have tools at their disposal that will allow them to give you advice specific to your Sonos system and what it reports.

If you know how, it might be worth first trying a change of DNS servers on your router’s settings. Try Google’s 8.8.8.8, and reboot the router afterwards. If you don’t know how, our technicians can help.

I hope this helps.

Thanks! I’ll try that.

I have the same issue and spent four hours on ine with Sonos and Eero (wifi net provider) and no one can solve it. Both at level two escalation now.

 

If you have any VPN clients I would try to remove them and reboot phone.  That really gummed up my iMac sonos app and removel fixed it instantly.  Haven’t tried to reinstall yet.  

 

If you find anything please let me knwo and I’ll do the same.

I have had similar issues and may have a workaround for those of you reading this.  I have a few wired speakers and some wireless.  I can use any music service but Spotify without issue.  However, when using Spotify Sonos would skip songs on most and would start to play a few only to say “connection with Spotify lost”.  
 

I did finally find something that works for me and seems promising so far.  I disabled the wired speaker’s wireless ability, thus in effect turning off Sonosnet.  This somehow seems to have solved my issues and i can now listen to Spotify once again without issue.


I don’t quite know what is happening to cause any of this, so I think it is worth mentioning I also have a Unifi Dream Machine Pro SE handling my routing.  I don’t know if the Unifi system or my settings are related whatsoever but I thought it was an important variable to include for anyone at Sonos (or Spotify) who may have the ability to read this and fix it.   

 

Same thing here, tried everything like salejan, but the issues remains.

Best regards

Martin

Thanks for your suggestion Statecowboy.  No luck here.

 

Have a good day.’
Kevin

Doesn’t work

Reply