Sveriges Radio from Sonos app skips track

  • 30 January 2021
  • 5 replies

I have the exact same issue as described here

but from the Sveriges Radio. Very annoying when listening to a podcast as it does not remember where it was and you need to listen to find where you are. Happens about every 20-30 min.


And no, I don’t have any network issues or with playing directly from the app via AirPlay


Best answer by Corry P 4 March 2021, 16:58

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

5 replies

Userlevel 5
Badge +16

Hi there @Sunshinerunner Brother.

Thanks for reaching out and welcome to the community! We’d be glad to help.

To verify, this is specifically happening on Sveriges Radio only?

Is there a particular speaker exhibiting the problem?

Was there any change made on your system/network prior to starting to experience this?

To better understand what’s going on, please submit a diagnostic report through the Sonos app shortly when the issue happens, and reply with the confirmation number. I'd start by reviewing your system and go from there, it will help in identifying what's possibly causing the issue.


Looking forward to hearing from you soon.

My system was already gone through by your senior technicians for another connectivity issue due Sonos requireing specific Wifi channels that could not be modified on my Deco wifi system, and this was solved by putting a strong signal (mesh router) close to the speaker. So that is definitely not the issue.

This is the identical issue as the long discussions with Spotify skipping tracks. If you solved that with the Spotify team, perhaps you need to look at it with the Sveriges Radio app team, or apply a similar fix.

The issue does not come up with live broadcast streams, only for selecting a podcast on demand. 

I would prefer if you start at that end before I spend hours on trying to find an error on my specific system.

Diagnostics: 1226883267


Is there any news about this problems? I have had it for a couple of months now but its not until now I have time to deal with it and search for a solution. For me it happens only when i’m listen to podcasts and not music. Even if I listen to podcasts thru Spotify. It looks like it some “time out” with tracks being too long.

Userlevel 7
Badge +18

Hi @Sunshinerunner Brother 

Thanks for the diagnostics - it shows, I’m afraid, that local network problems are still the cause of your listening issues. All 3 rooms are being repeatedly asked by your mesh to connect to 5GHz, which they will not do, resulting in disconnects.

I recommend you connect one speaker to your router (or main mesh node) with an ethernet cable. If you don’t have a speaker near your router, you can connect one to a secondary mesh node, but only as a last resort. Be sure to keep your speaker, router and mesh node 1m distant from each other, or as far as is practical if 1m isn’t possible. Wiring one speaker with ethernet to your network will change the way in which they all connect to your network, creating their own mesh system.

Once this is done, please open the Sonos app and make sure all 3 rooms are connected (wait a few minutes to make sure). Then, select Settings » System » Network » Change Sonosnet Channel » 1. This will get Sonos’ mesh to work on a different channel from your WiFi mesh.

Test for a few days. If testing is successful and an improvement has been made, either keep one Sonos speaker wired to ethernet, or purchase a Sonos Boost to be connected to ethernet permanently instead.

If you only have problems in “Alice rum", these will be due to interference near the speaker - please read our reducing wireless interference page for help.

Still having issues during the testing? I recommend you get in touch with our technical support team again.