Answered

Spotify skips to next song or stops playing, other sources work just fine meanwhile


Userlevel 1
The past couple of months when playing music from Spotify on any of the sonos speakers the music skips to the next song or stops playing at random points. It can be after 2 songs or half a day. The controller reports connection to spotify lost. Sometimes i can immediately click play again and it starts over but sometimes it takes 1-10 min before i can resume. Meanwhile i can play from other sources just fine so it seems like a Spotify specific issue. If i try to play using spotify connect then as i select the speaker, it changes it back to the previous target.
icon

Best answer by Edward R 19 June 2019, 13:58

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

269 replies

Badge

Just throwing my name in the hat as well. Sonos user for years and no issues (still) with services other than Spotify. Spotify cuts out and skips tracks intermittently and it’s frustrating. Other services continue to play fine, so I too think this lies deeper with Spotify. Please do something! 

Badge

I am having the same skipping issue while playing Spotify from the Sonos app that started all of a sudden a few months ago. It would skip in the middle of a song and then skip the next track as well. I have a 15-song playlist that I use as an alarm everyday and the same songs skips. Here’s the pattern:

Song 1 - ok
Song 2 - ok
Song 3 - ok
Song 4 - skips whole track
Song 5 - ok
Song 6 - skips in middle
Song 7 - skips whole track
Song 8 - ok
Song 9 - ok
Song 10 - skips in middle
Song 11 - skips whole track
Song 12 - ok
Song 13 - skips in middle
Song 14 - skips whole track
Song 15 - ok

This problem occurs for any playlist and radio stations that I listen to from Spotify via the Sonos app although I don’t think it’s the same pattern of song skips as above. However, everything plays perfectly when playing directly from either the Spotify iOS app or Spotify desktop app via Spotify Connect to my speakers. Playing other music services from the Sonos app work fine too so it’s just a specific problem of Spotify from the Sonos app.

I have several speakers that are connected to ethernet directly and am using SonosNet. Nothing has changed with my network and everything has been working perfectly for a few years until a few months ago. I was hoping the new S2 app release was going to fix this issue but the issue still occurs.

I have the same problem with sonos/spotify and many other people i know. Im thinking aboit selling my system as its been going on for so long 

  • What devices do you have?

3 sonos1

1 sonos5

1 sub

1 soundbar

 

  • Has anything changed on the network?

No

  • Which service(s) are you trying to listen to?

Spotify, saved to device or streaming is the same 

  • Is the behaviour always the same?

Yes. Skips every now and then.

  • Can you recreate it with ease, or is it random?

Random, but regular. Most of the time it just a skip a song in the middle of it, but sometimes it just stops playing. Happens several times per day

diagnostic: 1533096031

 

 

Hello

Im also experiencing this issue with Spotify.

Diagnostics submitted: 629512704 and 1524953219

(second one immediately after a skip)


Interestingly, I don’t get the issue if I use Spotify as the interface and Airplay/Share to Sonos. It only occurred when I use the Sonos interface to search and initiate Spotify playback.
 

 

Badge

I am having the same skipping issue while playing Spotify from the Sonos app that started all of a sudden a few months ago. It would skip in the middle of a song and then skip the next track as well. I have a 15-song playlist that I use as an alarm everyday and the same songs skips. Here’s the pattern:

Song 1 - ok
Song 2 - ok
Song 3 - ok
Song 4 - skips whole track
Song 5 - ok
Song 6 - skips in middle
Song 7 - skips whole track
Song 8 - ok
Song 9 - ok
Song 10 - skips in middle
Song 11 - skips whole track
Song 12 - ok
Song 13 - skips in middle
Song 14 - skips whole track
Song 15 - ok

This problem occurs for any playlist and radio stations that I listen to from Spotify via the Sonos app although I don’t think it’s the same pattern of song skips as above. However, everything plays perfectly when playing directly from either the Spotify iOS app or Spotify desktop app via Spotify Connect to my speakers. Playing other music services from the Sonos app work fine too so it’s just a specific problem of Spotify from the Sonos app.

I have several speakers that are connected to ethernet directly and am using SonosNet. Nothing has changed with my network and everything has been working perfectly for a few years until a few months ago. I was hoping the new S2 app release was going to fix this issue but the issue still occurs.

 

Have waited for this issue to happen again before submitting the answers below together with the diagnostics:

  • What devices do you have?
    • 1 x Playbar, 1 x Sub, 1 x Beam, 4 x Play:1, 1 x Play:3, 4 x One, 1 x One SL (on SonosNet)
  • Has anything changed on the network?
    • No
  • Which service(s) are you trying to listen to?
    • Spotify through the Sonos App (iOS and Mac)
  • Is the behaviour always the same?
    • Yes, song skips in middle and skips the song after as well
  • Can you recreate it with ease, or is it random?
    • It usually happens on the 6th song played on any playlist but it also happens randomly and often after that
  • Diagnostics Number
    • 786680544

Have to admit I am relived to find this thread. If only so I know I am not going crazy. This problem started for me immediately after switching to S2 and now happens so frequently that it’s making my expensive Sonos set-up nearly useless. Have been a loyal customer of Sonos and Spotify for years and years. This problem is depressing. 
 

i switch router channels and rebooted all components of my set-up. Uninstalled and re-installed apps. Still happening. A real bummer.

Userlevel 2

Same story with me as many others here.  Have been streaming via Spotify for over a year, and sometime around a month or two started having the skipping songs issue.  I haven’t changed a thing on my network for over a year as well.

 

Got curious today and went in to the Spotify app, started a playlist and told it to play on one of my Sonos units and no skipping at all.  Can’t see how this is network related, the issue exists when playing a Spotify playlist from the Sonos app, but does not exist when playing from the Spotify app both times listening on the same piece of Sonos equipment.  

I am having the same issue with Spotify titles skipped. Other sources work fine, although I am using mostly Spotify and TuneIn. I also have the feeling that it is always the same tracks getting skipped. No recent changes in my setup either and one speaker connected via Ethernet to router. Diagnostic data submitted: 335506190

Same thing happening to me. Skipping randomly on songs, sometimes it will jump several songs ahead on the queue. It does it multiple times on each listening session.
DIAGNOSTIC CONFIRMATION NUMBER:
1344262772

 

  • What devices do you have?
    2 Play 1s, 1 Play 3 (1st gen), 2 Play 5 (1st gen), 1 Connect, Bridge. 
     
  • Has anything changed on the network?
    No. I talked to service provider and they checked and optimized things on their end. WIFI is on channel 1 & Bridge is on channel 11
  • Which service(s) are you trying to listen to?
    Spotify. 
  • Is the behaviour always the same?
    yes, but not predicable. It skips partway through a song or will just skip ahead on the queue, sometimes multiple songs ahead. 
  • Can you recreate it with ease, or is it random?
    Random

Adding my name to this issue. It’s been going on for a few months now. This always happens when playing an album on Spotify from start to finish. It will start skipping songs around track 5 or 6. I’ve tried changing wifi channels, and also moving my Sonos system from wireless to SonosConnect — both with no positive results. This only happens on Spotify. I’ve tried to recreate the same situation on Amazon Music, and the albums play from beginning to end without any issues. Sorry, do not have a diagnostics report to attach this moment, but can the next time it happens (needless to say, have only been using Amazon Music for now)

 

  • What devices do you have? 
    4 Play:1, 1 Play:3 (First gen); 1 Play:5 (First gen)
     
  • Has anything changed on the network? 
    No. I changed my wifi channel to try and better the situation and did not have an effect. Also switched from wireless connection to SonosConnect with no effect either.
     
  • Which service(s) are you trying to listen to? 
    Spotify
     
  • Is the behaviour always the same? 
    Yes. This specific behavior happens when playing an album from start to finish. The song skipping typically starts around track 5 or 6, will skip 2 songs, then continue playing. Then the same situation will happens again around track 11-12. 
     
  • Can you recreate it with ease, or is it random?
    Recreate it probably 95% of them time. This always happens when playing an album from start to finish, and only happens on Spotify. I’ve tried to recreate the issue while listening to the same album on Amazon Music, but it does not skip and the album plays all the way through.
Userlevel 1

I have the same issue with Spotify on my Sonos system, I have had contact with Sonos support a few times but have given up. I have a subscription to Deezer now, I have no problems with that service, so it seems Spotify is going to lose a customer.

 

My Sonos config: 4x play 1, 1 playbar, 1 sub. Playbar is wired to the router, the rest is on wifi.


My diagnostic number is: 1546107338

  • Has anything changed on the network? 
    Nope
     
  • Which service(s) are you trying to listen to? 
    Spotify
     
  • Is the behaviour always the same? 
    No it's irratic but every now and again a song will interupt and Sonos will skip to the next song in the list.
     
  • Can you recreate it with ease, or is it random?

          It happens so often that it's annoying the hell out of me.

 

I hope you can resolve this issue with Spotify as I'm 100% convinced it's not a local issue of the user network as you seem to think.

 

I have exactly the same problems and have had for several weeks. Only happens when I access Spotify from Sonos and not when I access Sonos from Spotify. Also fine with Amazon. Very annoying. Please sort!

Badge

So I did a bunch of rebooting, unplugged and replugged all my speakers and reset my Wi-Fi. Spotify for the last few days has seem to be pretty good. I haven't noticed nearly as many dropouts, only a few things here and there. My fingers are crossed that this keeps up, but I know that it's an ongoing issue. So hopefully it will keep working. 

Badge

Scratch that - my issues continue. Was fine for a day or so, but now back to cutting out and skipping.

Userlevel 6
Badge +2

I would want to know if the issue is Spotify or Sonos fault. Because the simplest action is to quit Spotify and have a new subscription with Tidal, Deezer, or others.

So if the problem comes from Spotify servers, no qualm to abandon them because they do nothing to fix this.

But… if the problem comes from Sonos software, and not from Spotify, it bothers me to do this… because I have some “loyalty” to Spotify…

So if only we could know who is guilty…..

In the meantime, it’s just shameful that nothing has been made to fix this problem. Is there perhaps a war between Spotify and Sonos? Or is it because Sonos could be bought by Apple…?

Shameful.

I would want to know if the issue is Spotify or Sonos fault. Because the simplest action is to quit Spotify and have a new subscription with Tidal, Deezer, or others.

So if the problem comes from Spotify servers, no qualm to abandon them because they do nothing to fix this.

But… if the problem comes from Sonos software, and not from Spotify, it bothers me to do this… because I have some “loyalty” to Spotify…

So if only we could know who is guilty…..

In the meantime, it’s just shameful that nothing has been made to fix this problem. Is there perhaps a war between Spotify and Sonos? Or is it because Sonos could be bought by Apple…?

Shameful.

 

Sonos is not going to throw a partner under the bus, so asking who to blame is useless. One thing is for sure, Spotify is the most buggy service on Sonos, as most services are relatively problem free.  So take that as you may.  

And no, Sonos is not being bought by Apple.  

I am an IT guy with a rock solid WiFi mesh network. About a month and a half ago songs on Sonos playing through Sonos started skipping songs mid way. I don't buy the WiFi story that it is disconnecting therfore skipping songs. I don't have the issue when streaming songs through Sonos using Amazon music. I spent two hours with Sonos Tech support only to be cut-off after I had sent no less then 5 diagnostic tests to the tech. The tech helping me was nice, but seemed incapable of figuring out my issue. I was then dropped from the call and my issue was never fixed. In my personal opinion there is a problem between Sonos and Spotify interfacing which is causing the songs to skip only when songs are streamed through Sonos onto Spotify. I would like an answer from Sonos and not some bogus your WiFi is causing the issue answer. I am waiting.

Badge

Can anyone confirm if things have been better since the update? Mine has been 100% for the past few days surprisingly, I didn’t want to jump the gun and jinx myself, but I heard back from support today (again) with this:

We just wanted to confirm if these issues are still occurring now. There have been a few things on our end which may have contributed to these errors that have since been resolved.

I wonder if they found an issue with Spotify and were able to rectify it? 

Badge

Can anyone confirm if things have been better since the update? Mine has been 100% for the past few days surprisingly, I didn’t want to jump the gun and jinx myself, but I heard back from support today (again) with this:

We just wanted to confirm if these issues are still occurring now. There have been a few things on our end which may have contributed to these errors that have since been resolved.

I wonder if they found an issue with Spotify and were able to rectify it? 

 

Yes, it seems like the issue is finally fixed! It has been working flawlessly for the last few days without skipping. Wished they would have officially acknowledged that there was a problem though but glad that it’s fixed now. *fingers crossed* 

Badge

I did have terrible issues late last night, but today has been mostly 100%. Crossing my fingers that it’s up and running now for good, but time will tell. 

Badge

No dice. Still trouble at startup and drops from one or more speakers when using Spotify. Going to try YouTube Music for a while again. I'm bummed but for me this is too big an issue to stick with Spotify. 

Badge

Just chiming in once more. I tested all of last week - even took notes - and I have very few issues. Mostly at startup if anything, where it would take anywhere between 10-30 seconds for music to start playing, but only one time did I notice a dropout at all, nothing compared to what it was previously. 7 days strong and I’m confident in Spotify integration. Hopefully, nothing changes from here, but whatever was fixed, thank you!! 

Hi, 

I have been having the same issue since I got a Spotify account in February. I select a song. Plays for around 20 seconds and stops. Restart the song. Stops 20 secs later.. Give us in frustration. 

In reply to your request: 

  • What devices do you have? Living Rm: Playbar, Sub, 2x Play:1; Kitchen: Play:1; Bedroom: Play:1; Boost in 2nd Bedroom 
  • Has anything changed on the network? No
  • Which service(s) are you trying to listen to? Spotify 
  • Is the behaviour always the same? Yes, described above 
  • Can you recreate it with ease, or is it random? Yes, definitely. 

I have tried all of the things I see on threads: powering down all devices and turning back on one by one; changing channels on the Sonos system; etc. 

I have always had an issue with TV sound dropping out in the Kitchen when grouped with the Living Room. I gave up on that a long time ago. 

I would add my concern and disappointment that such an expensive bit of kit only works for TV in the Living Room, my personal music library, and radio stations. I expect it to do everything. 

Diagnostic submitted - Your confirmation number is: 1469798923.

 

 

 

Hi, 

I have been having the same issue since I got a Spotify account in February. I select a song. Plays for around 20 seconds and stops. Restart the song. Stops 20 secs later.. Give us in frustration. 

In reply to your request: 

  • What devices do you have? Living Rm: Playbar, Sub, 2x Play:1; Kitchen: Play:1; Bedroom: Play:1; Boost in 2nd Bedroom 
  • Has anything changed on the network? No
  • Which service(s) are you trying to listen to? Spotify 
  • Is the behaviour always the same? Yes, described above 
  • Can you recreate it with ease, or is it random? Yes, definitely. 

I have tried all of the things I see on threads: powering down all devices and turning back on one by one; changing channels on the Sonos system; etc. 

I have always had an issue with TV sound dropping out in the Kitchen when grouped with the Living Room. I gave up on that a long time ago. 

I would add my concern and disappointment that such an expensive bit of kit only works for TV in the Living Room, my personal music library, and radio stations. I expect it to do everything. 

Diagnostic submitted - Your confirmation number is: 1469798923.

 

 

 

I tried playing Spotify through the Spotify app (instead of Sonos app) and it seems to be working now. Much more stable. Only been a few hours but no more stopping 20 seconds into a song.

You can even select which room from the Spotify app now (not sure if this is new or not.. but I just noticed). 

 

 

 

 

This problem with Spotify only (not occuring with Apple Music) is easily reproductible for me by putting all my Sonos devices on one group and jumping from song to song, or advancing the time in a song, using the S2 Sonos app.  

With Apple Music, I get a normal experience, but with Spotify I get random erratic results of all sorts…

I am using the same song on Apple Music and Spotify to keep the comparison as good as possible.  In the comparison I am doing, everything is identical, with the exception of Apple Music vs Spotify.

Somehow, the Sonos “orchestration” across all devices seems to be good with Apple Music, but not as good with Spotify.