Answered

Spotify keeps losing connection

  • 11 April 2021
  • 5 replies
  • 231 views

Please can you help, my sonos system will not connect to Spotify.  It keeps saying it has lost connection, I have tried all things I can find on the internet and still will not work.]

Please can you help

icon

Best answer by Xander P 12 April 2021, 13:14

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

5 replies

Userlevel 6
Badge +15

Hi @marksappy, welcome to the Sonos Community!

How long have you been experiencing issues with Spotify, and what exact steps have you tried so far?

In general I would recommend rebooting your router (turning it off for about 15 seconds before turning back on) along with any Sonos devices, and if there’s no change, to remove and then re-add the Spotify account completely.

Hi Xander,

 

I have tried all of those things.  It has been happening for the past month or so

Userlevel 6
Badge +15

Understood - mind sharing how your network is set up? What make/model of router are you using, and are there any extenders or mesh systems in use?

Are any of your Sonos speakers connected via Ethernet, or is this a fully wireless setup?

Hi Xander

The router I am using is LINKSYS Model number WHW03 V2  on Gigaclear fiber broadband.

None of my Sonos are on the Ethernet all are wireless.

Mark

Userlevel 6
Badge +15

Got it - it may be worth testing with a speaker connected via Ethernet cable, if there are no issues in this setup then that would point toward interference as being a culprit.

You can also get in touch with our Support Team via live chat or phone call, and they’ll be able to take a closer look at your system and perform some live troubleshooting :)