Answered

SonosNet Greyed out

  • 25 January 2023
  • 17 replies
  • 130 views

Userlevel 3
Badge +2
  • Prominent Collaborator I
  • 59 replies

Hi all. I have my Beam (Gen 2) hardwired with 2 SonosSL as surround speakers (not hardwired). Until recently they were all connected via SonosNet showing WM:0. today SonosNet is greyed out and they are showing as copied below. Any ideas?  The only change recently made was static IP’s for all devices. 
 

Secondary question, Should I disable my Wi-Fi network that I previously used?  Maybe that will “force” SonosNet?  Or does it not work like that? 
 


 

 

icon

Best answer by Stanley_4 26 January 2023, 01:14

View original

17 replies

Userlevel 7

I would check the Ethernet cable is correctly inserted into both the Beam and your router.

Once you get your speakers onto SonosNet, you can remove your WiFi credentials from the app if you do not have any portable devices (Roam and/or Move as they will always connect through WiFi)

Userlevel 3
Badge +2

I would check the Ethernet cable is correctly inserted into both the Beam and your router.

Once you get your speakers onto SonosNet, you can remove your WiFi credentials from the app if you do not have any portable devices (Roam and/or Move as they will always connect through WiFi)

unplugged and re-plugged in Ethernet and back to all WM:0 on all. Is it best practice to remove Wi-Fi credentials or just let it go since all is working?

 

Thanks again

Rick

Userlevel 7

I would remove the WiFi credentials so your system had no option other than to be on SonosNet.

Userlevel 3
Badge +2

Is there ever a reason to change the SonosNet channel?

Is there ever a reason to change the SonosNet channel?

 

It should be different from your router.

Userlevel 7

Is there ever a reason to change the SonosNet channel?

There is always a chance of wireless interference on a given channel. The interference may only be temporary, but changing the SonosNet channel could improve performance if the initial channel started to have issues. You should ensure your router is not broadcasting on the same channel as SonosNet. For you router, also only choose between channels 1, 6 and 11, rather than Auto.

Yes. I had a neighbor move in who was using the same channel as I was using for my SonosNet, so I ended up needing to switch. 

Userlevel 3
Badge +2

Is there ever a reason to change the SonosNet channel?

There is always a chance of wireless interference on a given channel. The interference may only be temporary, but changing the SonosNet channel could improve performance if the initial channel started to have issues. You should ensure your router is not broadcasting on the same channel as SonosNet. For you router, also only choose between channels 1, 6 and 11, rather than Auto.

Good info. So if I understand correctly the Control Channel I should set to 9 (currently using 9 but chosen by auto) and then I should be all set because my SonosNet is channel 6?  
 

Everything else look ok?
 

 

Userlevel 3
Badge +2

 @Mr. T I Also noticed once I choose channel 9 the “Extension Channel” defaults to “Below”.  Assume that is ok?

Userlevel 7

Is there ever a reason to change the SonosNet channel?

There is always a chance of wireless interference on a given channel. The interference may only be temporary, but changing the SonosNet channel could improve performance if the initial channel started to have issues. You should ensure your router is not broadcasting on the same channel as SonosNet. For you router, also only choose between channels 1, 6 and 11, rather than Auto.

Good info. So if I understand correctly the Control Channel I should set to 9 (currently using 9 but chosen by auto) and then I should be all set because my SonosNet is channel 6?  

Everything else look ok?

No, set the Control Channel to either 1 or 11, as SonosNet is on 6

You can also change the bandwidth to 20MHz only.

 

 @Mr. T I Also noticed once I choose channel 9 the “Extension Channel” defaults to “Below”.  Assume that is ok?

I don’t have an “Extension Channel” option on my Asus router. If you can disable that setting then I probably would.

Userlevel 7
Badge +21

While poking about you may run across a Sonos option to disable WiFi.

DO NOT do that as what it really does is turn off the internal radio.

That would be the radio that is also used to connect to the Surrounds and Sub.

Userlevel 3
Badge +2

@Mr. T  So I removed my Wi-Fi credentials as I had my beam hardwired and all surrounds set through SonosNet (WM:0). Today this is where I’m at.  I’ve unplugged my Beam and plugged back in but no dice.  Does the system need to still keep in touch through my Wi-Fi periodically or should it not be acting like this?

 

I have my Beam hardwired through a switch and internet is working fine for the two other devices on that same switch.  Not sure what is the cause?  I can even see that the Beam is hard wired through my ASUS router?

 

 

@RaultTN 

It certainly should not be behaving like it is - removing the WiFi credentials is the ’usual’ thing to do when running your setup on SonosNet, if you do not have any portable Sonos products (Roam/Move) as part of the system - Some things to check are:

  • Your Ethernet cable to the Beam (try a different cable).
  • Try a different port on your switch, or wire the Beam direct to the router instead.
  • Ensure the Beams WiFi adapter is not disabled.

After checking the above reboot the router and players.

Userlevel 7

The system should not be acting like that. Wiring the Beam should create a stable system.

Is your phone connecting to a different network? Or do you use any extenders?

Otherwise, try swapping around the connections on the switch to see if it also occurs using a different port. Is it a simple switch, not a managed one?

Consider a bad network cable to BEAM.

PING BEAM to make sure that it is connected.

Userlevel 3
Badge +2

Thanks all. Ok so all I did was disconnect and reconnect (same port) the Ethernet cable from the beam to the switch. We’re back. Does that indicate a bad cable potentially?  I noticed the little green light in the Switch was not lit up for that port until I unplugged and plugged.   Switch is a simple switch (not managed). 

@buzz @Mr. T @Ken_Griffiths 

Userlevel 7
Badge +21

Likely just loose or a bit of crud or corrosion if the unplug-plug fixed it.

You might check the locking tab to insure it is working well.

Reply