Answered

Sonos speakers stopped directly playing songs from Apple music

  • 13 December 2022
  • 11 replies
  • 519 views

I have a pair of Sonos 1 speakers (set up as a stereo pair), Move and a Roam speaker. All of the  speakers were working perfectly but now none of them will play music directly from Apple music. The speakers respond to the command (ex. they say now playing xxx song from Apple music but then they don’t play anything, it is just silent). They do respond to other voice commands (ex. they will tell me the weather forecast or time if I ask). The speakers work fine when I play music from my phone and connect to them through airplay but not directly. I am not sure why they stopped doing this but any advice?  Thanks

icon

Best answer by Corry P 16 December 2022, 16:38

View original

11 replies

Userlevel 7

What voice assistant are you using? Have you tried removing and re-adding the voice assistant?

edit: just seen the Alexa tag in your post

Thanks Mr T. I am using Alexa. I did already try that but it does not fix it. The speaker does respond to voice commands, it just doesn’t paly the music :-(  

Userlevel 7

The other thing to try, is to disable and then re-enable the Sonos skill in the Alexa app

Thanks, tried that and unfortunately it did not help.

Userlevel 7
Badge +18

Hi @GarryP 

Welcome to the Sonos Community!

If the speakers will play Apple Music from the Sonos app but not via Alexa, please remove Apple Music from Alexa (in the Alexa app) and add it back on again.

If the speakers will not play Apple Music from the Sonos app, please remove Apple Music from Sonos and add it back on again.

Remove a music service account from Sonos

Add a music service to Sonos

I hope this helps.

Thanks Corry, I tried that and unfortunately it does not help. The speakers will respond and play Apple music when the voice command is “Hey Sonos” but not Alexa (but Alexa responds to other commands like weather etc., it just won’t play music). When I use Alexa, the speakers respond correctly and say they are going to play the song but then nothing happens.  I don’t understand because it used to work perfectly, then just stopped responding to Alexa.

Userlevel 7
Badge +18

Hi @GarryP 

That’s great info - the fact the Sonos Voice Control can play and Alexa cannot narrows things down quite a lot.

I think the likely issue is that the security token that gets exchanged between Sonos, Alexa and Apple servers relating to your respective accounts to make such a request actually work has been corrupted in some way.

To remedy this, please try the following steps:

  1. In the Sonos app, remove all instances of Alexa from your Sonos system
    • From the Settings tab, press Services & Voice

    • Under Voice, tap Alexa

    • Press the Sonos product that’s using the voice service, then press Remove. Repeat until no Sonos rooms have Alexa
  2. In the Alexa app, find the Sonos skill and disable it
    • More » Skills & Games » Search icon » Sonos » Disable Skill
  3. In the Amazon shopping website, log in to the same account used for Alexa and remove links to Sonos devices
    • go to Account » Devices & Content » Devices. De-register all entries relating to Sonos devices.
  4. In the Sonos app, add Alexa to the rooms you’d like it in. This will remake all the links intentionally broken in steps 1, 2 and 3
    • Tap the Settings tab. select Services & Voice > Under Voice, Add a Voice Assistant (or Add a Service in Sonos S1) > Amazon Alexa

I hope this helps. In the meantime, you could of course just ask Sonos Voice Control to play music rather than Alexa.

 

Thanks Corry! That seems to have fixed it. I really appreciate your help! It was getting frustrating trying to find the problem.

Userlevel 7
Badge +18

Hi @GarryP 

Fantastic news! I’m partly glad because the next thing to try is lengthy!

You are very welcome!

Thanks for updating the thread.

I have been having the very same issues described by @GarryP and have searched high and low.  I was at the point where I thought something was seriously wrong with my Sonos.   I came across this thread yesterday...and used the steps described by @Corry P


OMG!  It worked!!  My music is playing again and all is good.   Thank you both!!!

Thanks @Corry P! after +1.5 years without being able to hack it (reading all sorts of enabling/disabling posts) you did it!! Rock on!

Reply