Sonos S1 desktop controller only works with public network

I have several Sonos speakers connected to my home wifi network. For many years, I’ve been able to control the speakers both with the Android app and the Windows desktop app.

However, after I reinstalled Windows 10 today, the Sonos desktop app can’t find my Sonos system, unless I set my wifi network as a public network in Windows. The Android controller is still working fine.

I have checked my Windows firewall settings and reinstalled the Sonos desktop app several times. I have followed all the steps in Sonos’ configuration guide, where step 4 emphasizes that the network profile must be set to private. But the only way I can get the desktop controller to connect, is to do the opposite, and set it to public.

For obvious reasons, I don’t want to define my home wifi as a public network. Does anyone have a solution to this?

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

2 replies

Userlevel 7
Badge +23

This is the opposite of normal. Sonos requires networks to be marked as Private to Windows, so that the firewall allows inter-device communications.

Based on your wording I think there might be some confusion: a network marked as Public is not a security risk, are you confusing Window’s concept of public/private networks with the more general concept of public (eg Starbucks) wifi networks?

Yes, it’s the opposite of normal. I have tried with a third party app, which works as expected. But I would prefer using the Sonos app.

I’m not confusing the two consepts of public/private. The reason I don’t want to mark my home wifi as public, is that it would make the firewall prevent some of my other apps from communicating. I’m sorry if the opening post was unclear.

Now I have also installed the Sonos app on my Windows 11 laptop, and with the same result. The app can only find my Sonos system if my home network is marked as public.