Answered

Sonos continues to skip songs

  • 7 October 2020
  • 5 replies
  • 230 views

I am convinced something is wrong with one of my speakers, but I am trying to diagnose it.  In playing apple music, using the S2 app, directly to a Sonos Play one, songs will play half way through, then skip to the next, or will skip several resulting in long periods of silence.

I have tried unplugging the device and plugging back in, I have tried moving closer to an access point, I have tried rebooting the network (which should not be a resolution unless it only has to be done with updates).  Nothing seems to be fixing this.

Playing from the app should be the purest way of playing anything (it cuts out Alexa, it cuts out airplay, etc).

What else can I try?

icon

Best answer by Airgetlam 7 October 2020, 16:57

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

5 replies

Unplug all Sonos devices from power, then reboot your router. When the router comes back up, plug the Sonos devices back in.

Might be worth reading through the wifi interference FAQ as well, as it also can cause similar symptoms to what you’re describing. 

Unplugging every Sonos seemed to do the trick.  I even tried it once and had missed unplugging one, so I did it again with all unplugged.  I am listening to the same playlist, from the same location of the house, on the same speaker with no issues today.

Finding a time of day to take do a wifi reboot was the biggest difficulty. :)

It’s a good ‘temporary’ fix, but your router can potentially get back into that same status in the future. Might be worth looking in on how to set up reserved IP addresses in the router’s manual, and assign them to all your network devices. 

Sonos loves to blame problems/skipping songs on poor Wifi.  Playing music through a streaming service works well with Sonos.  If you’re trying to play your own stored music through Sonos, it is crap!  It randomly skips over songs and gives the error message that it has lost connection, even though it plays the next song and if you try to move it back to the skipped song, it still skips at the exact same point and gives the same error message.  Buying one of their boosters does NOT solve the problem.  The problem is with Sonos accessing stored music even on incredibly high speed Wifi.  Don’t let Sonos convince you that it’s a problem with your Wifi.  The problem is with Sonos.

Userlevel 1

As an additional note,  I have had this same problem recently.  Posting my solution here, for those that might need it, in addition to the OP answered solution.

Well, in the end, this problem of Sonos instability and speakers not all joining quickly when grouped, songs skipping regularly, was solved by pulling the one ethernet cable out of the central speaker, and forcing Sonos to use the house wifi for all music streaming.  Everything is rock solid now. 

Normally, conventional thinking is to use ethernet connection whenever possible.  But in my case, and I’m sure others, the conversion of your system to SonosNet when you do this, can cause some distant speakers to not operate smoothly.

This likely only works in a robust mesh wifi system, like we have running here (central wifi router, 4 distal wifi points, each ethernet backhauled).  Even with all 16 speakers playing music, I am stilling getting gig speeds to my other devices on the network.

For some having the problems described, you might try ditching the ethernet connections, see if notice a positive change.

 

Stephen