Question

Sonos app won't connect to Brennan B2.

  • 8 October 2020
  • 4 replies
  • 1245 views

Hi all,

I have been using Sonos for many years and used to have my generic NAS drive as music library. Now we have a Brennan B2, so I removed the old music library and followed the steps set out by Brennan to connect the B2 as my new music library.

However, after selecting the music folder through the “Add Shared Music Folder” process on the Sonos app, I get an error message. “Sonos was unable to add the music folder”

  • Folder name, login and password are correct (copied from Brennan’s website).
  • I can connect to the Brennan B2 on my Win 10 laptop, so I know the NAS connection on the B2 works.

Neither the Sonos app nor the Sonos program on Windows will let me connect the B2 as a music library.

I would be grateful if anyone had a suggestion how I can get the two connected.


This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

4 replies

Check the settings on this device to ensure that SMB v1 is allowed. Sonos still requires v1 to access the NAS.

Thanks, Airgetlam.

Do you know how I can do that on my phone? Android or Apple.

Or ist it a one-time only requirement that I could do from my PC?

Userlevel 7
Badge +17

You should turn on SMBv1 on your server, so the Brennan, I presume.

Did you take a look at this? https://www.brennan.co.uk/itemcontent.php/content/Sonos

I read the Brennan instructions about 10 times. ;-)

I find the Brennan on my laptop without any problems. Switched on the NAS setting as suggested. It's Sonos that refuses to connect to it.

 

I receive the error message "access to the share \\BRENNANB2\music denied - check username and/or password".

I copied & pasted the info from the Brennan website, so no typos (by me).

 

​​​​​​Reading about SMBv1 it sounds like something I don't want to activate on my network became of security risks. And it is Sonos that requires it... So not sure how to solve this. Other than plugging it into aux.

 

​​