Answered

Since iOS 14 Unable to Connect to Sonos System

  • 30 November 2022
  • 19 replies
  • 408 views

Badge

It’s been doing this since iOS 14.   Gives the two error messages on the Sonos app - “unable to connect to Sonos” also says “join a nearby Sonos system”.  You can follow these steps but it seems to just forget the Sonos system once again.

 

Had this Sonos system for years and it only started with iOS 14- any ideas?

icon

Best answer by Ken_Griffiths 1 December 2022, 23:48

View original

19 replies

Just updated to iOS 16.1.2, and still no issues.

Can you describe your network, and the router in use? I’m wondering if your iPhone is connecting to a different subnet than your Sonos is on. 

Badge

gosh darn it- I’ve got a head cold and got the iOS version number, wrong.  

the problems started with iOS 16.  I am all on the latest stuff. 

 

Im using a netgear router, there is only one wifi network in the house.  I’ve got a Sonos BOOST as well that is plugged directly into the router.   

this all worked perfectly pre iOS 16.

Badge

the other piece of relevant info- My Sonos Mac app has no problems connecting to my system- it’s just my Sonos app on my iPhone.

Have had a head cold before, completely understand. Either before cold medicine or after….I’m equally mentally vague at both points in time :) Although there are some who might say I’m always that way….

I also have a NetGear (Nighthawk R6400) and use a Western Digital NAS to store my music. Which NetGear router are you running? 

Its odd, though since you’re using a BOOST. Have you checked that all speakers in your system are showing WM:0 for all speakers? Look in Settings>System>About my system for that data. If any of them are showing WM:1 (other than the Roam and Move, which should always show WM:1), try a quick reboot of the speaker, and see if it moves over to WM:0.

Which speakers do you have in your system? Are they S1 or S2 devices? 

There’s also some sort of security setting in iOS Wifi that I’m not really cognizant of, which I rely on @Ken_Griffiths to explain, as he knows much more about it than I do 🙂 I should pay more attention, it’s fixed a lot of folks systems. @Ken_Griffiths , is it the Private Networks flag under my wifi settings?

Yes, there is a security feature within the iOS network connection settings that does MAC address ‘spoofing’ for the Wireless Adapter called ‘Private Address’. It can sometimes cause issues with some router connections - perhaps try switching it off.

See the attached image on how to find the setting within the current network connection in the iOS settings.

Badge

My Router: Nighthawk RAX80    

All are S2 and all show WM:0- see below. 

 

 

Associated Product: 192.168.1.10

---------------------------------

Sonos One: Bathroom

Serial Number: 48-A6-B8-FB-07-B0:6

Sonos OS: S2

Version: 14.19.1 (build 70335220)

Hardware Version: 1.26.1.7-1.2

Series ID: A201

IP Address: 192.168.1.12

WM: 0

---------------------------------

Beam: Bedroom

Serial Number: 54-2A-1B-83-93-1E:C

Sonos OS: S2

Version: 14.19.1 (build 70335220)

Hardware Version: 1.23.1.11-1.2

Series ID: A101

IP Address: 192.168.1.14

Audio In: Dolby Digital 2.0

WM: 0

---------------------------------

Sonos Five: Bedroom Aux

Serial Number: 34-7E-5C-D2-7A-7C:4

Sonos OS: S2

Version: 14.19.1 (build 70335220)

Hardware Version: 1.30.1.5-1.2

Series ID: D100

IP Address: 192.168.1.11

WM: 0

---------------------------------

Boost: Boost

Serial Number: 78-28-CA-76-9D-EA:E

Sonos OS: S2

Version: 14.19.1 (build 70335220)

Hardware Version: 1.12.1.2-1.1

Series ID: A100

IP Address: 192.168.1.17

WM: 0

---------------------------------

Sonos Arc: Living Room

Serial Number: 48-A6-B8-BF-99-45:2

Sonos OS: S2

Version: 14.19.1 (build 70335220)

Hardware Version: 1.27.1.8-1.2

Series ID: A100

IP Address: 192.168.1.30

Audio In:

WM: 0

---------------------------------

Sonos One: Living Room (RS)

Serial Number: 48-A6-B8-FE-A4-C8:3

Sonos OS: S2

Version: 14.19.1 (build 70335220)

Hardware Version: 1.26.1.7-1.2

Series ID: A201

IP Address: 192.168.1.26

WM: 0

---------------------------------

Play:3: Office

Serial Number: 00-0E-58-7F-0E-40:4

Sonos OS: S2

Version: 14.19.1 (build 70335220)

Hardware Version: 1.8.1.2-1.0

Series ID: A100

IP Address: 192.168.1.10

WM: 0

OTP:

Just for clarity, it’s called (on iOS 16.1.2) Private Wi-Fi Address, and is exactly where @Ken_Griffiths indicates.  Mine turns out to be “on/green” but it certainly would be worth trying it off, and then trying it on, with tests in both states. 

Nice router. It’s the one I’m thinking of upgrading to, at some point in the “can the wallet afford it” future. 

Just out of curiosity, and because I think I’m out of ideas, what happens if you turn off the Wifi 6 part of the router’s software, and just go with the old, bog standard, “the way it was” wifi signal? I’m wondering if the iPhone isn’t prepared (as I type that, I’m wincing) to connect properly new hotness. Or maybe the S2 controller isn’t? Worth a test, at least. No cost involved.

If that fails, I’d definitely be submitting a diagnostic both from the iPhone, and your other controller for comparison purposes, and calling in to Sonos to discuss. 

As it’s just an issue with the iPhone App, perhaps try an App reset on that iDevice via…’Settings/App Preferences’. On reopening the App, skip the opening screens, but accept T&C’s and allow network access and connect the App back to the ‘existing’ Sonos system and see if that fixes the issue.

Also don’t forget to sign into your Sonos account again in the App 

Badge

Yes, there is a security feature within the iOS network connection settings that does MAC address ‘spoofing’ for the Wireless Adapter called ‘Private Address’. It can sometimes cause issues with some router connections - perhaps try switching it off.

See the attached image on how to find the setting within the current network connection in the iOS settings.

hey Ken- turning this off on iOS seems to have done the trick.  note on my Mac I have this turned on but it doesn't cause the problem.   

It seems to be connecting via iOS now- is there a way I can keep this feature on yet still connect to Sonos?

’Private WiFi Address’ is really only needed when using public networks, it’s a feature that was introduced so that your device cannot be tracked as it moves between those different public connections.

On a Home network, it’s really quite unnecessary, so I just leave it off when at Home.

By default, it will switch itself back ‘on’ for connections to other networks outside the Home anyway, so I would perhaps just leave it as is whilst at Home… I have always had it switched off at Home, ever since Apple introduced it on their mobile devices.

Well, that’s annoying. The ‘Private WiFi Address’ trick is not working here. Did restart iPhone & iPad, no luck. Two hours ago I was happily listening to a podcast via Apple app, and coming back from shopping, AirPlay not working anymore.

I use an iPhone 13 mini. And an iPad. The recent update really stuffed things up.

Am now considering a hard reset of the speaker (Ikea Symfonisk Picture Frame) but before I do so, are there any other tricks I could try? Calling customer service Sonos was unsuccessful. After 20 minutes no change in the tune, not even acknowledging that I actually called Sonos, I just hung up.

I don’t want to use the sono app for my music. I pay Apple. And I want to be able to see the lyrics of songs. Not possible with sono. Quite disappointing.

Can’t find how to edit so doing it this way. A friendly Sonos customer server on the chat helped me out. Unplugging of speaker and router was enough to reset it all. It’s working fine! Thanks to Jeffrey on the chat. Hope more people will find this useful.

Can’t find how to edit so doing it this way. A friendly Sonos customer server on the chat helped me out. Unplugging of speaker and router was enough to reset it all. It’s working fine! Thanks to Jeffrey on the chat. Hope more people will find this useful.

Yes usually a reboot of the speaker and/or router will resolve an AirPlay issue. Good to hear you sorted it.👍

Badge

Hey Ken-

so it -appeared- resolved when I was able to login to my Sonos system yesterday.  But today it's acting up again.  A bit more random tho in that if I just exit the app and try again it often resolves. any ideas?

Perhaps a router setting that makes it more able to find Sonos on my mobile device.  Again this does not happen at all on my Mac.

@JSBintheCity,

The Sonos App uses SSDP multicasting to discover the speakers on the network, sometimes (occasionally) I’ve seen this non-discovery issue too, usually with my iPad Pro (3rd gen), but as you mention, closing the App and toggling the WiFi off/on will also sort it for me, usually …then it’s fine for a while.

I don’t get the issue so much with my iPhone XR, nor with my (cheap) Android tablet …so I’m not sure if there’s an issue with some of these iOS devices🤷‍♂️ - I’ve not (yet) found the cause to this one, but here’s hoping things improve with each new update, from Apple and/or Sonos.

I currently run my Sonos system on a mesh WiFi system. One of the mesh Hubs is my router and the ISP provided router is operating in modem mode. I do have more success with my Sonos system running on SonosNet (one device/Sonos Port, wired to the primary mesh Hub) - that works well for device discovery, but I’m just a sucker for punishment and presently running all on the WiFi signal instead.

I think you are using a Sonos Boost and a SonosNet connection, so you might find that trying a different SonosNet channel will improve things for you.

Its best to set the routers 2.4Ghz Wifi channel to 1, 6 or 11, as they are non-overlapping channels, and also set the channel-width to 20Mhz only to reduce interference.

Then set the SonosNet channel, so it’s at least 5 channels away from your chosen router channel and see if that improves the discovery issue for you. I would also reserve all your Sonos IP addresses in the routers DHCP reservation table, if you know how to do that, as that really helps with these things too.

Note too that ‘WiFi Calling’ and security/vpn software on the mobile controller device can sometimes interfere with Sonos device discovery, it’s ‘sometimes’ slightly more problematic if using wireless extenders, or EOP adapters, as part of the network aswell.

Hopefully something in the above few paragraphs however may help you to resolve the discovery issue.

HTH

Badge

So I’ve tried all the steps but I’m still getting this problem.   

I’ve turned off private relay, changed the wifi channels, I’ve made sure im on WM0, I’ve turned off wifi calling.  I don’t have any VPN software.  

I did *try* and reserve DNS addresses by going into Lan settings but it seems to keep forgetting the ones I add.  This is likely some sort of user error or some other incompatibility.  

do you have any other ideas? These problems did not start until the fall with the new version of iOS.

So I’ve tried all the steps but I’m still getting this problem.   

I’ve turned off private relay, changed the wifi channels, I’ve made sure im on WM0, I’ve turned off wifi calling.  I don’t have any VPN software.  

I did *try* and reserve DNS addresses by going into Lan settings but it seems to keep forgetting the ones I add.  This is likely some sort of user error or some other incompatibility.  

do you have any other ideas? These problems did not start until the fall with the new version of iOS.

What WiFi channel are you using for the 2.4 GHz band on your router and what is the channel-width? Also what SonosNet channel are you using and how far away is the wired Boost from your router (I’m assuming you have it wired direct to the router?)

Badge

Sonos is on 11 and the Router is on 1. 
But remember, my desktop Sonos connects thru wifi also and is fine.  Doesn’t that imply its’ related to iOS?

Just as a note, I’m somewhat confused by the ‘DNS settings’ comment, as I am relatively sure that @Ken_Griffiths was suggesting reserving IP addresses,  and not changing DNS. 

They are two very different things. 

Reply