Music Library will not successfully get imported in S2 PC app

  • 18 March 2023
  • 4 replies

I am setting up a new S2 system in a 2nd home. The system is all connected and working fine and I am trying to attached an established music library on a NAS drive which I used on the S1 system before for years with no problems. It is a big library with over 25,000 songs. When I attach to it I am told that I am connected and that it is scanning the library. After a few minutes it fails with a message that says: “//xxxxxxx/” is no longer available. The device where the music files are stored may not be powered on, or the path may have changed.” … meanwhile I am connected to that file share with no issues from various PC’s on my network. Sometimes it fails in 3-4 minutes, sometimes it runs 20 minutes and fails. The Buffalo NAS drive is always online and connected and has no issues.

I have tried following the ridiculous advice: unplug all sonos devices, the nas and reboot the router and then when the router is back online power up the sonos and NAS devices and try again. It makes NO difference. 


Best answer by Ken_Griffiths 18 March 2023, 22:27

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

4 replies

Maybe try changing the version of the SMB protocol to v2 (or higher) on the NAS box share. Use the netbios name, or it’s allocated ‘fixed’ IP address in the path and ensure the ‘share’ username and password are correct and see if that perhaps solves the issue.

Try segmenting your library slightly. For example: rather than having one large music folder, break it into smaller folders such as:


You can define up to 16 library segments.

I suspect that there might be a timeout due to the large number of files being processed in one gulp. Breaking the library into smaller pieces will reduce the processing time. The only difference to the system user will be in the Music Library’s Folders View.

I’ve never had to do that before and that is a lot of work due to the size of the library. Also it is just uneccessary (unless their software is that sloppy) and certainly, sonos should warn if that’s a potential problem. But they have no such notices anywhere. I’m not the first person to transfer a large library to a new system.


So here’s another data point. I had been doing the updating on a laptop on the wireless network and that was the one that kept failing. It turns out I also have a little pc on the networked, with a wired ethernet connection. After I got home two days ago I tunnelled into that PC and installed the Sonos app and then loaded then entire library in one gulp! The odd part was without my explicitly deleting the 6 or so smaller folders that hat been attached that were buried within the library, when I was testing, Sonos deleted those references. 

But now, for no good reason, it is working fine.


Userlevel 1
Badge +1

i’m having exactly the same issue, my S1 system is happily indexing and using a 22K track library stored on a QNAP NAS but my S2 system has recently started exhibiting the same problem described above. I’ve tried several things, resetting router, switches etc however nothing has fixed it and I constantly get the “server is no longer there” a few minutes after it starts indexing. I’ve opened a case with Sonos and they assure me the developers are working on a fix. I presume there’s a lower timeout threshold on the S2 platform when retrieving directory contents or something. I’m surprised they don’t catch something as basic as this during QA.