Answered

Music Library Folder Address

  • 29 October 2021
  • 12 replies
  • 221 views

I have a music library on an external USB drive to a Samsung Galaxy tablet. I have just “upgraded” to Sonos S2. Now when I want to “Add Shared Music Folder” to the Music Library Setup, it no longer gives me an option to browse, I can only fill in a box that wants an address string for the folder.

Whatever I try for the folder, I only get the response that “The computer ……. cannot be found”. I am guessing at the folder path so I assume that it is wrong, but it may be right and I have some enable/disable settings wrong on the tablet which is what much of the frequent problem advice seems to suggest.

What should the folder address be so I at least start with that correct? \\Galaxy Tab A (2018, 10.5)\Tablet\USB Storage 1\Music\ is a typical failure.

 

 

icon

Best answer by John B 29 October 2021, 20:14

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

12 replies

As far as I am aware, it has never been possible to include tracks stored on a mobile device, or on a drive attached to one, in a Sonos Music Library. 

You might be able to access the tracks via "on this mobile device", although I wouldn't bet on it.

It’s not a Samsung mobile phone, it’s a tablet. And it’s a tablet I was forced to buy when Sonos stopped allowing me to make system changes on my desktop.

It’s not a Samsung mobile phone, it’s a tablet. And it’s a tablet I was forced to buy when Sonos stopped allowing me to make system changes on my desktop.

 

“Mobile device” is a standard industry term for a phone, tablet, phablet, etc.  Anything running a mobile Operating System like iOS or Android.  

As @jgatie has explained, I never thought or suggested that you were talking about a phone.

You can still keep your library on a computer and still update and maintain it using the desktop controller. You can reindex and play tracks from that library using any Sonos controller, including one on a mobile device, such as your tablet.

Your attempt to set the library up on the tablet (or a drive accessed through that tablet) is misguided and doomed to failure. 

Ah, OK thanks. This was an attempt at a workaround because I could not access the library on a computer. When I try to add the comuter music folder path I get an “Adjust File Sharing Settings” pop-up that I can’t get away from. I have checked/unchecked the appropriate boxes in my Norton 360 firewall, but not the Windows Firewall which is not operating. Could the Windows firewall settings be stopping it, even though the Windows firewall is not operating? Do I have to switch from Norton to enable the Windows firewall just to check its settings?

It may be that a Windows update has disabled SMBv1 file sharing, which I think Sonos still needs. 

I can't remember how you re-enable that but Google is your friend.  It might not be that, but it's where I'd look next.

Also check that your home network is classified as private not public and has file sharing enabled. 

Ah, OK thanks. This was an attempt at a workaround because I could not access the library on a computer. When I try to add the comuter music folder path I get an “Adjust File Sharing Settings” pop-up that I can’t get away from. I have checked/unchecked the appropriate boxes in my Norton 360 firewall, but not the Windows Firewall which is not operating. Could the Windows firewall settings be stopping it, even though the Windows firewall is not operating? Do I have to switch from Norton to enable the Windows firewall just to check its settings?

 

SMB version shouldn’t matter on the PC if you have installed the PC Controller.  The PC Controller will set up a web addressed share which doesn’t care about your SMB version.  Try installing the Sonos PC Controller and add the music folder from there. 

Thanks, I assume the “desktop controller” or “PC controller” is the Sonos S2 App which I have installed and am using to add the music folder? I believe I have cleared any firewall/SMBv/network issues but I still can’t get past the “Adjust File Sharing Settings” pop-up screen. The “Next” button which gains a Windows Defender logo just takes me back to the previous screen

Since making any changes, have you rebooted your computer? This is often necessary for such changes to become effective. 

Yes, regularly reboot computer. Still no progress. The remaining block seems to be that the Sonos Set Up “Adjust file sharing settings” pop-up that I cannot get past wants me to add the Sonos Library Service to the Windows Firewall exceptions list. This is not an option specifically for me in Norton 360, so I have approved all exceptions there, but it has had no effect.

Userlevel 7
Badge +18

Hi @aceretum 

Welcome to the Sonos Community!

I recommend you get in touch with our technical support team, who have tools at their disposal that will allow them to give you advice specific to your Sonos system and even fix it for you by remotely connecting to your computer’s desktop.