Answered

Music Library connection fails when speakers on Sonos Net

  • 25 May 2023
  • 5 replies
  • 125 views

I recently changed all of my Sonos speakers to a separate Sonos Net instead of direct WiFi (one speaker with a wired Ethernet connection).   This was because Sonos still seems to have issues with mesh WiFi networks - speakers randomly disappear from the list, especially if the controlling phone moves from on mesh node to another.

This worked well to stabilise Sonos (apart from Roam, which unfortunately does not support Sonos Net).

Unfortunately, although the Sonos system now works better for streaming, this seems to have killed access to my local music library on a Synology NAS.   It seems that the music library configuration can’t cope with the speaker and library not being on the same subnet.   Unplugging the Ethernet cable to revert the speakers to WiFi connection brought the library back online immediately.

Is this an issue that Sonos are aware of?  I seem to be stuck in a no win situation here - either no music library access, or accepting that sometimes not all my speakers will be visible to the controller app.

icon

Best answer by Airgetlam 26 May 2023, 07:37

View original

5 replies

Sonos has always required everything to be on the same subnet. There’s never been, to my knowledge, an attempt made to allow an NAS source to be on a separate subnet. 

Though at least one speaker (the one with the Ethernet cable) is on that subnet - and even that one can’t see the NAS when Sonos Net is active ….

It does seem an odd design decision if implementing one of the Sonos standard configurations (Sonos Net with or without Boost) disables core functionality like music libraries.  

SMB is a routable protocol, and the Sonos speakers need to be route aware in order to access streaming services. so the speakers can access some services off subnet.

I’m sure you are right that it’s always been this way - but still puzzling that they would choose to put in that kind of restriction when quite a lot of customers use SonosNet for one reason or another.   It wouldn’t be hard to change the code for this to work.   

However - they do seem to be moving away from supporting Sonos Net at all - from what I’m reading in the forums the new ERA300 systems don’t support this at all.   Given that direction, perhaps they should focus on making the system work better with mesh WiFi.

Not sure I understand what you’re saying. SMB is the protocol that the Linux kernel that Sonos runs that is used to access NAS data. There’s no real relationship between the use of SMB and the restriction that Sonos needs to be on the same subnet, at least that i’m aware of. Sonos does more than average cross communication between devices, likely the reason that the entire system needs to be in the same subnet. However, I’m neither a programmer, nor am a party to the decisions taken in 2000 or 2001 when Sonos wrote the underlying protocol that operates their system. 

What I can say is that the majority of my system of 20 plus speakers work with my NAS, on SonosNet, save the Roam, which can’t connect to SonosNet. But that works across my Wi-Fi as part of my Sonos system, and also connects to my NAS. 

If you’re having connection issues, once everything is on the same subnet, I’d post details, or submit a diagnostic and call Sonos. There would likely be a network issue that’s blocking access to the NAS. 

What I mean is that there is no technical reason why SMB would not work between subnets, so that restriction would have to be a result of the way that Sonos have coded this.  
However, with the exception of Sonos Net, everything on my system (whether wired or wireless) is already on the same subnet, so in that respect, my configuration is the same as yours - except possibly in terms of distance between individual speakers.
Looking at the connection data on my broadband hub, I was surprised to see that the speakers connected on SonosNet actually show up on the same subnet anyway, as if they were all wired - so it looks as if traffic from SonosNet to my home network is bridged by the speaker rather than routed.

When I remove the wired Ethernet connection to one speaker, this means that all speakers connect via WiFi rather than Sonos Net, and then connection to the NAS works for all speakers.  So this can't be a network problem as everything works fine when SonosNet is not involved.

When the Ethernet connection is replaced, the other speakers (except Roam) then reconfigure themselves to use Sonos Net, and only connect to the main subnet via the speaker with the Ethernet cable. Roam is always on WiFi.
The problems start to arise when the cable is replaced, and speakers return to Sonos Net.  I do have a bit more detail on this.  Initially it all seems to work, until the Music Library index is updated.  The index update fails with an error about the library file share no longer being available and after that, the devices on Sonos Net can no longer play any files from the library.  The speaker with the direct wired Ethernet connection still has access, as does Roam (still on main WiFi), but as the index is not being updated, any new files will not be visible.

I'm guessing as to possible explantions:
Perhaps one or more of my speakers is too far from the others for SonosNet to have a reliable connection, but the house WiFi signal is stronger?  I believe the index has to be on all the speakers, so one weak link would probably break the process.
I only have 8 speakers in total (four of which are in stereo pairs), so the distances are probably greater that in your 20 speaker system.
If this is the case, then maybe the heavier traffic generated by the indexing process makes the issue worse?

For the moment I have just reverted to having all speakers directly on WiFi, as this way the the Music Library is reliable, including regular index updates.  It also seems that since the last software update, that Sonos seems to work a bit better on mesh WiFi networks, so the need to use SonosNet has gone away for now - which may be as well given that the most recent new products don't support it anyway (ERA300 etc.)

Many thanks for your suggesttons on this.

Userlevel 4
Badge +4


Looking at the connection data on my broadband hub, I was surprised to see that the speakers connected on SonosNet actually show up on the same subnet anyway, as if they were all wired - so it looks as if traffic from SonosNet to my home network is bridged by the speaker rather than routed.

 

 

That is, because the SonosNet is indeed just a bridge to your network, it is not a separate subnet so there is also no routing needed. Why your smb share don’t work is hard to tell, but certainly not because it’s a different subnet. If you still prefer a wired setup, I would suggest to reach out to Sonos support as they have diagnostic tools to see what’s going on.

Reply