iTunes music library on QNAP NAS no longer working

  • 21 January 2023
  • 4 replies

I know this topic has been posted a few times, but I have not seen a recommendation that works for me.


For years, I’ve stored an iTunes music library on my QNAP NAS, and accessed it as my Music Library via Sonos through this path: //[NAS IP]/homes/music/iTunes Media/Music


A couple months ago, it stopped working.  I removed and re-added my library, but still nothing.  I found a thread about SMB and confirmed that I have S2 and SMB2 on the NAS.  I tried changing the path to have no space between “iTunes” and “Media.”  No change.


Interestingly, although none of my library shows up in Sonos searches in the app my NAS shows up in Browse (perhaps as a Media Server?), and even shows content.  But none of the tracks will play (throwing an error).


The only other thing I can think of is the way Sonos logs into my NAS.  I enabled 2FA on my NAS about 6 months ago, requiring a Google Authenticator code.  Obviously, Sonos can’t enter that.  So perhaps Sonos can’t properly login?  How does one work around this issue?



Best answer by Corry P 23 January 2023, 14:44

View original

4 replies

Userlevel 7
Badge +18

Hi @G60m7 

Thanks for your post!

It’s possible that the 2FA is an issue - the verification should be sent to your preferred device (your phone), but it’s entirely possible our software isn’t willing to wait for this to happen as 2FA isn’t common on NAS drives. I can only suggest disabling the 2FA feature - if only to test.

Please also ensure that the music folder and all sub-folders and files have the correct permissions to allow Sonos to read them.

Failing that, I recommend you get in touch with our technical support team, who have tools at their disposal that will allow them to give you advice specific to your Sonos system and what it reports.

I hope this helps.

I have run into the same problem.  Starting a couple of months ago my Sonos system started behaving very erratically when trying to play music from a library stored on a QNAP NAS - it had been fine for several years previously.  

I tried to renew the music library path in the system settings menu but the system kept giving me an error message to say “unable to add the music share….error 900 “ (I also get errors 1000 and 1002)..  About 1 in 10 attempts to sign into the library were successful (ie the bug is not consistent).

Sonos tech support told me to reset the SMB protocol to SMB1, which I did without success.  Actually, I think this suggestion is rubbish since there are other posts on this forum saying that S2 controllers work with SMB2 and 3. I went back to SMB3 and was able to finally connect to the library on the NAS but only temporarily and failed in an attempt to rebuild the index.  I also downgraded one Sonos component to S1 and tried to add the library using the S1 controller but that didn’t work, either.

I don’t think it’s a QNAP problem. I have two QNAP NAS boxes with different versions of the QTS operating system and Sonos will not connect with either.  The more modern box has 2FA but I do not think that is the issue since I can bring up the NAS folders on my Mac in Finder without having to use 2FA protocols - you only need 2FA when logging into the NAS.

Right now I have had to resort to playing music through the Plex service I have installed on my Sonos system, and that is fine.  Which begs the question - if Plex can access these files, why can’t Sonos?

BTW, Sonos need to smarten up the music library add interface - it would help to have a browse function to locate the relevant folder path for the library to be added.  The current interface is very clunky

Technical details: Sonos S2 app v 14.20; QNAP NAS TS669 running QTS 4.3.2242 and TS253Be running QTS

Userlevel 7
Badge +17

Plex works differently from Sonos. Plex runs on your NAS and runs its database from there, connecting your speakers to the program that runs on the NAS. Sonos runs the databse on the speakers, so needs access to the files from the outside.

I have an update on this.  My case was escalated (sending a vituperative message to the CEO may have helped) and I spent the best of an hour talking to a technician.  After running exhaustive tests on my LAN and system to confirm my network connections were not the problem he volunteered the information that this is a problem known to both QNAP and Sonos and is being worked on - he didn’t say whether Sonos or QNAP updates were the problem but my money is on Sonos since the QNAP box that hosts my music library is an old TS669L which doesn’t get many firmware updates these days.  The same problem may apply to Synology boxes (another reason I think it’s a Sonos sourced problem).

The short term solution is to get a Buffalo NAS to host the library files.  These are simple and cheap, but they do the job.  It’s basically just a disc drive, and won’t host multiple apps in the same way a QNAP box will.