Error 900 while adding music library with MacBook and QNAP Qfinder Pro NAS

  • 12 September 2023
  • 6 replies

  • Contributor I
  • 4 replies

I’m running Sonos S1 speakers from my MacBook Pro with Qfinder Pro Nas which needs SMB1. QNAP upgraded so that SMB1 is not default. Anyone know how I can change to SMB1?

  Any advice gladly received.


Ian j


Best answer by Corry P 15 September 2023, 13:24

View original

6 replies

Userlevel 7
Badge +18

Hi @ijen 

Welcome to the Sonos Community!

A quick Google search for “qnap smb1 enable” produced the following steps:

Configure QNAP NAS for SONOS S1 (Enable SMB v1)

  1.  Open the "Control Panel"
  2.  Click on "Win/Mac/NFS/WebDAV" in the "Network & File Services" section.
  3.  Click on "Advanced Options" Set the "Lowest SMB version to "SMB 1" and click Apply.

I don’t know if these steps will work on your particular QNAP NAS, however.

I hope this helps.

Hi Corry,
Thanks for the info but having followed your steps I don’t have the Advanced Option “Set the Lowest SMB . . . ’’ in that panel. Now waiting for QNAP to reply!



QNAP replied with instructions  - “As you are on an older unit your OS does not have these options in the GUI, so you will need to follow Method 2 for QTS 4.3.6/4.3.3/4.3.4” which involves ‘Open a secure shell (SSH)’ etc”    which is a bit beyond me!

Userlevel 7
Badge +18


Secure shell is fairly easy to work with, even though it does not look user friendly at all. You just need to launch the Terminal tool in macOS, then type “ssh admin@” (without quotes) followed without spaces by the IP address of the device you want to connect to (you can find the IP address of your QNAP by looking in your router’s settings page for connected client devices, or, presumably, by looking at your QNAP configuration page).

Once connected, just copy and paste the commands that QNAP gave you into the window, and type “exit” when done to disconnect.

I just now found the step-by-step instructions on the web, but they are split between multiple pages and not the clearest I’ve ever seen. I’ll compile them into one set of steps for you below:

SSH access the NAS in macOS

  1. Open Finder.

  2. In the menu bar, click Go and select Utility

  3. Open the Terminal app.

  4. In Terminal, use the command ssh admin@YOUR_NAS_IP_ADDRESS (for example: admin@ Note: If this is the first time you’ve accessed your NAS with SSH you will receive an authenticity warning. Enter yes.

  5. Enter the admin password. Note: Your input will not be displayed on the screen.

Change SMB options

Copy each of the 3 lines below and paste into the window one at a time, pressing Enter/Return on the keyboard after each line:

setcfg -e Samba 'Min Protocol'

setcfg -e global 'min protocol' -f

/etc/config/smb.conf /etc/init.d/ restart


Type “exit” followed by Enter/Return to exit SSH, and repeat to exit Terminal.

I hope this helps.

Hi Corry,

Thank you so much for this. I’ve now got my Sonos back linked to my QNAP nas music and enjoying my music again. Followed your instructions - didn’t get the menu showing up but copied the 3 lines as you stated, all working. I’m happy doing stuff on my Mac but going into the Terminal is not my happy place.

 Thank you, much appreciated the info you gave.

Kind regards


Userlevel 7
Badge +18

Hi @ijen 

I’m glad to hear it worked! Thanks for updating the thread!

I’ll remove the part about the menu in case anyone else tries to follow.

Thanks, and you are very welcome!