Connection to Spotify was lost

  • 19 January 2021
  • 19 replies
  • 1671 views

Over the last several months, Spotify has been functioning terribly with the Sonos setup in our household and 8/10 it displays the message “Unable to play ‘X’ - the connection to Spotify was lost.” 

 

This error appears if I choose a song from within the Sonos app using Spotify music services; if I choose Spotify Connect from within the Spotify app it just fails to connect to any Sonos speaker; and if I ask Alexa to do it she confirms the action but then nothing happens. All other music services are functioning correctly on Sonos with no interruptions, so I know it is not an internet connectivity issue. I am also fully confident that my Spotify account is not being used simultaneously on any other device.

 

I have removed Spotify from our music services within the Sonos app, I have reset the Wi-Fi (even created a new Wi-Fi network), and I have also reset all our Sonos products to factory settings - none of these steps have fixed the issue.

 

We have three Play:1’s, one One and a Move. All are connected via the wireless network.

 

This issue is very frustrating as Spotify is the number one music service we previously used on our Sonos’. Any recommendations would be greatly appreciated.

Diagnostics submitted 396472726.


19 replies

Did you try removing the Spotify Account from your Amazon Alexa account, sign out of ‘all devices’ in the online Spotify settings and then recreate the link in Alexa App and then reauthorise the Spotify service in your Sonos App to see if that fixes it for you?

 

Did you try removing the Spotify Account from your Amazon Alexa account, sign out of ‘all devices’ in the online Spotify settings and then recreate the link in Alexa App and then reauthorise the Spotify service in your Sonos App to see if that fixes it for you?

 

Thank you for the suggestion. I followed your instructions but no change. I don’t believe it to be a problem with Alexa/Sonos/Spotify, as it is occurring when working outside of Alexa and using the Sonos or Spotify apps as well. It is something with the Spotify/Sonos linkup.

Did you try removing the Spotify Account from your Amazon Alexa account, sign out of ‘all devices’ in the online Spotify settings and then recreate the link in Alexa App and then reauthorise the Spotify service in your Sonos App to see if that fixes it for you?

 

Thank you for the suggestion. I followed your instructions but no change. I don’t believe it to be a problem with Alexa/Sonos/Spotify, as it is occurring when working outside of Alexa and using the Sonos or Spotify apps as well. It is something with the Spotify/Sonos linkup.

I see you’re from the U.K. the same as me - I subscribe to Amazon Music and subscribe to Spotify Premium too - I mostly use Amazon, but I’ve just switched my default music over to Spotify in the Alexa App and it seems to be working okay here.

Might be an account issue somewhere, perhaps🤔?. Have you checked your account Country settings are okay? 

https://www.sonos.com/myaccount/user/profile/

 

Did you try removing the Spotify Account from your Amazon Alexa account, sign out of ‘all devices’ in the online Spotify settings and then recreate the link in Alexa App and then reauthorise the Spotify service in your Sonos App to see if that fixes it for you?

 

Thank you for the suggestion. I followed your instructions but no change. I don’t believe it to be a problem with Alexa/Sonos/Spotify, as it is occurring when working outside of Alexa and using the Sonos or Spotify apps as well. It is something with the Spotify/Sonos linkup.

I see you’re from the U.K. the same as me - I subscribe to Amazon Music and subscribe to Spotify Premium too - I mostly use Amazon, but I’ve just switched my default music over to Spotify in the Alexa App and it seems to be working okay here.

Might be an account issue somewhere, perhaps🤔?. Have you checked your account Country settings are okay? 

https://www.sonos.com/myaccount/user/profile/

 

Yep, region settings both in Spotify and Sonos are set to United kingdom.

You keep mentioning Alexa, but as I’ve said, I don’t believe this is an Alexa app issue. What makes you think it is? I am getting these errors when I am not even using Alexa - they occur when I choose a song from Spotify within the Sonos app. In fact, I have removed Alexa voice services within the Sonos app and disabled the skill in the Alexa app and I am still getting the issue.

It is a Spotify/Sonos linking issue.

Yep, region settings both in Spotify and Sonos are set to United kingdom.

You keep mentioning Alexa, but as I’ve said, I don’t believe this is an Alexa app issue. What makes you think it is? I am getting these errors when I am not even using Alexa - they occur when I choose a song from Spotify within the Sonos app. In fact, I have removed Alexa voice services within the Sonos app and disabled the skill in the Alexa app and I am still getting the issue.

It is a Spotify/Sonos linking issue.

Ah forgive me, I was thinking you were using Alexa to initiate Spotify playback too. I’m not getting the issue here with the App and you’ve certainly done the things I would have tried, as another user.

It might therefore pay you to speak to Sonos Support in that case, you can contact/chat to them via this link:

https://support.sonos.com/s/ 

Also, maybe go onto speak to Spotify Support too, if that becomes necessary/relevant via this link: 

https://support.spotify.com/uk/contact-spotify-support/

Hope you get it sorted.

Yep, region settings both in Spotify and Sonos are set to United kingdom.

You keep mentioning Alexa, but as I’ve said, I don’t believe this is an Alexa app issue. What makes you think it is? I am getting these errors when I am not even using Alexa - they occur when I choose a song from Spotify within the Sonos app. In fact, I have removed Alexa voice services within the Sonos app and disabled the skill in the Alexa app and I am still getting the issue.

It is a Spotify/Sonos linking issue.

Ah forgive me, I was thinking you were using Alexa to initiate Spotify playback too. I’m not getting the issue here with the App and you’ve certainly done the things I would have tried, as another user.

It might therefore pay you to speak to Sonos Support in that case, you can contact/chat to them via this link:

https://support.sonos.com/s/ 

Also, maybe go onto speak to Spotify Support too, if that becomes necessary/relevant via this link: 

https://support.spotify.com/uk/contact-spotify-support/

Hope you get it sorted.

Thank you for your advice Ken, it is appreciated.

I’ve been playing around with them again this evening and it is currently only the Sonos One that is displaying the error, but the issue does come and go between all the speakers at different times. I have done a complete factory reset on the One and even moved it right next to the router (to eliminate the possibility of wireless interference), and still no change.

I’ll contact Spotify tomorrow and see what advice they offer.

Badge

FIX THIS SONOS

Have this problem, too. This was working two days ago. US here. 

Userlevel 6
Badge +16

Hi @dropdx & @Clumsy Clod, Thanks for reaching out and welcome to the community. sorry to know about this issue on Spotify on Sonos, we currently have an outage with Spotify on Sonos, we’re working with our team to have it fixed as soon as possible. You may check the outage status on our website status.sonos.com.

If there is anything else I can do for you, please, don’t hesitate to let me know.

Badge

Thank you. That’s what I was hoping for - an indication that Sonos is aware of a large issue with Spotify and simply reseting everything isn’t going to help.

Hi @dropdx & @Clumsy Clod, Thanks for reaching out and welcome to the community. sorry to know about this issue on Spotify on Sonos, we currently have an outage with Spotify on Sonos, we’re working with our team to have it fixed as soon as possible. You may check the outage status on our website status.sonos.com.

If there is anything else I can do for you, please, don’t hesitate to let me know.

@Simon B, I know you weren’t replying to me but I would just like to clarify that I was having this issue long before any temporary Spotify outage and I still am now.

How come when you direct us to check status.sonos.com it says everything is working?? Thought it was just me having problems. 

 

How come when you direct us to check status.sonos.com it says everything is working?? Thought it was just me having problems. 

I think that was perhaps some hours before your post, it was fixed quite quickly. I didn’t even notice the Spotify outage, personally speaking.

So when Sonos is reporting “Spotify is experiencing a full outage” yet a Spotify alone is working just fine, whee as y on earth died that mean?  Having 8 Sonos speakers all acting like bricks does me zero good. 

Spotify, much like many other services, uses a separate server to provide the services they give through Sonos. So when there is an outage, the particular server that Sonos’ software points to is probably down, while the server that Spotify points their own software to is likely not experiencing the same issue. 

At no point does Sonos have that stream on their servers, under their control. All the controller does is tell the software on the speakers what web server (address) to go and get the stream from, which belongs to Spotify. Sonos does not have the control to change where they are pointed to, they need to point to the servers that the streamer asks for, and has implemented the Sonos API on. 

So when Sonos is reporting “Spotify is experiencing a full outage” yet a Spotify alone is working just fine, whee as y on earth died that mean?  Having 8 Sonos speakers all acting like bricks does me zero good. 

It usually means the Spotify music service available to your Sonos System/Sonos App is not working. It may have no bearing at all in relation to your native Spotify App. Sonos provide a ‘service’ status page here for users to see if there are any current issues:

https://status.sonos.com

Thank you so much for the information Ken, greatly appreciated. 

Having the same issue over tha last few weeks. I have a premiun Spotify plan but cannot use it any more.over Sonos.

I have tried pretty much everything; resetting speakers, reauthorization os Spotify over Sonos, router restart, etc. No luck though.

All other services play fine over Sonos.

This is very disappointing From Sonos/Spotify.

Any help would be appreciated.

Having the same issue over tha last few weeks. I have a premiun Spotify plan but cannot use it any more.over Sonos.

I have tried pretty much everything; resetting speakers, reauthorization os Spotify over Sonos, router restart, etc. No luck though.

All other services play fine over Sonos.

This is very disappointing From Sonos/Spotify.

Any help would be appreciated.

Assuming Spotify is available in your Country on Sonos and that your online Sonos/Spotify country settings are set correctly for your location, then perhaps try the following.. go online and login to your Spotify account via a web browser and look for and sign-out of all devices on your account. Then remove/reinstall the Spotify App from your mobile controller device and finally do the same thing and remove reinstall the Spotify service in your Sonos App. Just ensure that when logging into your Spotify ‘account’/‘service’/‘app’ that you use the same login credentials. 
 

Then see if that solves your issue. If not, it maybe best to contact Spotify support, or perhaps Sonos Customer Care via this LINK

Reply