connect to library.

  • 3 October 2020
  • 4 replies

Hi my NAS died and I now try to connect a USB device connected to my modem with all the music on to Sonos.  Using the browse option I can see the modem with the Music subfoldetr in the Explorer style search but the ‚Ok‘ button is greyed out and I can’t select the music folder. 

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

4 replies

Does your modem allow a USB device to be used as an NAS? If it does, you need to be sure it allows SMB v1 to be used for access, it’s the oldest version of SMB, and the only one Sonos is currently capable of using to access NAS drive data. Most NAS drives these days use SNB V2 or SMB v3 for security purposes, so an NAS usually needs it to be specifically turned on for v1. 

The modem seems to allow SMB (SAMBA).  Not sure what version so ?  This is enabled but still does not seem to work.


Contact the manufacturer and ask them what version of Samba (SMB) they’re supporting. 

Userlevel 6
Badge +17

Hi @ThomasBo.

Welcome to the Sonos community and thanks for reaching out to us. I understand that your current NAS drive has already failed and would still want to play your own music via USB. Once you have confirmed the recommendation of @Airgetlam, I would like to suggest going through these recommendations to help out as well.

I would recommend the following basic troubleshooting steps:

  1. Reboot the router by unplugging it from power and plugging it back after 10-15 seconds to refresh network connectivity and delete temporary data stored on the router.
  2. Reboot your Sonos Connect.
  3. Force close and re-open the Sonos app
  4. Test if the issue persists.

I would also like to suggest the following guides to check if these things would also help fix the issue.

  1. I had to change permissions for the folder where my music is stored.  It was set to “Custom,” and I changed it to “Read & Write.”
  2. I then went to System Preferences > Security & Privacy > Privacy.  Under “Full Disc Access,” both the Sonos program AND SonosLibraryServer must be allowed.
  3. Finally, the computer name and NetBIOS name must be exactly the same in both System Preferences > Sharing - and in System Preferences > Network > Advanced > WINS.

After that, update the Music Library.

Please let me know how it goes. We are always here to help out.