Answered

Volume control Sonos Playbar through Samsung One Remote

  • 14 February 2018
  • 42 replies
  • 161403 views

Does anyone know how to connect the Samsung One Remote control to the Sonos Playbar so that I can control the volume of the playbar? I tried various ways but can’t get it to work.... I read the the playbar has IR whereas the Samsung remote control has RF but nevertheless there seems to be a way to make them connect. Hope someone can share the ultimate solution for this issue with me!!
icon

Best answer by buzz 19 February 2018, 03:26

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

42 replies

Userlevel 2
Badge +1

Quick question. Can you control volume of playbar via Samsung one remote when tv is off ?(music playing when tv is off)

Userlevel 5
Badge +16

Hi @geoffs87, thanks for reaching out to the Sonos community and for letting us know about your concern. Have you contacted Samsung about this for further assistance? Check your Samsung TV software update and see if it will work? You can only program one remote with your Sonos soundbar, if you will program another remote, it will override the current. If you’re still experiencing the same, you can use a universal TV remote or your cable remote. Please do not hesitate to reach out if you have further questions, additional feature requests, or concerns, we'll be glad to assist you.

The above steps (using Samsung, 4th power test etc) all worked for me, for about a week… and then turned the TV on today, remote not controlling so is. No indicator light flashing on the playbar, but does show up display on TV. Anyone have this issue, where it was once working, and then suddenly stops and can’t resolve using previously successful solution?

Just ran into this issue after unplugging tv and soundbar due to relocating. Here's the fix for my Samsung One Remote not controlling volume, but it still showed a visual response on tv.

Instructions on Samsung TV:Go to Sources -> Universal Remote -> New Device

Select Device Type: Home Theatre System

Select Brand: Sonos

Select Home Cinema Configuration: Optical

Start "Power Test" and now hit "No" (unsuccessful) until the 2th power test, then select Yes (home theatre system turned on/off).

This was the fix for me! Hope this helps!

After searching around for longer than I want to admit, this worked the first time! Thank you 

Userlevel 5
Badge +16

Hi folks,

Thank you for reaching out to the Sonos community. We really appreciate your time and effort in bringing this concern to us. Let me help you with this.

The following steps below will guide you to configure your Samsung One Remote to control your Sonos home theater speaker. If your TV uses an external IR emitter, make sure it’s within line of sight of your Sonos home theater speaker before you begin.

1. Go to the Home menu on the Samsung TV, scroll left, and select Sources.
2. Select Universal Remote. If this is your first time setting this up, you will be asked to set up your Universal Remote. Select Start.
3. Before we add the Sonos home theater speaker, you will first need to complete the remote set up for your cable, satellite, or Blu-ray player. Select New Device and choose the device you’re adding.
4. Once you’ve added your other devices, select New Device, then Home Theater System.
5. Type “Sonos” in the search box, select Sonos from the results, then select Optical for the input.
6. You will be asked to do a power test. Select the Power Test button. When it asks you if it worked, select Yes and then Done.
7. Go back to the Universal Remote setup menu and select one of the other input devices you've added, like a cable box or Blu-ray player. Select the other input devices and choose Use with Home Theater. Do this for all of your active inputs.

Your Samsung One Remote will now output IR and is ready to work with Sonos. Here’s a helpful video about it. Follow the steps in our article on setting up a TV remote with Sonos to finish the process.

If you experience any issues following the steps above, please contact Samsung support for further assistance with setting up the Samsung One Remote.

Please feel free to reach out in the future if you have any other questions. You're always welcome here.

any progress on this SONOS?

It worked for me only after switching off the IR-repeater setting from the Sonos app

I have a beam and a 2016 Samsung TV.  I cannot get the two to communicate at all via the Sonos One Remote - sounds works but no volume control with the remote.  I tried the 4 times.  I tried twice.  No Beam model number.  And no Samsung One Connect, this was model was before that.  And Samsung is no help.  They just say the Beam is not compatible with Samsung.  Any help?

I recently purchased a Q80T and when I setup the Beam, I didn’t have to do anything special to control the volume with the Samsung remote; it worked automatically with the Beam.  I used the Sonos app to optimize the Beam for my environment.

af2k is spot on.  i just got a new 82” Samsung Q7DR. Contacted Samsung support and they told me that the TV would not control volume using an optical connection.  Was coming here to post that info when I saw his instructions.  Works to a T except the App Instructions are different now.  But, find the Remote Control in your app and delete the old one.  When it detects the new one it will find the Samsung Optical and all of a sudden, I can control the volume of the Samsung TV while using its apps.

I just went through this process many times and it does not work with my new 2019 Samsung Frame (model: QN65LS03RAFXZA). I followed af2k’s awesome workaround by pretending the soundbar is a Samsung model and setting the Sonos manually which worked perfectly.

 

Another note: I was on a call with Samsung support and they are useless. They don’t even know how their device works and insist that the remote only uses IR for power signals and nothing else.

Hi

i havs tried all of the suggestions above. The pioneer solution worked but then it stopped working a few weeks ago. I have a frame 2019 model. My connect box is in a different room so there is no line of sight. Can anyone help?

//hasse

Userlevel 2

I FINALLY got my 2019 Q80R Samsung One remote to work my Sonos Playbar’s volume and mute functions. Similar instructtions to those above by MNS1974 with a few changes (2019 model TVs?)

Instructions on Samsung TV:

Go to Source → Universal Remote → New Device → Home Theatre System 
Select Brand: Sonos → Select/Search… This is where it gets weird - search for “Playbar” but it never worked for me when I selected “Playbar” from the list but DID when I selected “PBAR1USBLK” from lower in the list. Once selected, choose “Optical” as connection type.

Start "Power Test" and hit "No" (unsuccessful) until the 2nd power test (2019 TVs only give you 2 attempts - not 4...), there select Yes (home theatre system turned on/off), then “Done” and after that, it worked.

My Playbar was purchased new in early 2019 and is updated to current update level, so I can’t say what the difference is between “Playbar” and “PBAR1USBLK” in the list, only that “Playbar” never worked.

 

Hopefully this will help someone. I was frustrated for months attempting to get this to work until I stumbled on the alternate “PBAR” choice.

Cheers,

C

Just ran into this issue after unplugging tv and soundbar due to relocating. Here's the fix for my Samsung One Remote not controlling volume, but it still showed a visual response on tv.

Instructions on Samsung TV:Go to Sources -> Universal Remote -> New Device

Select Device Type: Home Theatre System

Select Brand: Sonos

Select Home Cinema Configuration: Optical

Start "Power Test" and now hit "No" (unsuccessful) until the 2th power test, then select Yes (home theatre system turned on/off).

This was the fix for me! Hope this helps!

Ok I have a 2019 Q8 Samsung.  I only use the streaming interface on the tv.  There isn’t a one connect box.  How do I set up the remote to work?  
 

After you go through the initial remote set up you can’t try it a fourth time.  After the third time of telling it that it didn’t work it asks for the model number of your home theater system.  I put in Playbar and then go through the same three set up attempts again. 
 

It ridiculous to spend this much money on a sound system to have to do all of these work around a to get it to work.   

I only use the built in apps (no HDMI devices) and i cant get the volume to work with the Samsung remote.

Working now! "the issue is that the IR signal comes from the one connect box and not the remote."
Badge +1
Mine works on source devices but it won't work the volume on the built in apps?
I am not sure if they did an update over past few weeks (either Sonos or Samsung) but I lost the ability to control volume. I have tried all the steps here to get it back. Still not working.
I got the Sonos Playbar fully working to be controlled by the One Remote with my Samsung Q7F 75" (2018 model, QE75Q7FNA).
My One Connect box is inside a closed cabinet and the Sonos Playbar receives the IR commands directly from the One Control.

It is working for me at every input, tested on DVB-S2 (Satellite), HDMI1 (Apple TV), HDMI2 (PlayStation 4) and Apps (Netflix, Amazon Prime, etc).

Instructions on Samsung TV:
Go to Settings -> Universal Remote -> New Device
Select Device Type: Home Theatre System
Select Brand: Samsung
Select Home Cinema Configuration: Optical
Start "Power Test" and always hit "No" (unsuccessful) until the 4th power test, there select Yes (home theatre system turned on/off).

After this the Sonos Playbar can understand the IR commands emitted by the One Remote, without the One Connect box needing to be in line-of-sight.

Change remote on Sonos Playbar:
Start the Sonos App
Go to More -> Settings -> Room Settings-> Room with TV/Playbar -> TV -> Remote control setup

Follow on-screen instructions, you will have to learn Volume Up/Down and Mute.

Congrats, you will have now a flawless working Samsung One Remote + Sonos Playbar setup.

At least it works at me perfectly.

None of the other "workarounds" that I found by other users worked for me.

Cheers
Worked for me thanks.
Can anybody tell me how change the label on screen from Samsung to Sonos?
I got the Sonos Playbar fully working to be controlled by the One Remote with my Samsung Q7F 75" (2018 model, QE75Q7FNA).
My One Connect box is inside a closed cabinet and the Sonos Playbar receives the IR commands directly from the One Control.

It is working for me at every input, tested on DVB-S2 (Satellite), HDMI1 (Apple TV), HDMI2 (PlayStation 4) and Apps (Netflix, Amazon Prime, etc).

Instructions on Samsung TV:
Go to Settings -> Universal Remote -> New Device
Select Device Type: Home Theatre System
Select Brand: Samsung
Select Home Cinema Configuration: Optical
Start "Power Test" and always hit "No" (unsuccessful) until the 4th power test, there select Yes (home theatre system turned on/off).

After this the Sonos Playbar can understand the IR commands emitted by the One Remote, without the One Connect box needing to be in line-of-sight.

Change remote on Sonos Playbar:
Start the Sonos App
Go to More -> Settings -> Room Settings-> Room with TV/Playbar -> TV -> Remote control setup

Follow on-screen instructions, you will have to learn Volume Up/Down and Mute.

Congrats, you will have now a flawless working Samsung One Remote + Sonos Playbar setup.

At least it works at me perfectly.

None of the other "workarounds" that I found by other users worked for me.

Cheers!

—————————————————————
Following instructions worked for me

Instructions on Samsung TV:
Go to Settings -> Universal Remote -> New Device
Select Device Type: Home Theatre System
Select Brand: Samsung
Select Home Cinema Configuration: Optical
Start "Power Test" and *hit "No" (unsuccessful) for 1st time & hit “Yes” for 2nd time to covert Samsung to Infrared*, there select Yes (home theatre system turned on/off).

After this the Sonos Playbar can understand the IR commands emitted by the One Remote, without the One Connect box needing to be in line-of-sight.

Change remote on Sonos Playbar:
Start the Sonos App
Go to More -> Settings -> Room Settings-> Room with TV/Playbar -> TV -> Remote control setup

Follow on-screen instructions, you will have to learn Volume Up/Down and Mute.

Congrats, you will have now a flawless working Samsung One Remote + Sonos Playbar setup.

At least it works at me perfectly.
Great video which walks you through this very easy:

https://youtu.be/lDDFhersXMs
I got the Sonos Playbar fully working to be controlled by the One Remote with my Samsung Q7F 75" (2018 model, QE75Q7FNA).
My One Connect box is inside a closed cabinet and the Sonos Playbar receives the IR commands directly from the One Control.

It is working for me at every input, tested on DVB-S2 (Satellite), HDMI1 (Apple TV), HDMI2 (PlayStation 4) and Apps (Netflix, Amazon Prime, etc).

Instructions on Samsung TV:
Go to Settings -> Universal Remote -> New Device
Select Device Type: Home Theatre System
Select Brand: Samsung
Select Home Cinema Configuration: Optical
Start "Power Test" and always hit "No" (unsuccessful) until the 4th power test, there select Yes (home theatre system turned on/off).

After this the Sonos Playbar can understand the IR commands emitted by the One Remote, without the One Connect box needing to be in line-of-sight.

Change remote on Sonos Playbar:
Start the Sonos App
Go to More -> Settings -> Room Settings-> Room with TV/Playbar -> TV -> Remote control setup

Follow on-screen instructions, you will have to learn Volume Up/Down and Mute.

Congrats, you will have now a flawless working Samsung One Remote + Sonos Playbar setup.

At least it works at me perfectly.

None of the other "workarounds" that I found by other users worked for me.

Cheers!
Yep, I think the trick is to have a device connected to be on, so for instance if you set your Sonos universal remote to HDMI 1, that device should be on or if you set your Sonos universal remote to HDMI 2 that device should be on. I might be wrong but when I set up my Sonos to HDMI 2 with my PS4 I was able to change the volume but when I went back to HDMI one I couldn't. Tomorrow I will toggle with it again in the meantime try that method, and I'll get back to you tomorrow
I have my Sonos universal remote setup to HDMI 1. Since I have a device connected to it(chrome cast) I believe that's why I can toggle the sound along with my tv audio set to out/optical. So I currently have a cable box to HDMI, Xbox to another HDMI, and a blue ray player to another HDMI. So when you set up your Sonos you just told your TV that the Home Theater Sonos was connected to the HDMI that the chrome cast was on?