Unable to play, file cannot be found using a NAS based iTunes Library Imported Playlists

  • 31 December 2013
  • 10 replies

I copied my iTunes library to my NAS (iomega StorCenter ix2) and then added that NAS folder to my Sonos Music Library. I can play all the music files from that library via all the options (Artists, Albums, Composers, etc) except the Imported Playlists. When I select any song via the Imported Playlists, Sonos gives an error message: "Unable to play {song name} - the file \\.... cannot be found. It looks like Sonos cannot translate the pathname of the files from the iTunes library play lists to the "new" location on the NAS... or maybe I did not set up the NAS folder properly... Here is the complete error message: Unable to play '01 Paper in My Shoe.m4a' - the file \\HOMENAS\Homedata\Users\XXusernameXX\Muisc\iTunes\iTunes Music\Zydeco Dependents\Zydeco Dependents\01 Paper in My Shoe.m4a cannot be found This is the path to the iTunes library on my NAS: \\HOMENAS\HomeData\Deja Vu Backups\iTunes

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

10 replies

Userlevel 7
Badge +26
Hello Tim,

Thanks for the great information there. The playlists are working backwards to play the tracks, but they need the new location to look closer to the old one. I'd recommend adding a "Music" folder to your NAS path and reindexing (\\HOMENAS\HomeData\Deja Vu Backups\Music\iTunes).

I made your recommend fix. I add a folder to the NAS so that the path was now: \\HOMENAS\HomeData\Deja Vu Backups\Music\iTunes, then removed the library from Sonos and re-added it. I get the same error: I can play the songs, but the imported playlists don't work. When I add the library to Sonos, should the path end with "Music" or "iTunes" or somewhere else higher/lower in the path? I tried both ways: ending the path at "Music" and at "iTunes" and it still had the error when trying to play a song via the imported playlists... I did notice that the error message changed when I ended the path at "iTunes." In that case it reads:
'Unable to play '01 Paper in My Shoe.m4a' - the share \\HOMENAS\HomeData does not exist."

Seems like the path is the issue... 

Any other ideas?

Userlevel 7
Badge +26
Hi Tim,

It still most likely a problem with the path. I'd recommend trying it without the "Deja Vu Backups" folder and indexing to the Music folder.

Please let me know how that goes.

I am also unable to get all the songs in the playlist to play. They appear to be in folders other than iTunes. Some of the songs in the play list play.
Having the same issue, was on the phone to Sonos for 1 hour, and they said its an iTunes issue, which I Feel is not because I can play the playlists in local iTunes folder. PLEASE SONOS help users to sort this out, it is causing users a lot of problems by reading all the forums.
Userlevel 7
Badge +26

Are you having trouble playing tracks off a NAS drive? Can you please submit a diagnostic from the system there after you get an error message playing from the NAS drive and reply back with your confirmation number?

To fix my original issue I had to change the NAS path to: \\HOMENAS\HomeData\Music (the iTunes folder is located in the Music folder on the NAS)... once I did this, the imported playlists worked fine.

I will play around with this some more, as I really wanted to create a folder on my NAS to contain the complete backup of my Macbook Pro (using Deja Vu) and just pointing the Sonos Control Music Library to the backup copy of the iTunes library on the NAS... with the current solution there is not a real "clean" way to keep my Macbook Pro backup files separated from the rest of my NAS files. I may have to create a new "share" off the NAS to hold the backup files so the path is simple enough for Sonos to handle... I'll post my final solution.

Userlevel 2
the way in which we use NAS and Sonos is not clean at all.  I forever have problems.  I moved from Chronosync to DejaVu to try something different, but not sonos struggles to find the files.  It has to be easier than this???
I have the same issue. I posted it last week but now can't find it. I have tried the path of the nas folder and the explicit path to the music folder in the iTunes folder.
Thank you Tim for this fix! I was going crazy trying to figure it out. I had to move my music folder to the root of my network drive and voila. All playlists are now working.