Radioplayer service still not working?



Since the total outage of Radioplayer a few days ago, Radioplayer service on Sonos app is still not working (at least for me), even if the service seems to be up and operating normally.

I resetted the app, removed and reinstalled Radioplayer service but seems not to be helpful.


Can anyone tell me if there are still problems? Other services works fine!




This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

14 replies

There’s no indication on the link for “View real-time service status” that it’s down, which suggests to me that it’s a local issue to your network. Have you tried removing it completely from your Sonos controller, then adding it back in, to force a new handshake with the service?

Conversely, if that doesn’t work, I would recommend that you submit a system diagnostic within 10 minutes of trying to play the service and call Sonos Support to discuss it.

There may be information included in the diagnostic that will help Sonos pinpoint the issue and help you find a solution.

When you speak directly to the phone folks, they have tools at their disposal that will allow them to give you advice specific to your Sonos system and network. 


I've also had the same. Removed, re-added, still nothing. Everything else works perfectly.

Userlevel 6
Badge +12

Radioplayer is working fine for me without any issues so it may be more to do with your local environment. 


@Francis_2 , what did Sonos support say when you called them with your diagnostic?

Hi all,

I tried almost everything but it seems not to work. I powerd off the complete system, re-installed the app, removed and re-added the service, changed country in the profile to update it, but nothing works.

After adding the service, when I open it, it only writes “unable to browse music”.

No more ideas what I can try to solve this.. ?

@andrea.parigi what did Sonos support say, when you submitted a diagnostic, and called them?

I did not submit any diagnostic yet, thought I coud solve it without calling the assistance.

I think It will become necessary now, don’t know how to proceed!

Should I submit a diagnostic also without calling, or better get in contact with someone before?


I’d submit the diagnostic first, and have the number ready when you call in. Better than waiting with them holding for you to run the diagnostic.


I had a very long call with Sonos who tried to help as best they could. I submitted a few diagnostics, but they’re saying it might be either the DNS service I use (Cloudflare) or my router (Eero). I ran out of time though. I use the service for one station so I’ll give up for now and maybe try a different DNS provider soon.

Finished a chat with a very friendly guy. He told me the problem could be country dependent, and there had been multiple tickets about the same problem. Meanwhile, we tried another Sonos service for radio called “myTuner Radio”. This one is working fine, but at the moment there is no official answer from Sonos to the Radioplayer malfunction. He told me to change country in my profile and chech if its working, but by now nothing changed.

I will try to call again and see if there is a solution or not.

The challenge ultimately, for Sonos at least, is all that they do is point your speakers to a location maintained by RadioPlayer, they really aren’t involved as a middleman until the point at which the RadioPlayer server provides your speakers the actual data.

The advantage they do have is that they can read the data in a diagnostic that you tell them about, which hopefully has more details in it about the specifics as to why the connection is failing. Unfortunately, all of us, including the individual users, don’t get access to that data (likely due to GDPR and other privacy concerns).

Have had the same issue since the original outage.

Removed service, re-added service, power cycled all Sonos components, power cycled router, reset router to default DNS, was set for google. Nothing fixed the issue, still unable to browse Radioplayer service.

Have just changed router DNS to Cloudflare and and restarted router, Radioplayer service now back working in Sonos. Maybe something else has just been changed elsewhere and its a coincidence on timing but worth a shot if service still not working on your systems, UK based. 


Same problem. Reset my router to factory default settings & all now working. 

Same problem for me.