Trouble adding Boost to existing system

  • 6 February 2023
  • 1 reply

Hi all,

I’ve just bought a Boost 2nd hand. It arrived today and when I connected it up to my router the light went solid white, but the app couldn’t find it. I tried re-booting it then it occurred to me that the previous owner may not have de-registered it from their system so I factory re-set it. I’m now getting a blinking green light but the app still won't find it.

I saw in another topic one of the agents suggested temporarily connecting one of the speakers to the router, then starting the “add product” process again for the Boost but this hasn't worked either.

Can anyone help me get it connected please?


Best answer by Jamie A 7 February 2023, 17:23

View original

1 reply

Userlevel 5
Badge +12

Hi @BH1983, welcome to the Sonos Community!

How far are you getting in the add product process? Does the app give any error messages or does it just hang on one screen and not progress? 

Please ensure the controller meets our app requirements and the controller has the correct permissions enabled for the Sonos app.

If you haven’t already, try rebooting your Router → Sonos speakers → and Controller in that order by powering them off for around 30s/1 minute then back on. After doing so, attempt to add the Boost when the LED is flashing green (You may need to Factory Reset the Boost again).

I hope this information helps, but let me know if you’re still unable to add the Boost.