Speakers in a Group drop out when audio switches


Userlevel 2
Badge +4

Well, this one is annoying. I have a Yoga Studio and have 6 Play 3’s mounted on the walls, when you switch tracks or playlists or even when they songs run themselves and switch to the next track at least half of the speakers drop out, but within 30 seconds they all reconnect.

 

Internet speed is 300MB+ and I did try turning off the modem and router (just those 2) and for a short time afterwards the audio was switching perfectly no dropouts at all. Then today we are back to speakers dropping out again. 

 

In conclusion, the audio will drop from certain speakers and return within 30 seconds without intervention, the system consists of 6 Play 3’s, 2 SYMFONISK’s, a Connect, and a Boost.

 

If anyone has a solution or idea please share, one of my teachers ditched this epic Sonos system to use a JBL BT speaker for a class “because it works”, so please any help here is huge

 

Best!


21 replies

Presumably the Boost is wired and you are running all on SonosNet.

So perhaps see if this helps to improve things for you…

  1. Set the main routers 2.4Ghz WiFi band to use a ‘fixed’ (least-used) non-overlapping channel. Use either channel 1, 6 or 11 and if the router allows, set the channel-width to 20MHz only.
  2. Goto “Settings/System/Network” and set the SonosNet channel so that it is at least 5 channels away from your chosen router channel in Step 1 above.
  3. Whilst in the Network Settings in the Sonos App, if present, remove your routers WiFi credentials, as these are not required when running your system with one Sonos device wired to the router.
  4. Set the Boost at least one metre away from the router and place high so that it and your speakers are above head height, so that the bodies in your class are not interfering with the wireless signals 

See if that then improves your Sonos connectivity.

Userlevel 7
Badge +22

Also here: 

 

Userlevel 2
Badge +4

Thanks for the replies! So, the only thing that is hard wired to the router is the Boost and the Connect is hard wired to the Boost. 

 

I will try to raise the Boost’s location. I noticed something when the issue seems to be present. I come in the next morning and the only speaker connected is the “Studio Left Wall” speaker. Sure, I hit the icon and add the rest of the speakers or press “everywhere” and they are supposed to connect, yes, they connect but like before it takes about 20 seconds before the do. 

 

I removed the boost completely and this did not resolve the issue at all. I also manually added each speaker back into the system and the problem went away but later presented itself once again. 

 

I have not messed with the wifi or the wifi settings yet. Also, Stanley_4 the link you left is broken and does not pull up a page.  

 

Appreciate all the help

Userlevel 7
Badge +22

Strange, the link works for me. Here is the bit from there:

Look at your network matrix and see if you are seeing problems there.

Use any of your Sonos IPs except the Boost

http://172.16.1.115:1400/support/review

 

If the Boost is wired to the router and you are using the second port on the Boost to wire the Connect, effectively you have wired the Connect to the router, using the Boost as an Ethernet switch.

Having the Sonos app take 20 to 30 seconds to wake up seems pretty common. I usually see 20-22 seconds from starting the app until the rooms populate and the controls work. My-Sonos usually takes a lot longer to populate.

You can always submit a diagnostic and contact Sonos with the number it gives you. Submitting one within about 10 minutes of the problem gets Sonos the log data they need to assist.

Userlevel 2
Badge +4

Well, I decided to essentially delete everything off of the system and start anew, this seems to have resolved the issue completely, things have been great until they were not.

 

Now at the present I have revived an older issue of track skipping. What happens now is that when you play a song, the next song in the queue will play just fine, but the following or 3rd song will not play and I will get a message that says “cannot connect to spotify” then switches tracks to the 4th song. In a studio where the next song being in sync is very important this is a big issue that comes and goes. Anyone heard of this?

Userlevel 2
Badge +4

Actually says “connection to spotify was lost” then plays the next song.

Skipping music usually is caused by one of two things. 

First, it could be an issue on Spotify’s side. 

Second, it could be an issue of wifi interference or a duplicate IP address of some type breaking the ability of the speaker to temporarily reach your router, and hence the Spotify server. 

Userlevel 2
Badge +4

Wi-Fi interference is actually what I initially thought was the case, so I purchased the Boost to help mitigate the issue but to no avail. I have reset the router and modems and reconnected everything back and the issue persists. Outside of doing another entire system delete and reprogram not sure how to resolve this 😔

 

The BOOST doesn’t really do much in terms of wifi interference, unless you may have set the channel it’s using to one that isn’t being used by your current router. It’s just a separate wifi signal, effectively, and it’s still radio based, so it can be affected by all the sources of wifi interference that affect your other router’s signal. 

Userlevel 2
Badge +4

Before I started this thread, this current issue has plagued me.

 

This issue is so specific, every 3rd song it skips, like it is trained to do so. If I simply press the next track on the list it will play and the connection with Spotify would not be lost, but I can’t be the dj the whole class. I will try digging deeper, maybe I will create a new thread specific to this issue.

Userlevel 2
Badge +4

I started a new thread here: Audio skips every 3rd track like clockwork! | Sonos Community

Userlevel 2
Badge +4

**Update**

 

So this issue of the audio dropping out of certain speakers is still going on. I created a new dedicated network and the issue persists. I have since dropped the Boost from the system.

 

Here is what I know for sure: If you start a new playlist or switch to a different song, about half the speakers will drop out, they will all come back in under 30 seconds. If the tracks change on its own, like when the song ends, there is zero issues, works perfectly. 

 

After adding a new dedicated network, I can rule out interference on the network as a potential issue. Seems strange it just when you manually change tracks. 

 

Any ideas on this?

So this issue of the audio dropping out of certain speakers is still going on. I created a new dedicated network and the issue persists. I have since dropped the Boost from the system.

Here is what I know for sure: If you start a new playlist or switch to a different song, about half the speakers will drop out, they will all come back in under 30 seconds. If the tracks change on its own, like when the song ends, there is zero issues, works perfectly. 

After adding a new dedicated network, I can rule out interference on the network as a potential issue. Seems strange it just when you manually change tracks. 

If the audio buffer is depleting to an empty state after approximately the same amount of time 2-3 songs - and it’s not the ‘sending’ source, then I would still hazard a guess, that it’s interference from somewhere, or an issue with the ‘primary’ group co-ordinator, but without details of the network setup, including channels, channel-widths and the identity of devices etc; then it’s difficult to make any suggestions.

You are perhaps best to to reproduce the issue with your new network setup and then immediately submit a Sonos system diagnostic report from within the Sonos App, note it’s reference and then contact/chat with Sonos Support Staff via this LINK and see what the Staff can perhaps suggest to resolve the matter.

Doing that might at least help to rule out a hardware issue with your grouped devices - it may even help you identify a much better group co-ordinator to handle the audio to the secondary devices and to change channels/channel-widths to improve the situation.

Userlevel 2
Badge +4

Let me provide a little more details, I setup v4 Starlink and have great signal with no obstructions, getting about 150Mb+ consistently. I created a separate 5ghz network called “Starlink GLO” and a 2.4ghz called “GLO Yoga Studios”. I connected 6 Play 3’s, 2 Symfonisks, and a Gen3 Sub. They are all connected to Starlink GLO (5Ghz). 

 

I thought that by separating the Sonos speakers to their own network with only Sonos it would be good to go, but I am presented with a new problem and less of the problem I mentioned above.

 

What is happening now is the audio will literally start to skip, not in the sense it is jumping a head but in the sounding sense, it would drop in and out of all speakers mid song with no prior warning or track changes, the sound is the equivalent to pressing the mute button superfast at different times for all the speakers, has to be the worst thing I have heard. 

 

Skipping the song “may” solve the issue but this one is stressful from an audio perspective.

 

My first inclination was to change the Starlink GLO network to being 2.4ghz instead of 5ghz since they operate on 2.4ghz on their own. Wonderful AI suggested that 5ghz would be better since there will be less interference on that network, but it seems that maybe the less range of 5ghz is having a measured affect?

 

If I were to guess it seems like there is no buffer, when I look at Starlink stats I can see outages of less than 0.1s but those did not coincide with the drop/muting sound so maybe not a buffer issue.

 

Would changing the network Sonos is on to 2.4ghz be a good option? I also noticed the Boost would not enter the system (maybe its locked to 2.4ghz only?)

 

Thanks!

Userlevel 7
Badge +18

Have you set reserved ip addresses for your speakers? Is the Starlink wifi set to one of the channels 1, 6 or 11? These simple steps can eliminate a lot of problems. 
 

Yes: I’d be inclined to use the 2.4Ghz band. 

Userlevel 2
Badge +4

I have not reserved IP addresses, sounds like something that I should do? Easy process? I will begin to shift to 2.4ghz, hopefully I don’t have to re-add the entire system, last time that was a 2 hour process, but whatever it takes :)

Userlevel 7
Badge +18

I have not reserved IP addresses, sounds like something that I should do? Easy process? 


It should be explained in the manual; if not there may be someone here that’s familiar with the kit that can talk you through it. In principle it’s quite simple. 

Userlevel 2
Badge +4

Does reserved IP address have anything to do with Custom DNS? Starlink has this on it:

 

 

@GLO Yoga,

Custom DNS is a different thing to reserving/fixing (making static) your device IP addresses - look for DHCP in your router configuration pages - you will likely see the devices (and their IP and MAC Addresses) that are connected to your router. You just need to set them to static for Sonos products, rather than dynamically assigned addresses.

Userlevel 2
Badge +4

Well diving into it before I change things here is what it looks like:

 

Then I clicked the one with the lowest signal and got this, my guess is this may be causing the issue: 

 

Yes @GLO Yoga, it looks like the 5Ghz WiFi signal could be improved in that area of the Home. Maybe move the speaker to a different location, if practicable, or blacklist/whitelist the speaker in the router settings to force it to just use the 2.4Ghz band instead and set the band to a ‘fixed’ channel 1, 6, or 11 and to use a channel-width of 20Mhz only, that’s if your router configuration pages allows you to perhaps change those things.

Reply