Sonos sub connecting to wifi despite Boost

  • 16 November 2022
  • 8 replies
  • 125 views

Userlevel 3
Badge +6
  • Enthusiast I
  • 94 replies

Despite having had a Boost installed for quite some time now, I noticed earlier today that my Sonos subwoofer is connected to my wireless network.  I first noticed it in my Unifi network dashboard as ‘Sonos Connect Hero’ and then cross-referenced that to ‘About my system’ using IP address.

I had noticed before that despite the Boost, my 5ghz network seems to randomly re-appear in the Sonos network settings.  Each time, I remove it, then some time later it reappears.

How do I permanently ensure that the sub is connecting only via the Boost and NONE of the Sonos speakers are connecting to my wifi?


8 replies

Userlevel 3
Badge +6

Actually looking further, I take it that WM:0 means the sub actually isn't on WiFi. It so, then something else is caching that network name. Could it be the Roam (even when not powered on?)

 

 

When a Sonos Sub is ‘bonded’ to a Sonos device, such as a Beam (for example) - the connection to/from the Sub is via an ‘ad-hoc’ 5Ghz wireless connection with the main player - so it neither uses SonosNet, nor your WiFi, when in use. The main player proxies the Sub IP address from the routers DHCP server.

If the main player is using Sonosnet/Wireless Mode Zero (WM: 0) then the Sub will show the same status in the About My System area of the App. If the main player is using the 2.4Ghz WiFi (WM: 1), rather than SonosNet, then the Sub will show in the ‘about box’ as WM: 2.

Userlevel 3
Badge +6

Thanks, so something is causing the system to cache my wireless network. How do I permanently remove it and ensure that Sonos is never connecting via Wi-Fi?

@twuk 
My router shows the Sonos master devices, when running on SonosNet, as all being wired to the LAN, even when they may actually be wireless …and the bonded devices (Sub/Surrounds) show as being connected during boot/start-up time, but after their boot sequence, when they ‘bond’ back to their master device, they show in my router configuration as being ‘off-line’… obviously they are simply using the ad-hoc 5Ghz connection at that point.

I understand however, that some routers may display the Sonos ‘sonosnet’ connections differently.  

Hope that info. may assist you further.

Thanks, so something is causing the system to cache my wireless network. How do I permanently remove it and ensure that Sonos is never connecting via Wi-Fi?

If you did not have any Sonos ‘portable’ products Roam/Move (which always use WiFi only and cannot use SonosNet), then I would have just suggested you remove the WiFi credentials from the Sonos App to stop/prevent the devices using your WiFi, but I noticed you mentioned you have a Roam - so there’s no way to remove those credentials whilst you have portable products as part of your Sonos Household.

So the WiFi credentials stored in the App is open to be used by all, but those non-portable devices that use SonosNet will prefer that connection, unless it drops below a certain threshold, in which case it will try to jump onto the WiFi connections listed in the App Network settings. See below…

If you have separate SSID’s for the routers 2.4Ghz and 5Ghz WiFi bands, then perhaps just list the 5Ghz band credentials only in the Sonos App network settings, as that is a more robust method to enforce your compatible devices to use the 2.4Ghz (further reaching) SonosNet connection. It may however limit the connection distance that the Sonos portable devices are able to use, as the 5Ghz band, whilst faster, is less penetrative through walls etc.

Userlevel 3
Badge +6

I have exactly that… a Roam accessing the 5ghz network only. It’s an unfortunate shortcoming that having a portable Sonos product results in the whole system being able to jump into the wireless. 

I have exactly that… a Roam accessing the 5ghz network only. It’s an unfortunate shortcoming that having a portable Sonos product results in the whole system being able to jump into the wireless. 

The SonosNet connection must be really ‘poor’ for that to happen and the WiFi AP must be quite near too. If it happens regularly, then you might want to consider running all on your WiFi connection instead - also ensure that the WiFi adapter on the master player is ‘enabled’. Some folk tend to wire their master devices and (wrongly) switch off the WiFi adapter, which is usually (obviously) still needed for the ad-hoc connection to any wireless slave devices, like surrounds or Sub.

Moving your devices around a little may improve things, but I recommend to not wire any slave device, unless you have no other option and it’s then best to wire the slave and master devices to the same switch/router.

I personally choose/suggest to not switch off the WiFi adapter on any Sonos HT product and also not wire any surrounds, or Sub to the LAN. Only wire all HT products as a last resort.

Whenever I do opt to wire a HT master device, then I wire it back to the router/hub - I never wire it to a separate access point/secondary mesh hub.

Userlevel 3
Badge +6

Thanks for all the  help. At least I  now understand where the WiFi connection is coming from, and that it's unavoidable whilst I have the Roam. (Very seriously considering getting rid of that anyway. )
 

The products appear to connect to my Boost fairly reliably as it stands. I've also ensured its 2.4g network is as far from the WiFi 2.4g channel as possible. 

Reply