Sonos One disconnected overnight "WiFi password incorrect" fix.

  • 20 October 2019
  • 30 replies

Dear Sonos-ers!


Issue; “Incorrect password” for wifi set up even though you enter the right password.


“Incorrect password” → Factory reset → Ethernet to router → create new router password for network on router → set up speaker again with Ethernet still in → “create wifi network” via app → Enter your new router created password → should work!
I am creating this as hopefully my first and last post on this community thread.


I have spent the last 2 hours troubleshooting this issue, so creating this in the hope that this helps you further. Hopefully this will improve my karma!

I went to sleep last night with the Sonos One speaker working perfectly, with a smile in the corner of my mouth. Waking up, the Speaker was essentially a brick, went through the “whats wrong” troubleshooting several times via the app to no positive effect.

Then, I eventually got the “enter your wifi” option, entered my password, and got “password is incorrect”. I thought I might have missed a character, then realized no, I wasn’t at fault here. I even used “forget network” on my phone to make sure the password did work.

So I went to the extreme of connecting the sonos via Ethernet(digging through several drawers) and connected and…. yes it sprung back to life!

I was so puzzled, the wifi was not working, but the Ethernet was. So I searched this, and went through several threads, filled with raging sonos users, and others using the classic “have you turned it on/off” trick. 

So finally, I logged onto my router, changed the password on it for the entire network .

Then, I factory resetted the Sonos One (steps in other articles), Ethernetted the speaker again, and then via the app, I used the “create wifi network” option. 

I entered the new password and HALLELUJAH it worked!

Why changing the password on the router worked, or why it somehow stopped working overnight, is a puzzle to me. I did go through some firewall settings on my laptop, I was messing with Stream what you hear, but not sure how they could have effected things here?

Anyway, I went through this pain so you don’t have to!

Great speaker, amazing mind blowing sound and features, but Sonos if you are reading this;

  1. No compatability with Windows audio? Why? This should be such an easy solution. Why only Airplay2/Apple compatability? I would like to not think this is some sinister way to get us to buy sound bars and other products?
  2. The community threads are a mess here, I don’t understand why they are allowed to be a forum for people to kill each other. Toxic users should be pruned, it makes for a terrible experience having to search through them. Like look at the replies on this;
  3. After factory reset, the sonos controller DELETED all my presets and favourites, yeah again, this should be an easy fix!

Anyway, happy to have this up and running, and really enjoying the experience (now!).


This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

30 replies

I did see some posts about Sonos being able to connect to 5Ghz networks, so maybe that happened when the 2,4Ghz network was shut.

If there is some incompatibility with authenticating on 2.4GHz on Orbi systems then there ought to be some kind of application note made available for us!

Userlevel 7
Badge +17

If there is, and enough people call it in, I'm sure Sonos will notice it….

Hi, I had the same experience today, just woke up and no speakers were connected to WiFi, powering off and on did not help, etc.  Play:1 and Play:5 on S2 12.1.

Plugging in a network cable and deleting / attempting to rejoin the network only resulted in WiFi password incorrect, even after a factory reset.

I eventually solved after finding this thread.  Had to disable 5GHz (make it 2.4GHz only) on my WiFi network, then I was able to join OK.  Have since re-enabled 5GHz and restarted the speakers and they join OK.

If it happens again I guess I’ll just setup a separate SSID as a 2.4GHz only network for Sonos.

My router, switch and AP are all UniFi gear, if it makes a difference, but sounds like this is happening to everyone.

OK, if I factory default the Play:1, conect direct to router with ethernet. Configure the Wireless Password while connected using the ethernet, then remove the ethernet and reset, it DOES login to the Orbi WiFi and I can stream again.


Userlevel 7
Badge +23

Logins have been an issue for routers that have 802.11b/g disabled (ie 802.11n-only).