Sonos boost connection on S2 app

  • 3 October 2022
  • 1 reply

Moved house with new router.  S2 app does not recognise the boost, the rest of the system was found and is on the regular wi-if network. 

tried various things, rebooting router, changed cables, changed sockets in the router and on the boost, tried a factory reset on the boost - but now it just has the green flashing indicator light

how do I get the boost to connect and provide the dedicated network for Sonos that is needed to prevent drop out etc


Best answer by Corry P 3 October 2022, 16:10

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

1 reply

Userlevel 7
Badge +18

Hi @Andrew276 

Welcome to the Sonos Community!

I’m sorry to hear you’re having this trouble, but I first have to point out that a Factory Reset was just not the right thing to do - it rarely is. I’m only saying this now so that others reading this may avoid taking that step. Please follow these steps:

  • To get your Boost connected, first ensure it has no ethernet cable connected to it
  • Connect one of your other products to the network via ethernet temporarily, and to power, then wait a minute or two
  • Open the Sonos app and ensure it is connected to the rest of your system
  • If your Boost’s light is no longer flashing green, unplug it from the power for a few seconds, plug it back in and wait about 1m for the flashing green light to appear
  • In the Sonos app, go to Settings » System » Add Product and continue from there. If the setup flow starts before you get that far, the app has detected the Boost by itself and you can continue there
  • Once the Boost has been successfully added to your system and updated itself (if needed), you can then reconnect the ethernet cable between it and your router/switch, while disconnecting the existing ethernet connection to the other player you chose earlier. Please keep the Boost and the router at least 1m apart

All your (non-portable) speakers should now be on SonosNet. You may need to ensure that SonosNet and your WiFi are on non-identical, non-overlapping channels (1, 6 and 11 do not overlap). Settings » System » Network » SonosNet Channel to adjust.

I hope this helps.


Edit: You should also remove your WiFi credentials from the Sonos system - but only if you have no portable products (Roam or Move). Settings » System » Network » Manage Networks » remove all entries.

2nd Edit: I missed out what is now the second step - your Sonos system must be on SonosNet before you can add the Boost.