Cannot get my SOnos system to work reliably - at the end of my tether with it, please help!

  • 27 November 2022
  • 9 replies
  • 144 views

Good day all

I am desperate for some help with my Sonos system; it has never been reliable, and my efforts to sort it just seem to make it worse and worse.

My setup:

Sky Broadband through a TP Link Archer VR2100 router

Sonos Boost

GF:

Beam, Sub and Two Play:1’s in Living Room.  The Beam is plugged into ethernet.

Playbar, Sub and two Play:3 in Games Room

Sonos One/Sonos One SL pairing in Dining Room

Sonos One/Sonos One SL pairing in Kitchen

First:

Play:1 in daughter’s bedroom

Two Play:1 in Master Bedroom

Play:1 in Study

I have made permanent IP addresses for all the Sonos stuff in the router.

After much cocking about this weekend I have finally seemed to get everything running on the Boost (I got this about a month ago in the hope it would solve the endless drop-out and play errors, and it’s only today I managed to get everything connected to it at once) so all are on WM: 0.  I just tried playing through all speakers and it worked!  Brilliant, sorted, I thought.  Forty minutes later the whole system went silent and vanished.  I’ve just managed to get it back up running again but don’t know for how long.

Looking at the network matrix all the upstairs speakers have OFDM ANI levels of 9 and many of the speakers are ‘undefined’.  Noise Floor for all speakers ranges between 100 and 115

Can anyone suggest anything further I can so?  Is the Boost overloaded with so many speakers?  Can I buy another and daisy-chain them? Will that help?  I am so sick to death of the damn thing failing, I’m just running out of ideas and want to take them all into the garden and smash them to pieces with a sledghammer.

I would be most grateful to anyone who can offer any guidance!

Many thanks in advance 

Rob (Duckle)


9 replies

Userlevel 7
Badge +20

Hi

Can you download a wi-fi analyser on to your phone, (I use WiFiAnalyzer on Android) this will show how many overlapping wi-fi signals in your home.  You can then use the channel graph to check if you have overlapping wi-fi signals.  You can change the channel in Sonos App>Settings>System>Network>SonosNet Channel

Hi Rob

Sounds like a bit of a nightmare. The Boost isn't being overloaded. 

First question - which router or routers have DHCP enabled? Which have WiFi enabled?

Second question.  Any likely candidates for the wireless interference upstairs? Baby monitor? Smart lights?

Third question: how close to your router is the Boosr?

Thanks to you both.

I have checked the channels nearby and it’s on the best channel (6) out of the three options.

DHCP is set up on my TP Link VR2100 router, as is WiFi 2.4 and 5 GHz.  I have a TP Link power line passthrough too, but that doesn’t connect to any other Sonos speakers, it’s just for my PS5 and Sky box.

Upstairs, the only other wireless device we have is the printer in the study.  Weirdly, for some reason Sonos gives the study an OFDM of 0 and it’s green even though it’s further away upstairs than the master bedroom, which has on OFDM of 9 and red.

Userlevel 5
Badge +9

With your Beam connected to Ethernet do you even need a Boost? Surely the Beam will take over the setting up of SonosNet?

Both the Beam and the Boost are wired to the TP-link router?

NinjaBob - I don’t know!  My knowledge is lacking to be honest.  I only connected the Beam up via ethernet this morning and I’ve had the boost running for a couple of weeks or so.  Do you think I should try turning off the Boost then, now I’ve connected the Beam?

John - yes, Boost directly, and Beam via a small switch

Hi. Leave Boost and Beam wired.

Boost should be at least 3 feet from router. 

Is Master Bedroom Sonos near anything electrical or near wall to neighbours?

Weirdly, for some reason Sonos gives the study an OFDM of 0 and it’s green even

though it’s further away upstairs than the master bedroom, which has on OFDM of 9 and red.

The colour of the boxes down the left hand and the OFDM value reflect how hard the speaker is having to work to resist local interference.  So not really weird at all - it is just telling us there is a source of interference close to the master bedroom but not near the study.

Also, is the switch to which you refer unmanaged?

One other thing that might improve stability is to remove your WiFi credentials from Sonos in Settings, System, Network, Manage Networks.

 

 

Reply