Can't get LG Magic Remote volume control to work with Playbase


Badge

Hello everybody,

I’ve been unable to use my LG magic remote to control my Sonos Playbase for a whole year.

I’ve got an LG C7 OLED, a Sonos Playbase and 2 Sonos Play:1s set up for surround. I want to get a Sonos Sub and a couple of Sonos 1s to have around the house, but being unable to control my existing Sonos products with my TV’s remote control is not really inspiring me to spend more. I’ve already spent around 1000 euros for the existing setup as it is. Internal TV speakers just don’t cut it.

To this date the only similar topic I have found on this forum is this one by user earplugs: Playbase and LG Magic remote | Sonos Community

It was all working fine until about a year ago, when I moved country. Everything remained in storage for a period of time, and I started setting it all up again probably in early July. I remember the TV got a firmware update as soon as I took it online, and since then the TV’s menu options have changed massively. Device Connector on my LG TV is no longer giving me a manufacturer list (I remember I used Phillips once when setting it up in 2019), and the new remote setup process on the Sonos app is only working when the TV is off (and of course the moment the TV is on the remote becomes useless again).

This process on the Sonos support website also doesn’t work: Unable to adjust the volume using the LG Magic Remote | Sonos

Has anyone else had this problem? Is there a solution? The only way to remotely control the volume now is through the Sonos app, which is OK, but not ideal, as I don’t want to be holding my phone constantly when watching a movie.

At this stage I am almost ready to factory reset both TV and Sonos equipment and set up everything from the beginning again. But I am wondering if that will not work either.

LGRemoteNotWorking 15 days ago

I fixed it. Holy *** , I fixed it, after 18 months. It had to do with the Location settings of the TV.

The guy on the phone from LG earlier briefly said that it may be due to the country change, but it didn’t immediately click. By sheer chance, as I was typing my previous post 20 minutes ago, this topic came up on the right side of the screen:

Configure LG OLED Magic Remote (2018) with Playbase | Sonos Community

I had never seen it before, but the poster had the same issue I was having. The solution came by @markymos, who briefly mentioned the LG service country in a post of his, and then @Jools23 confirmed that it worked for him.

So I went to settings, general, location, and changed the location for everything to UK, rather than Greece. I am not sure how that had gotten changed, and if it happened automatically or if the TV asked me at some point.

Now that I’ve changed it back to UK, I get the option to select the manufacturer in the device connector. I set the remote up again, and lo and behold, I can now use my LG magic remote control to control the Playbase’s volume!

Thank you everyone, and especially @Ken_Griffiths who has been suggesting things and coming back to this topic for months.

 

*Moderator Note: Modified in accordance with the Community Code of Conduct.*

View original

33 replies

I spoke to LG support just now, and they said they will look into it and call me back within 48 hours.

@Ken_Griffiths, is there a specific way to restart the TV and view the webOS logo? I only see it after a firmware update.

I understand you can change the LG user agreements in your LG account ‘Settings/General/Account Management’ and that will cause the TV to fully reboot, or leave the TV powered off completely for (I think) 10 minutes. 

Sadly it didn’t last and the remote is now not controlling the SONOS again 🙄

Sadly it didn’t last and the remote is now not controlling the SONOS again 🙄

It sounds like you may perhaps have an intermittent fault somewhere. I would submit a Sonos diagnostic report, both when the remote works and when it doesn’t, and note the two reference numbers. Then contact/chat with Sonos Support Staff via this LINK  and see what the Staff can suggest to resolve the issue. I guess there’s no saying at this stage that the fault may lie with Sonos, it might of course be an issue with the remote infrared, but see if the Staff can perhaps see anything untoward in your diagnostics or see if any other paired IR TV remote has the same intermittent issue.

Badge

LG support came back today to tell me that they were unable to determine possible issues and that it should all work fine. They suggested I reset the TV to factory settings again and it may get resolved, but I think it’s all a firmware issue which they have failed to identify.

In any case, I’ll reset the TV and the Playbase again at some point, and see if anything changes.

LG support came back today to tell me that they were unable to determine possible issues and that it should all work fine. They suggested I reset the TV to factory settings again and it may get resolved, but I think it’s all a firmware issue which they have failed to identify.

In any case, I’ll reset the TV and the Playbase again at some point, and see if anything changes.

I don’t personally think you will need to reset the playbase. I would start with the TV - it’s just a real pain to reset any TV as the in-built Apps have to be setup again - that’s something every TV manufacturer needs to fix and make easier for the user.

Have you tried removing the optical connection and switching over to the internal TV speakers for half an hour or so …and rebooting the TV, then see if it lets you add it back and setup the Sonos manufacturer along the way? - I think many LG TV’s have an AV Reset option too, don't they? Have you tried that feature? On many of their TV’s ...it often starts with pressing the ‘mute’ button three times on the Magic Remote, but I’m not sure if it will work for you in this instance, but far easier than a full reset.

Badge

I fixed it. Holy *** , I fixed it, after 18 months. It had to do with the Location settings of the TV.

The guy on the phone from LG earlier briefly said that it may be due to the country change, but it didn’t immediately click. By sheer chance, as I was typing my previous post 20 minutes ago, this topic came up on the right side of the screen:

Configure LG OLED Magic Remote (2018) with Playbase | Sonos Community

I had never seen it before, but the poster had the same issue I was having. The solution came by @markymos, who briefly mentioned the LG service country in a post of his, and then @Jools23 confirmed that it worked for him.

So I went to settings, general, location, and changed the location for everything to UK, rather than Greece. I am not sure how that had gotten changed, and if it happened automatically or if the TV asked me at some point.

Now that I’ve changed it back to UK, I get the option to select the manufacturer in the device connector. I set the remote up again, and lo and behold, I can now use my LG magic remote control to control the Playbase’s volume!

Thank you everyone, and especially @Ken_Griffiths who has been suggesting things and coming back to this topic for months.

 

*Moderator Note: Modified in accordance with the Community Code of Conduct.*

Userlevel 2

Good job. Glad the solution worked. 👌 

Ah that’s great news @LGRemoteNotWorking - glad to hear that you have managed to sort it. 👍

Reply