ASUS RT-AX86U & SONOS CONNECTION ISSUE SOLVED!

  • 12 December 2020
  • 90 replies
  • 29024 views

Userlevel 2
Badge

I’m posting this in hopes of saving someone else from the hours of frustration I’ve endured to resolve this issue.

From the time I set-up my Arc + Sub + Surrounds system in July with an Asus RT-AC88U router (connected to Fios Gigabit internet) it has worked without issue. I’ve used Asus Smart Connect with all settings at default. No problems with the S2 app and no problems when I upgraded to an iPhone 12, other than the loss of Trueplay support, which continues to be a problem. (HELLO Sonos! Anyone home?)

Then I recently upgraded to the RT-AX86U using same Smart Connect default settings and, initially, all seemed fine. But soon the dropped connections started. I’d reboot and the Sonos system would connect for 10-30 minutes, then lose wifi connection again. Meanwhile, all other wifi devices in my home worked just fine--the Sonos was the only problem child. 

I did all the troubleshooting I could, then called into Sonos support and spent almost 2 hours with a tech rep trying every potential solution possible, but nothing worked. (However: KUDOS to such extraordinary tech support!) He then escalated the issue to an appointment with the Senior Support Team. 

Meanwhile, I went into the router settings once again, looking for anything that might be an issue--even though I had gone through them all with the tech rep, and these were all the same settings that had worked on the AC88U. On a whim, and not expecting it to help, I turned off the QoS feature, which I have set to prioritize bandwidth for media streaming over other tasks. BINGO. That was it. Sonos system has stayed connected ever since. I can’t explain why that would be a problem--I’ve always had the QoS set that way, and with gigabit service, an AX router, a modest load of wifi clients in my apartment and no gaming, there should be bandwidth aplenty. But that was the issue and it’s finally solved. 


90 replies

Another vote here for turning off the QOS.  I have an RT-AX58U connected to a RT-AC68U mesh and my second Play 1 was not connecting after being unplugged for a couple of days.  Called Sonos who ended up directing me to speak with Verizon about Fios blocking access to the speaker.  That sounded dubious. I found this thread and turning off the QOS which worked like a charm. Thank you !

Had lot of problem witth this, did clear my data and cash for Google home and sonos, then opened Google home and linked sonons again. This finally sovled my problem! 

 

Prior to this I had changed this settings. After clearing the data an cash this solved my problem.

 

Inställningar för ASUS:

På vänster sida klicka på Wireless

General/ Band 2.4GHz:

-Trådlöst läge -> Legacy
-Kanal bandbredd -> 20 MHz
-Authentication Method -> WPA2-Personal
-WPA Encryption-> AES
Tryck verkställ

Wireless / Wireless MAC Filter
-Enable MAC Filter-No 

Wireless/ Professional:

-Roaming assistant  --> Inaktivera
-Enable IGMP Snooping --> Aktivera
-Airtime Fairness  --> Inaktivera  på 2.4GHz och 5GHz
-Universal Beamforming/ Universal strålformning --> Inaktivera på 2.4GHz och 5GHz
Tryck verkställ

På vänster sida klicka på LAN och efter IPTV
-->Enable Multicast routing (IGMP Proxy) - Aktivera
-->Efficient Multicast Forwarding (IGMP Snooping)- Aktivera
Tryck verkställ

Starta om alla högtalare efter att dessa inställningar har gjorts/kollats för bästa resultat.

 

Mod Edit: Added English translation-

ASUS settings:

On the left side click on Wireless

General / Band 2.4GHz:

-Wireless Mode -> Legacy
-Channel bandwidth -> 20 MHz
-Authentication Method -> WPA2-Personal
-WPA Encryption-> AES
Press apply

Wireless / Wireless MAC Filter
-Enable MAC Filter-No

Wireless / Professional:

-Roaming assistant -> Disable
-Enable IGMP Snooping -> Enable
-Airtime Fairness -> Disable at 2.4GHz and 5GHz
-Universal Beamforming / Universal Beamforming -> Disable at 2.4GHz and 5GHz
Press apply

On the left side click on LAN and after IPTV
-> Enable Multicast routing (IGMP Proxy) - Enable
-> Efficient Multicast Forwarding (IGMP Snooping) - Enable
Press apply

Restart all speakers after these settings have been made / checked for best results.

Thank you! Enabling Multicast Routing has helped keep my connection alive.

I've struggled with this for years. 

What has seemed to make an impact is under 

LAN -> IPTV -> Enable Multicast Routing

For a week now every time I open Spotify my system is available to select.

I'd also recommend setting them to static addresses, as well as communicating to a specific access point vs letting the network decide.

Just in case this helps someone else, I read through this thread and after trying multiple resets, reboots, the works, I did finally solve it for me. Within the ASUS Router app (Android for me), I went to Settings → WiFi → Wireless Settings → Network Settings and turned OFF ‘Enable 802.11ax Mode’. I was having a devil of a time trying to get my sub to register. As soon as I disabled this setting, the sub instantly registered. Hopefully this helps others. 

Userlevel 2
Badge +3

I have just bought a new Asus RT-AX86U running Firmware Version:3.0.0.4.388_22068 so as to be able to use a VPN and am experiencing the same issue as detailed in the many posts here and elsewhere.

I have reset all my Sonos speakers to factory settings and reinstalled and all seems good until after a few minutes they all show as disconnected again. I have followed all prompts to re-connect  in the Sonos S2 app and lost count of the number of reboots and I have chatted online with Sonos support who then said I would need to contact telephone support all of whom have viewed multiple diagnostic reports all to no avail; my last contact ended with me disabling Wi-Fi 6 and everything appeared connected and working only to all appear disconnected again a couple of minutes after I thanked support and ended the call.

 

I am now using my Internet suppliers router for Sonos and the Asus for everything else.

This also seems to work Better for me! Thanks

I downloaded a free version of Wifi Analyzer on my old Android phone and scanned through my apartment and channel 6 (2.4GHz) was the least crowded so I tuned in to it.

It has been working almost flawless since, only some split second drop out and its nothing that bothers me and rarely happens. 

Airplay 2, Spotify connect and Sonos all works.

Userlevel 7
Badge +23

Are there any iOS users here? I tried two days connect Sonos to my new Asus rt-ax86u with Android, no success. Tried my wife's IPhone for Sonos network update and success right away! All speakers found immediately.

Router is with newest firmware and airtime fairness off, QoS off.

Your phone is probably connecting on 2.4GHz and your wife’s on 5GHz (or vice versa). These routers are infamous for messing up broadcasts between radio frequencies. Please, choose a different router.

Are there any iOS users here? I tried two days connect Sonos to my new Asus rt-ax86u with Android, no success. Tried my wife's IPhone for Sonos network update and success right away! All speakers found immediately.

Router is with newest firmware and airtime fairness off, QoS off.

I'm getting extremely sick of this. It's been ongoing for years now, and it's always blamed on Asus. I have exactly no issues with any other of the 20 other devices connected to my Asus network except bloody Sonos. I'm almost at the point of throwing it all out despite the sunk costs. This needs to be fixed, enough is enough. Go and buy some Asus routers and trial them in house Sonos r&d and fix the damn problem. 

 

It is unlikely any of the ”20 other devices” on your network need to communicate with each other, and that is the feature that Asus seem unable to make work reliably (per this thread and others). And that is also a critical requirement for Sonos devices. Please, just get another router.

 

Not exactly correct.

Problems with Samba are often simply access errors, where once they worked.  Reported in the Sonos System Error Log, they show as:

  • “Unable to connect to: //<your samba path>”,
  • “//<your samba path> is no longer available. The device where the music files are stored may not be powered on, or the path may have changed.”
  • Unable to play '<your music file>.mp3' - unable to connect to //<your samba path>.

As Revrobbo noted, it is absolute and complete BS that someone at Sonos has not tried to replicate this problem and fixed it, given all the years of venting on this forum.

 

We had this same problem. We rolled our firmware back to:

3.0.0.4.386_47029

2022/01/05

After so much time, I have finally made it work. After all the tips here in the thread and nothing has really works to 100% for me.
I downloaded a free version of Wifi Analyzer on my old Android phone and scanned through my apartment and channel 6 (2.4GHz) was the least crowded so I tuned in to it.

It has been working almost flawless since, only some split second drop out and its nothing that bothers me and rarely happens. 

Airplay 2, Spotify connect and Sonos all works.

 

 

 

IPTV multicast routing is enabled.

Asus AX68U Merlin 386.5 (have not try 386.5_2) Factory reset and no restore from backup.

Userlevel 7
Badge +23

I'm getting extremely sick of this. It's been ongoing for years now, and it's always blamed on Asus. I have exactly no issues with any other of the 20 other devices connected to my Asus network except bloody Sonos. I'm almost at the point of throwing it all out despite the sunk costs. This needs to be fixed, enough is enough. Go and buy some Asus routers and trial them in house Sonos r&d and fix the damn problem. 

 

It is unlikely any of the ”20 other devices” on your network need to communicate with each other, and that is the feature that Asus seem unable to make work reliably (per this thread and others). And that is also a critical requirement for Sonos devices. Please, just get another router.

I'm getting extremely sick of this. It's been ongoing for years now, and it's always blamed on Asus. I have exactly no issues with any other of the 20 other devices connected to my Asus network except bloody Sonos. I'm almost at the point of throwing it all out despite the sunk costs. This needs to be fixed, enough is enough. Go and buy some Asus routers and trial them in house Sonos r&d and fix the damn problem. 

 

a miracle.  did a ax3000’s firmware update
updated to 3.0.0.4.386_47029

connect amps working again. and other smart devices that were having connection issues.

like a switch

didn’t even do a factory reset…

 

 

 

Hi

 

 Re the asus problem, there is new firmware available   6061    this has fixed the problem for me re sonos   also did a factory reset on my router  RT AX 82U

 

hope this helps

I’ve had the same problems on my RT-AX58U, every firmware upgrade did cause issues with my SONOS system. Because of that I have been running an older firmware version from september 2020 (version 3.0.0.4_384_9918).

I’ve tried most of the suggestions in this thread without any success...

Yesterday (2022 jan 4) my router forced me to get the latest firmware, even though I have the automatic update turned off… And of course the upgrade messed up my SONOS system. So I reverted back to my old version, and SONOS was up and running again.

But after a while the router upgraded to the newest version again, and again messed up my SONOS!

So I decided, after the upgrade to the newest firmware, to make a factory reset and setup the router from scratch. I did not reload any saved preferences.

That brought my SONOS system back again.

So far It has been working for 16 hours…

I’ll keep my fingers crossed.

Why is anyone in this thread still trying to use these Asus routers? Get a router from an actual network company, eg AmpliFi, and quit wasting your time with these terrible Asus devices.

Since you’re recommending -- how are Sonos systems with Mikrotik routers?

And FWIW, many people have already made what could be considered significant investments ($$) in their Asus routers, and changing up is impractical.  Asus-Merlin is still a thriving community, so it would be behoove many to stay on that platform.

Userlevel 7
Badge +23

Why is anyone in this thread still trying to use these Asus routers? Get a router from an actual network company, eg AmpliFi, and quit wasting your time with these terrible Asus devices.

This week my Beam would not connect to my Asus RT-AX88U router.

I have previously tried the enable then disable Airtime Fairness trick on both 2,4 GHz and 5 GHz, but my Beam would still not connect to my router.

What did help was changing the following option under Wirless → Professional, under 2,4 GHz radio. My Modulation Scheme was set to “Up to MCS 11 (NitroQAM/1024-QAM)”, I selected instead “Up to MCS 9 (TurboQAM/256-QAM)”.

Power cycled all my Sonos gear (Beam, Sub and 2 x One), and they connected back to the router and rejoined my surround setup.

This issue just cropped up for me! I have a Sonos beam, sub, and Pay 1 speakers downstairs, and a sub and two Play 1 speakers upstairs. Well the the system no longer recognizes any of the Sonos speakers upstairs. Downstairs speakers are fine. 

Have had an ASUS RT-AX86U router for several months with no problem. Using this firmware:

Firmware version 3.0.0.4.386_45375

Can anyone help? Thanks! 

 

I’m on the same Firmware version 3.0.0.4.386_45375 using RT-AX82U and no longer able to setup my Sonos wirelessly. I have tried a couple of Asus settings mentioned here in the forum but still getting issues (as per screen shot), only way setup works for me is via ethernet cable but once ethernet cable is unplugged, it’ll drop out from the network again. Most likely, will have to rollback to older firmware.

Any luck on yours?

 

 

 

I have recently updated to Asus, and wasnt sure if this was a Sonos thing or a Asus thing.  I have tried all the settings mentioned, but seem to be having issues with (and only with) my Play:1 devices, which I have 3 of.  My Roam, Beam, Arc’s and Play One devices are showing.  

 

As you mentioned in this post, if I connect via ethernet, they appear.  If I do a factory reset on the Play:1, it does pick this up in the app wirelessly, but it takes forever at the stage of adding it to the network.  Once added, it says to reboot the device, but doing that still doesnt bring it into the app.

 

If I check connected devices on the router, the Play:1 device does show as online, but the sonos app doesnt seem to have a clue that it exists.

 

I have tried pretty much everything, but the 3x Play:1 devices I own, are all missing when wireless.  They arent anywhere near wired points, and the reason I have sonos is to remove the need for cables being everywhere.

 

Has anyone got any further with this, as lost my surround sound now, as I use 2 of these as LS and RS with the Arc.  If I connect them with Ethernet, I can re-add them, but as soon as the ethernet is unplugged, it says it cant see the device.

 

I have AsusWIFI AX Firmware 3.0.0.4.386_45934 and have tried all the suggestions above.  Thanks in advance.

Started having the issues after the latest firmware update on RT-AX82U. No system nor speakers detected and connecting directly via Ethernet didn’t help. Rolled back firmware to earlier release (July 2021) and system weren’t grayed out anymore and was able to add speakers via Ethernet but only for a minute. Now dropouts and not able to detect speakers is none stop. 

I called the tech support and after few try’s and two hours  of testing, they suggested I purchase the Boost to resolve these issues. Anyone has experience with using the Boost with latest firmware to resolve theses issues?

...I decided to fully update my routers and do a factory reset on them.  .. It worked, no other custom changes or drop downs.. just factory reset and its gold.  Hope this helps someone.

Note, I’m running - 3.0.0.4.386_43084-g728dd24

 This is working for me, too. RT-AX86U router

installed latest firmware 3.0.0.4.386_45375

then a hard factory reset

Sonos working fine

I had the same problem, Sonos Arc, Sub Gen 3 and One worked fine, but would not recognize my Play 5:II, solved it by rolling back the firmware.

This issue just cropped up for me! I have a Sonos beam, sub, and Pay 1 speakers downstairs, and a sub and two Play 1 speakers upstairs. Well the the system no longer recognizes any of the Sonos speakers upstairs. Downstairs speakers are fine. 

Have had an ASUS RT-AX86U router for several months with no problem. Using this firmware:

Firmware version 3.0.0.4.386_45375

Can anyone help? Thanks! 

 

I’m on the same Firmware version 3.0.0.4.386_45375 using RT-AX82U and no longer able to setup my Sonos wirelessly. I have tried a couple of Asus settings mentioned here in the forum but still getting issues (as per screen shot), only way setup works for me is via ethernet cable but once ethernet cable is unplugged, it’ll drop out from the network again. Most likely, will have to rollback to older firmware.

Any luck on yours?

 

 

Userlevel 7
Badge +23

 

Was a big fan of Sonos until this problem occurred. Asus routers are popular and highly recommended in in the consumer electronic products world. Asus routers should work with Sonos without any problem, well maybe a tweak to the router setting is OK. But that’s not the case here. So I will call Sonos tomorrow and see if they can fix this. 

This is 100% an ASUS problem to fix. Sonos require a functional local network, and the newer firmware on these routers do not provide that. I don’t think you’ll find many Sonos users recommending their routers these days.

Reply