Question

Alarm snooze not working most of the time - cant connect to product.

  • 26 June 2020
  • 2 replies
  • 239 views

Badge

I’ve setup the alarm and it seems to work - music starts playing in the correct room at the correct time. 

I get the alert notification on my iPhone that should allow me to snooze. However, I just get a “Can’t connect to product” error when I try to use snooze. 
 

Any ideas? Is this a known bug?

thanks!


This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

2 replies

Userlevel 6
Badge +17

Hi @badobsession81.

Welcome to the Sonos community and thanks for reaching out to us.

I would like to recommend the following guides for us to better understand what is going on with the Sonos system.

I would also recommend taking note of the following information for us to better understand your Wifi Network System and for us to check within our internal articles if we have a known issue with the network hardware.

  • Modem make and model.
  • Router make and model.
  • Wifi extender/booster make and model.
  • Mesh system make and model.

Please let me know if you still have further questions or concerns. We are always here to help.

Thanks,

 

Badge

Hi Paul

Only just seen this 3 months on, but still getting issue. I work around it by launching the sonos app and stopping the speaker that way. 
 

ive just done what you asked with an alarm set at 1030am and diagnostics submitted at 1029 before the alarm and then again at 1030/31 after the alarm but before trying to snooze. 
 

the first time I hit submit the diagnostic failed to send but I tried again and it was successful. 
After sending the second diagnostic I was able to snooze the alarm (I went via the iOS push notification which is where I get the problem, not from within the app). This was successful this time so didn’t recreate the problem. 

my instinct is that it works if you’ve created a ‘connection’ just before the alarm sounding - in this scenario I got a fail when submitting diagnostic initially, but then I was connected and in the app viewing my sonos system before exiting ahead of the alarm. I think something about being in the app and having a connection recently with the sonos system meant that I was able to stop the alarm. 
 

I was also able to dismiss the alarm after the 10 min snooze (from the iOS push notification)

 

I think the sonos app was open in the background so maybe that has something to do with it too?

on your other points:.

  • Modem make and model - BT hub 6, fibre to the property
  • Router make and model - BT hub 6
  • Wifi extender/booster make and model. - none
  • Mesh system make and model. -none

Hope you can help  

 

(ps I do sometimes get a problem connecting to sonos system when launching the app but a refresh or restart of the app always solves this)