Answered

Access denied to Synolog NAS server – can’t play files in one room other rooms are fine?

  • 29 April 2023
  • 56 replies
  • 8894 views

Userlevel 2
Badge +5

Access denied to Synolog NAS server – can’t play files in one room other rooms are fine?

 

I am a long time user of Sonos. I have 4 zones that all uses S1. I do have a Roam also (S2) but hardly ever uses it at my home.

 

My zones are: 

 

Office: two Play 5: gen1

Livingroom: Soundbar, Sub and two Play:3

Room 3: Play:1

Room 4: Play:1

 

I do have a booster as well. 

 

Out of the I can no longer play my music files from my Synology NAS – BUT only in my office…. I can play my files in the livingroom, room 3 and 4 – but NOT in my office.

 

I have tried from my MacBookPro App and from my iPhone app – but it will not play the files. Radio and streaming services are doing fine.

 

I can perfectly see my files/folders in the app – but access for playing is denied in my office. If I combine livingroom with office I can play the files in the office – but I can not start music from files in the office.

 

On my NAS I have 5 different main folders with files and it is all the same. Will not play in office but other zones are playing fine.

 

All systems are updated and I have rebooted computer, iPhone, modem, router, server, Play:5’s.

 

Can someone help me?

 

 

 

icon

Best answer by sjw 7 May 2023, 15:20

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

56 replies

Userlevel 7
Badge +15

When you say access is denied in a room, do you mean you're literally getting an error saying ‘denied’ or that you are unable to play music in some rooms but others are OK?

If one room is able to access the NAS, then your whole system has access - the speakers/rooms don't have individual ‘permissions’.

Userlevel 2
Badge +5

I have acces to the folders in my Office. But when Sonos i trying to play the files it says it cannot play the file because access is denied and it skips to the next file quickly and then the same error occurs.

And all other parts of my home I can play my files.

But the problem is I have not altered any settings lately. It just suddenly occurred.

Do you understand what I’m saying?

S1 App required the SMB v1 sharing protocol, so ensure the NAS is not set to v2, or higher.

I seem to recall from other posts here in the community that on the NAS box its as follows…

Goto the SMB settings under File Services, then Advanced, and then ‘Other’.  There is a setting called enable NTLMv1 authentication.  Once you do, you will get a nasty warning message about potential vulnerabilities with this aging standard.  Continue and enable the setting and it should then work.

I’m just not sure if the instructions above apply to your NAS model. If not, then maybe check the user manual and check the SMB version.

Userlevel 7
Badge +15

OP can play in some rooms though so I’m not fully understanding the issue.  Unless by ‘other parts of the house’ they mean non-Sonos devices too?

However, as @Ken_Griffiths , make sure your SMB is set to V1 as the minimum allowed version.

It looks like this:

 

Userlevel 2
Badge +5

SMB3 and SMB1 is already enabled

 

 

Userlevel 7
Badge +15

Are you able to Update your Library?

Userlevel 7
Badge +15

Hi, it looks like others are having similar issues where certain devices can connect and others not.  Seems to be related to an SMB update on the NAS.

See here -

Depending on your knowledge of accessing the NAS via ssh/Putty, there is also a fix a little lower.  

 

Userlevel 2
Badge +5

Thanks for the links. Makes sense but I\m not really interested ind neither ditch my Play 5 speaker for new expensive ones or down grade SMB on my NAS. Hopefully Sonos and Synology will come up with a good solution.

 

Tomorrow I will call the support and ask them what to do…...

Userlevel 7
Badge +22

You might try the suggested setting on your NAS smb.conf instead of downgrading.

unix extensions = no

Userlevel 2
Badge +5

I’m not that technical to be able to do that I guess..

Badge

I am having the same problems on my DS216play. All worked fine until the latest update. I am now on DSM 7.1.1-42962 (Update 5).

 

Any suggestions to solve this are highly appreciated.

 

 

 

 

Did you look at the threads that @sjw linked above?

Badge

Yes, I did. I checked my settings, but the problem still stays.

Badge

I have to correct myself, I cannot play music from any of my SONOS-players. 

 

I get the message: unnable to play …. - access tp //,,,,, denied.

 

 

 

Badge

Again, I have to correct myself. Apologies,

I checked again and I noticed the problem occurs on my Sonos 5 (Gen 1) and on my Sonos Connect. it works fine on my Sonos 1 (Gen 1).

Again apologies for my inaccuracy.

 

Userlevel 7
Badge +15

It isn't a ‘check settings’ thing, you need to make (slightly technical) changes to your NAS.  Second link gives them.

Badge

Thanks for the quick reply. I checked the second link but I am not sure what the technical changes  are that you refer to. I see several options mentioned (downgrade SMB, which I do not want to do - add unix extension etc.)

Can you be please be more specific on what I can/should do?

Again thanks.

 

Thanks for the quick reply. I checked the second link but I am not sure what the technical changes  are that you refer to. I see several options mentioned (downgrade SMB, which I do not want to do - add unix extension etc.)

Can you be please be more specific on what I can/should do?

Again thanks.

In the last post @Outburst mentions this…

"I’m not sure whether this is an option on Synology drives, but instead of downgrading one could add “unix extensions = no” to the smb.conf file. Samba 4.15 includes a security change that makes this addition needed for some devices (old Linux Kernels)"

…so perhaps try that option or you might have to uninstall/downgrade the extensions as suggested before that - If you don’t make any changes, then I guess you’re stuck for the time being.

Userlevel 7
Badge +15

The changes are simple but require you to connect to your NAS in a way that most users are not familiar with (ssh). Until it's fixed their end (hopefully it will be), if you don't want to make those changes you won't be able to resolve the issue yourself.

They are very simple changes though and you just need to type and follow those instructions above (you need an Admin/root account for the NAS).

Badge

I logged in using SSH, but now I am stuck. I see my username@NASname: $

Do you have any other instructions (in detail) how to get to the smb.conf file and how to change it?

Thanks for your help.

 

Userlevel 7
Badge +15

Which model NAS do you have?  Do you know the ‘root’ password?  This is the main admin account.

Assuming you do, at the prompt, type

sudo -i  (note the space after sudo).

Press enter. (it should give a slightly humorous prompt).

Type the root password.

Post back when you have done this.

Badge

I have a NAS216play (old one).

I have logged in

Badge

It now shows:
root@Nasname: #

 

Userlevel 7
Badge +15

OK, we’ll do it one step at a time - I assume you have never done this type of thing before?

Type cd /etc/samba

Then type ls -al (they are lowercase L’s)

Does it show your smb.conf file?

Badge