Answered

Access denied to Synolog NAS server – can’t play files in one room other rooms are fine?

  • 29 April 2023
  • 56 replies
  • 8324 views


Show first post
This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

56 replies

Badge

Great, I am sure this will help others as well.

Userlevel 7
Badge +15

OK great, I’ll put all the instructions into one post.

Connect to the NAS via SSH (use PUTTY). (you may have to enable SSH in the NAS Control Panel)

Type sudo -i  (note the space after sudo).

Press enter. (it should give a slightly humorous prompt).

Type the root password.

Type cd /etc/samba  Press enter

Then type ls -al (they are lowercase L’s)

It should list the smb.conf file.

Type cp smb.conf smb.conf.backup  (that gives you a backup)

Now type:

vi smb.conf    Press enter

This takes you into a text editor in the smb.conf file

Check the line unix extensions=no isn’t already there.

Now press the down arrow until you reach the end of the file.

Type the letter o.  It should put the cursor below the last line - and you can now insert text.

Type the line unix extensions=no

Then press the esc key (top left of keyboard) a couple of times.

Now press the : key.  (Shift ;)

The cursor should go to the bottom of the file.

Type wq and then enter.

That writes the changes and quits out of the text editor.

The change is now made.

If anything seems to go wrong when you are in the file, press escape a couple of times, then : and then q! and enter.  This will quit the editor and make no changes.

Badge

Yes, thanks so much, I changed back the setting to use SSH.

Userlevel 7
Badge +15

Problem fixed yes?

Badge

Perfect, that did the job. Thank you so mu.

Great help. Much appreciated.

Enjoy your day.

Userlevel 7
Badge +15

Perfect.

OK, firstly, we will take a backup of the file!

Type:

cp smb.conf smb.conf.Rob  (that gives you a backup)

Now type:

vi smb.conf    Press enter

This takes you into a text editor in the smb.conf file

Check the line unix extensions=no isn’t already there.

Now press the down arrow until you reach the end of the file.

Type the letter o.  It should put the cursor below the last line - and you can now insert text.

Type the line unix extensions=no

Then press the esc key (top left of keyboard) a couple of times.

Now press the : key.  (Shift ;)

The cursor should go to the bottom of the file.

Type wq and then enter.

That writes the changes and quits out of the text editor.

The change is now made.

I don’t know if a reboot is needed for them to take effect - try it…

If anything seems to go wrong when you are in the file, press escape a couple of times, then : and then q! and enter.  This will quit the editor and make no changes.

Badge

 

Userlevel 7
Badge +15

OK, we’ll do it one step at a time - I assume you have never done this type of thing before?

Type cd /etc/samba

Then type ls -al (they are lowercase L’s)

Does it show your smb.conf file?

Badge

It now shows:
root@Nasname: #

 

Badge

I have a NAS216play (old one).

I have logged in

Userlevel 7
Badge +15

Which model NAS do you have?  Do you know the ‘root’ password?  This is the main admin account.

Assuming you do, at the prompt, type

sudo -i  (note the space after sudo).

Press enter. (it should give a slightly humorous prompt).

Type the root password.

Post back when you have done this.

Badge

I logged in using SSH, but now I am stuck. I see my username@NASname: $

Do you have any other instructions (in detail) how to get to the smb.conf file and how to change it?

Thanks for your help.

 

Userlevel 7
Badge +15

The changes are simple but require you to connect to your NAS in a way that most users are not familiar with (ssh). Until it's fixed their end (hopefully it will be), if you don't want to make those changes you won't be able to resolve the issue yourself.

They are very simple changes though and you just need to type and follow those instructions above (you need an Admin/root account for the NAS).

Thanks for the quick reply. I checked the second link but I am not sure what the technical changes  are that you refer to. I see several options mentioned (downgrade SMB, which I do not want to do - add unix extension etc.)

Can you be please be more specific on what I can/should do?

Again thanks.

In the last post @Outburst mentions this…

"I’m not sure whether this is an option on Synology drives, but instead of downgrading one could add “unix extensions = no” to the smb.conf file. Samba 4.15 includes a security change that makes this addition needed for some devices (old Linux Kernels)"

…so perhaps try that option or you might have to uninstall/downgrade the extensions as suggested before that - If you don’t make any changes, then I guess you’re stuck for the time being.

Badge

Thanks for the quick reply. I checked the second link but I am not sure what the technical changes  are that you refer to. I see several options mentioned (downgrade SMB, which I do not want to do - add unix extension etc.)

Can you be please be more specific on what I can/should do?

Again thanks.

 

Userlevel 7
Badge +15

It isn't a ‘check settings’ thing, you need to make (slightly technical) changes to your NAS.  Second link gives them.

Badge

Again, I have to correct myself. Apologies,

I checked again and I noticed the problem occurs on my Sonos 5 (Gen 1) and on my Sonos Connect. it works fine on my Sonos 1 (Gen 1).

Again apologies for my inaccuracy.

 

Badge

I have to correct myself, I cannot play music from any of my SONOS-players. 

 

I get the message: unnable to play …. - access tp //,,,,, denied.

 

 

 

Badge

Yes, I did. I checked my settings, but the problem still stays.

Did you look at the threads that @sjw linked above?

Badge

I am having the same problems on my DS216play. All worked fine until the latest update. I am now on DSM 7.1.1-42962 (Update 5).

 

Any suggestions to solve this are highly appreciated.

 

 

 

 

Userlevel 2
Badge +5

I’m not that technical to be able to do that I guess..

Userlevel 7
Badge +22

You might try the suggested setting on your NAS smb.conf instead of downgrading.

unix extensions = no

Userlevel 2
Badge +5

Thanks for the links. Makes sense but I\m not really interested ind neither ditch my Play 5 speaker for new expensive ones or down grade SMB on my NAS. Hopefully Sonos and Synology will come up with a good solution.

 

Tomorrow I will call the support and ask them what to do…...

Userlevel 7
Badge +15

Hi, it looks like others are having similar issues where certain devices can connect and others not.  Seems to be related to an SMB update on the NAS.

See here -

Depending on your knowledge of accessing the NAS via ssh/Putty, there is also a fix a little lower.