Unable to find Sonos Connect

  • 24 March 2023
  • 7 replies

Hi, I have been using my Connect for a number of years but after changing my wi fi network I can no longer find it. I’ve done a sytem reset but still nothing. I have also tried wiring it to my router.


Best answer by Airgetlam 24 March 2023, 19:12

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

7 replies

Connect the unit to your router via an Ethernet cable.  Use the app to change the WiFi credentials and then deploy wirelessly.  

However, it’s always a faint possibility that it’s ‘broken’, if it can’t connect while it’s wired to the router, assuming you’re using the correct controller (S1 versus S2). You may want to call Sonos Support directly to discuss it.

So after some messing around `I was able to fix my problem by downgrading to S1, I’ve been using S2 for quite a while with no issues. Once I’d downloaded the older OS and installed the app it linked up without any problems….yet (fingers crossed) Thanks

Userlevel 7
Badge +17

That’s probably because you’ve reset the Connect. I can understand that it would revert to S1 then……

Unfortunately it’s still not right and I can only use it when wired to router….


a few weeks ago all my casting/ streaming/ airplay services stopped working. We are using a 5G Fast 5688T home broadband modem. 
I swapped modem and the new 5688T is unable to connect to the amp. Has anyone encountered this issue? Same issue for 5Ghz and 2.4Ghz



Did you change you SSID and password? As explained in the new router - installation instructions FAQ, you may need to connect a temporary Ethernet cable to the Amp in order to ‘tell’ it your new Wi-Fi connection.