Dealing with HDMI ARC issues on Amp and input choices


Badge +1

I have an Amp hooked up to our living room TV in our house. (I also have a home theater setup using Sonos in our barn/guest house with the big screen TV.) I’m really fed up with the Amp, after any blackout or power flicker, losing all settings. I’ve been using regular stereo audio input pulled from an HDMI switcher to feed the Amp. Whenever we get a power flicker, my Sonos devices lose their groupings and settings. (Which, really, is pretty sad considering that pretty much any device, in 2021, can save such settings in non-volatile RAM - except the high priced Sonos!)

Every time we start up the TV and there’s been a power flicker (which we often don’t know has happened), we get silence. So, instead of using my IR all-in-one remote, I have to pull out my phone and run the Sonos controller and change the Amp input BACK to “Line In,” where I always leave it. What’s amazing (and sad) is that this system is on a UPS. Everything on that UPS keeps behaving normally during an outage or power flicker, but the Amp still loses it’s input setting. (We have a full house generator - if power is totally out, within 40 seconds the generator kicks in and restores power. With a UPS and the generator, this Amp is never without power - yet it’s so sensitive that after a power flicker, it loses settings!)

So, first, it’s really small of Sonos to not have a way to store a setting like that.

Second is a bigger issue. I took the output from the HDMI switcher and ran it into a splitter so I could run one HDMI cable to the projection TV and one to the Sonos Amp. Simple solution, right?

Nope. Then Sonos says, “No arc, gotta fix it.” I’m using equipment that supposedly uses ARC, but I don’t see why it’s needed, since the audio comes from my Apple TV and my Sony BD player. All Sonos has to do is read the audio signal off the HDMI cable.

I want to eliminate this continual pain in the rear. My wife hates, and I mean HATES having to change the Sonos Amp inputs if she wants to watch TV by herself whenever this has happened. I find it an annoyance that, on any kind of up-to-date system in 2021, shouldn’t exist.

I would like to be able to do one of the following, in order of preference:

  1. Just hook the HDMI cable from the HDMI splitter to the Amp and not have to deal with ARC and just use the normal audio from the Apple TV or Sony BD player. Both output audio on HDMI, so sound coming back from the TV is really not a problem.
  2. Keep the “Line In” setting all the time, so it’s not lost every time there’s a power flicker or outage.

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

66 replies

Userlevel 7
Badge +17

Hi @TangoMe 

Thanks for your post!

It certainly sounds like you’ve got a bit of an unstable power supply. I presume you have checked the integrity of the Amp’s power cable and connection? Have you tried plugging it into a different mains outlet?

It could be that the UPS is unable to immediately supply enough current for all the devices connected to it and power dips in the first fraction of a second. You may find that a power strip with power spike filtering will help the Amp, though I cannot promise anything. I assume an upgrade of the UPS would also serve.

The input used isn’t so much a setting that gets saved, but a choice made by software - if you reboot that software, then the choice goes back to it’s default. The same can be said for grouping. The priority here, I think, is to stop the power interruptions to the Amp, and the setting not being saved will no longer be an issue.

As for HDMI, splitters and switchers are not supported for these very reasons - we simply cannot assume that any of these devices will work, as we know nothing about their build quality or mode of operation.

  1. Just hook the HDMI cable from the HDMI splitter to the Amp and not have to deal with ARC and just use the normal audio from the Apple TV or Sony BD player. Both output audio on HDMI, so sound coming back from the TV is really not a problem.

 

The audio that comes from HDMI source devices, intended for a TV, is on different wires inside the HDMI cable than the ARC audio, and this is why you cannot simply connect a HDMI source device to an HDMI audio device and get audio. Line-In is not recommended for TV audio due to the fact that it is digitised and pre-buffered prior to playback, whereas HDMI audio is played as soon as possible to reduce lip-sync issues. I recommend you use HDMI-ARC, if you can, though I appreciate that projectors don’t supply it. This is why we do not support the use of projectors - you’re often forced to use splitters which are also unsupported.

 

  1. Keep the “Line In” setting all the time, so it’s not lost every time there’s a power flicker or outage.

Do you have Line-In Autoplay activated? If not, please go to Settings » System » [Amp Room] » Autoplay (under Line-In section). This should make the Amp switch to Line-In after the reboot, assuming the source is still playing. If it doesn’t, you should be able to mute then unmute the source via the remote which will then trigger the autodetection (though I think you may need 5 or 10 seconds of silence for it to work).

Finally, if you feel that there is some kind of fault with the Amp, I recommend you get in touch with our technical support team. If you are sure that the power issues are not due to a fault in the Amp, then I can only recommend you get these fixed for best operation.

I hope this helps.

TangoMe,

The SONOS ARC and BEAM, TV’s, and A/V units can have only one HDMI-ARC connection.

Normally, audio and video are sent from an input device (Cable box, DVD, Blu-ray, AppleTV, etc.) to the TV. Now that modern TV’s often include “Apps”, there must be a method for sending audio from the TV to the A/V receiver, BEAM, or ARC. It would be convenient if only a single cable is needed. This is the purpose of HDMI-ARC. In most home A/V systems there is only one TV, hence there is only one HDMI-ARC. The HDMI-ARC connection on the TV is wired to the HDMI-ARC connection on the A/V system or Sonos ARC. In general, 3rd party boxes inserted between HDMI-ARC ports do not properly handle the audio and control signals.

Explore the possibility that your UPS does not start fast enough. Simply force a power outage for your barn system and observe ARC’s response. If the UPS is too slow for ARC, ARC will reboot.

Badge +1

What I find interesting is that I have a projection TV on a similar UPS (same model), a computer, the Amp, an Apple TV, and a BD player all on that UPS. On others that are the same model, I have the other TV, an arcade game machine, other Apple TVs, computers, and much more. We have a whole-house generator, so with these UPS’s in place for these systems, the 40-50 seconds it takes for the generator to come online is not an issue for equipment going down. This includes my media servers, home automation hubs, a firewall, a TV tuner (with ethernet output), and more. So with all this sensitive equipment on UPS devices, it seems odd to me that the Amp is the ONLY one that freaks out with a power flicker.

We have projection TVs in both locations (our house great the home theater in the barn).  I get that a lot of people use smart TVs, but there are a lot of us who have spent thousands on good projection systems. Those TVs are not running an OS and loaded with apps, but, damn, yes, they can be a big investment.

I’m not clear, but it seems like the Amp is set up for one way of doing things. I’ve spent a good chunk of change on my projection TVs, although that was a few years ago. Neither has an onboard OS or ARC. They’re not designed for that, but they work well with Apple TV or any other box like that I’d want to use.

It feels, and I’ve run into this before, which is why I almost dumped Sonos in 2019, when we renovated our barn and set up the home theater setup, of going in another direction. It just feels like Sonos decides, “This is how things will work, and if that’s not your setup, well, it should be.”

(I’m still peeved that my Playbar, which is what Sonos was selling in 2019, had to use optical connections rather than HDMI and my consultant at Crutchfield said that’s probably the reason the sound goes out of sync. I had considered updating to an Arc to replace it, since the Arc uses HDMI, but now that I’m reading this, I figure it’s pointless and I may have to redo the whole 5.1 system if I want synced audio, since, I’m sure, the Arc will require Arc as well and not work with a projection TV that doesn’t use it and for which I use a HDMI switch so I can use my game console, a computer - for more games - a BD player, and Apple TV.)

Arcana is a great problem solver. HDFURY has a bunch of other products that can work through HDMI issues.

I used a PLAYBAR for the last 7 years or so, and never had a lipsync issue on either a Sony TV or a Vizio TV.

Sonos devices are, of course, limited by playing the signal as quickly as they receive it, so any lipsync delay would be due to the device providing the signal to the PLAYBAR. 

The Sonos PLAYBAR was originally released in 2013, which implies the design was created earlier than that. At that point, I don’t recall ARC being a ‘thing’ that any TVs had. Seems odd to be angry about Sonos designing and selling a device that matched the majority of TVs at the time. 

Badge +1

I used a PLAYBAR for the last 7 years or so, and never had a lipsync issue on either a Sony TV or a Vizio TV.

Sonos devices are, of course, limited by playing the signal as quickly as they receive it, so any lipsync delay would be due to the device providing the signal to the PLAYBAR. 

The Sonos PLAYBAR was originally released in 2013, which implies the design was created earlier than that. At that point, I don’t recall ARC being a ‘thing’ that any TVs had.

Unless there are different models, one point there is that the Playbar does not have HDMI input, so ARC is a total non-issue. The only connections (other than power) are optical and ethernet. My product advisor (again at Crutchfield, a company I trust - they haven’t led me wrong yet) has said that he has had complaints from several people who were using the optical cable for sound about sync issues.

Now, if there were a way to pull the audio from the HDMI cable and send it to the Playbar by ethernet AND do that quickly enough that syncing isn’t a problem, that would be a solution. But with the Playbar, the only actual audio input is the optical connector.

Seems odd to be angry about Sonos designing and selling a device that matched the majority of TVs at the time. 

My main complaint is about the Amp, a newer product, that won’t work with HDMI input only and requires ARC. With a projection TV on the other side of the room from an entertainment center, most people are not going to have an extra HDMI cable going that far.

Badge +1

Arcana is a great problem solver. HDFURY has a bunch of other products that can work through HDMI issues.

Thank you! I’m looking into both. That kind of research takes me time, so it’ll be a few days before I can look over both of them.

Badge +1

 

 

 

 

  1. Keep the “Line In” setting all the time, so it’s not lost every time there’s a power flicker or outage.

Do you have Line-In Autoplay activated? If not, please go to Settings » System » [Amp Room] » Autoplay (under Line-In section). This should make the Amp switch to Line-In after the reboot, assuming the source is still playing. If it doesn’t, you should be able to mute then unmute the source via the remote which will then trigger the autodetection (though I think you may need 5 or 10 seconds of silence for it to work).

I did this. I can’t remember if I did it on my iPhone or through the Sonos control panel, but I did it. Then I checked to be sure the Amp was on Line-In and muted it again. (I hear background noise when the Amp is not muted and everything else is off, so I have to mute it - since I can’t turn it off.)

A day or two later, after no sign of any power flickers (maybe one happened at night), we turned on the entertainment system and there was no sound. The Amp was, again, on TV as opposed to Line-In.

I’d go with the 4K-Arcana, but that’s $200 and is a lot to spend on an issue like this. I may use that, though, in the big screen setup, if I put in an Arc, which I’m thinking of doing. (I just don’t know what to do with the Playbar - my main reason it’s a problem is that the Playbar does not always stay in sync with the image and my advisor tells me that happens with optical connections, the only thing Playbar can use other than ethernet.)

Userlevel 7
Badge +17

Hi @TangoMe 

If you hear a background noise even when nothing is playing, I recommend you get a “ground-loop isolator” to fit between the Amp and it’s Line-In source device - this will remove the noise, and the removal of the noise will allow Autoplay to function as intended. There are a few kinds, with different connections, so please make sure you get a RCA-RCA model. Thankfully, these devices are pretty cheap.

There is nothing intrinsic to TOSLINK (optical) that will cause lip sync issues, but processing inside the TV could cause trouble. Note that there will always be a slight latency (about 35ms) between HDMI audio input to AMP and output. Latency is about 75ms for analog Line-In.

Cheap analog ground isolators are not always effective enough. If you try a few cheap, ineffective isolators, Jensen will eliminate your ground loop, but may be uncomfortably expensive.

As a quickie trial, try disconnecting the cable TV feed from your cable box. The CATV feed is a very common source of ground noise. Properly grounded CATV feeds are not usually much of an issue. There are ground isolators that can be installed in the CATV feed, but they often disrupt the signals. Again, the cheap isolators are more likely to be problematic.

Badge +1

There is nothing intrinsic to TOSLINK (optical) that will cause lip sync issues, but processing inside the TV could cause trouble. Note that there will always be a slight latency (about 35ms) between HDMI audio input to AMP and output. Latency is about 75ms for analog Line-In.

Cheap analog ground isolators are not always effective enough. If you try a few cheap, ineffective isolators, Jensen will eliminate your ground loop, but may be uncomfortably expensive.

As a quickie trial, try disconnecting the cable TV feed from your cable box. The CATV feed is a very common source of ground noise. Properly grounded CATV feeds are not usually much of an issue. There are ground isolators that can be installed in the CATV feed, but they often disrupt the signals. Again, the cheap isolators are more likely to be problematic.

Thanks - a lot of useful information in there!

But as to the TV source: We are out beyond cable and normal satellite internet and TV sucked so badly I dropped them. (I found a source for internet through a cellular modem for internet.) For TV, I have a digital antenna that (eventually) connects to a HDHomeRun Flex 4K that can tune to 4 channels at a time. The input for this is coax. Output is through my LAN. For “normal” TV, I have several Apple TVs and use the app Channels DVR on them for viewing (and a server version of it on a Linux based media server for DVR service).

On this particular entertainment center setup, the inputs are only the Apple TV and my Sony BD, so there is no cable box.

Badge +1

 

  1. Keep the “Line In” setting all the time, so it’s not lost every time there’s a power flicker or outage.

Do you have Line-In Autoplay activated? If not, please go to Settings » System » [Amp Room] » Autoplay (under Line-In section). This should make the Amp switch to Line-In after the reboot, assuming the source is still playing. If it doesn’t, you should be able to mute then unmute the source via the remote which will then trigger the autodetection (though I think you may need 5 or 10 seconds of silence for it to work).

 

More on this.

Somehow it’s marked as the answer, but it DOES NOT SOLVE THE PROBLEM.

I did this and tested - the Amp was still on Line-In, as it was before I did this. But now, every time we watch TV, I have to switch from HDMI to Line-In. Before I only had to switch if there was a power flicker, now, EVERY TIME, I have to change it to Line-In. My wife HATES it because it makes it harder for her to watch TV by herself since she can’t just use the Harmony universal remote and turn everything on at once.

Why Sonos can’t store this kind of setting in non-volatile RAM, like every other freaking device on the planet has done since somewhere around 2010 is beyond me. I spend extra for SONOS and every time the system loses power, I have to regroup everything and change settings like this. That is SO 2005!

 

Userlevel 7
Badge +17

Hi @TangoMe 

Once a thread has been quiet for a few days, we are required to mark Best Answer if it has not already been marked, and when we mark it, we always go by what the original question was. I’ve unmarked my response.

I did this and tested - the Amp was still on Line-In, as it was before I did this. But now, every time we watch TV, I have to switch from HDMI to Line-In. Before I only had to switch if there was a power flicker, now, EVERY TIME, I have to change it to Line-In. My wife HATES it because it makes it harder for her to watch TV by herself since she can’t just use the Harmony universal remote and turn everything on at once.

It sounds like you disabled Autoplay, not enabled it. Please turn Autoplay back on again.

Why Sonos can’t store this kind of setting in non-volatile RAM, like every other freaking device on the planet has done since somewhere around 2010 is beyond me. I spend extra for SONOS and every time the system loses power, I have to regroup everything and change settings like this. That is SO 2005!

As I mentioned earlier, it’s not a setting - it’s a state. All the settings are saved - like Autoplay, for example, or your WiFi credentials. I recommend you aim for resolving the power interruptions, but removing noise on the cable should help.

Badge +1

Hi @TangoMe 

Once a thread has been quiet for a few days, we are required to mark Best Answer if it has not already been marked, and when we mark it, we always go by what the original question was. I’ve unmarked my response.

Thank you! I get the reason for that policy, but it can be seriously misleading. This thread is a prime example: There was no clear working answer and to mark an answer as a solution when it may not be is totally inappropriate. (But that goes with what I have said. Sonos seems to want to do things their way, whether it works for others or not.)

I did this and tested - the Amp was still on Line-In, as it was before I did this. But now, every time we watch TV, I have to switch from HDMI to Line-In. Before I only had to switch if there was a power flicker, now, EVERY TIME, I have to change it to Line-In. My wife HATES it because it makes it harder for her to watch TV by herself since she can’t just use the Harmony universal remote and turn everything on at once.

It sounds like you disabled Autoplay, not enabled it. Please turn Autoplay back on again.

 

I get that point, but if I disabled it, then it would have had to have been enabled in the first place. If it was enabled, then either it doesn’t work or I wouldn’t be having this problem. So, either way, it’s a problem.

 

Why Sonos can’t store this kind of setting in non-volatile RAM, like every other freaking device on the planet has done since somewhere around 2010 is beyond me. I spend extra for SONOS and every time the system loses power, I have to regroup everything and change settings like this. That is SO 2005!

As I mentioned earlier, it’s not a setting - it’s a state. All the settings are saved - like Autoplay, for example, or your WiFi credentials. I recommend you aim for resolving the power interruptions, but removing noise on the cable should help.

A few points:

  1. NOTHING else is having an issue. The AppleTV continues fine, the BD player, if left on, continues fine. The ethernet switch on that circuit has no issue. NOTHING else shows a power issue. We have a standby generator that provides power to two buildings and I have the same model UPS on over half a dozen computers, TVs, firewalls, and other devices. All told, there are over two dozen devices on this same model power supply. NOTHING has a problem with it other than the AMP. NOTHING ELSE.
  2. Setting or state? I’m an end user. Granted, I’m a retired programmer and do a lot of sys admin work. But for a USER, it’s hard to tell, “Is this a state or a setting?” I had to go in to the app and change this, so, for most people, it’s a setting. Arguing that it’s a state is pedantic and asking any user to know more than they should. In fact, since one goal of Sonos seems to be to imitate the Apple reputation of “It just works,” this goes against that - “Oh, you have to know what’s a state and what’s a setting. You have to learn what is stored and persistent and what isn’t.” Speaking as a retired programmer (one who did well enough with his own software to retire early - so I’m not an idjit), this is making excuses for a product not behaving in what is a predictable way to the customer.
  3. Again, most devices keep settings or states in non-volatile RAM. I had problem with a damaged iPad, got a new one, and it backed up and even my games were at the point where I had stopped playing them. Setting or state, it’s absurd that it’s not persistent over a power loss. It just means, “Hey, customer who has paid hundreds of dollars for each Sonos device, if there’s a storm, you have to go around to every device and reinstate these settings.” That’s treating the customer/end user like crap.

Corry, I do appreciate your effort and time on this, and I realize that you have to take the Sonos line, but these are a few points where Sonos is using “developer think.” And, again, I’m speaking as a former developer. This is the kind of thing that has been thought through in terms of, “How does it work for us developers?” It’s far from, “What works for the users? What will make this feature work easily and predictably for the user?”

And the whole, “Check and resolve the power supply issue” is a seriously lame argument. That’s in the, “Oh, our product is perfect, it must be someone else’s fault,” category. As I pointed out, with over two dozen devices on that model UPS and multiple other products on the same one as the AMP, it’s pretty lame that this product, costing over $500 (forgot the exact price) is so freaking sensitive when something like an Apple TV doesn’t even notice there’s been a flicker. It sounds very much like, “It’s easier to blame something else that works for everything but us than it is to say, ‘Hmmmm. Maybe we should look into this.’”

I know there’s a lawsuit with Google over the whole house audio - which is, really, kind of silly, since SlimDevices was doing that earlier, too, and that was no problem. But what that has done is alerted me that Google can do what Sonos does. I feel seriously stonewalled on this so now I’m looking into whether I should just find other options.

TangoMe,

Have you tried forcing a power interruption to the UPS that services ARC?

Badge +1

TangoMe,

Have you tried forcing a power interruption to the UPS that services ARC?

That’s a good idea. I’ll try that in the next day or so when I have time.

Userlevel 7
Badge +17

Hi @TangoMe 

I’m sure you won’t like me being pedantic, but Best Answers are not Solutions. Very often, the Best Answer is to call technical support, which is not a Solution.

Regarding the Amp, I refer you back to my initial statement:

Finally, if you feel that there is some kind of fault with the Amp, I recommend you get in touch with our technical support team.

And regarding settings and “states”, I completely understand your points. With AutoPlay enabled, the input is determined, not remembered. With AutoPlay disabled, the Amp will start in a state of “no music selected” - no queue, no input selected. I can treat this as a feature request but as AutoPlay should take care of this for you, I wouldn’t expect to see changes any time soon. A ground-loop isolator should sort out AutoPlay functionality for you. 

Badge +1

Hi @TangoMe 

I’m sure you won’t like me being pedantic, but Best Answers are not Solutions. Very often, the Best Answer is to call technical support, which is not a Solution.

Regarding the Amp, I refer you back to my initial statement:

Finally, if you feel that there is some kind of fault with the Amp, I recommend you get in touch with our technical support team.

And regarding settings and “states”, I completely understand your points. With AutoPlay enabled, the input is determined, not remembered. With AutoPlay disabled, the Amp will start in a state of “no music selected” - no queue, no input selected. I can treat this as a feature request but as AutoPlay should take care of this for you, I wouldn’t expect to see changes any time soon. A ground-loop isolator should sort out AutoPlay functionality for you. 

Thank you for that extra on the settings and states. I get that AutoPlay fixes the issue, but when you’re talking about a feature request, AutoPlay as a fix for this is confusing or, at the least, counter-intuitive. It’s not at all clear to a user what’s going on or that using AutoPlay will keep it in LineIn on restart. Maybe having AutoPlay as the default, so the unit will always, after power loss, go back to exactly the way it was would be more in line with expected behavior?

I don’t know how it is now, but at my old house, I wasn’t using any UPS units, other than for my computers. Every time power went out and came back on, even for a short flicker, I would have to regroup my Sonos devices. In our new place, and now that I’m married, so there are two people in the house and guest house, and we have a guest house where family stays sometime, grouping doesn’t work as well and I don’t use it much. However, I found it seriously frustrating that grouping was not preserved during a power outage. Does AutoPlay fix that issue, too? Or has it been fixed?
 

It may only take 2-3 minutes to do things like change to LineIn and to setup groups again, but for a premium product like Sonos, that kind of thing should be automatic. It’s like buying an upscale car and, every time it starts, having to retune the radio to the last station you were playing and reposition the seat and steering column settings to the way they were when you were last driving the car. It leaves the customer feeling frustrated that something that most cars (or audio devices) should be able to easily do has to be repeatedly done by hand.

I ordered a ground loop from Amazon and tried it - it created a distracting buzz while we were watching TV. I’m sending it back. If there is something specific I should look for in a ground loop or a particular brand that is known to work well, I’m open to suggestions.

Cheap analog ground isolators are not always effective enough. If you try a few cheap, ineffective isolators, Jensen will eliminate your ground loop, but may be uncomfortably expensive.

 

@TangoMe,

As you use iDevices, like iPad, perhaps take a look at the Soro App - I assume as a former developer you may understand the workings of iOS shortcuts. The Soro App will allow you to setup the Amp to use the line-in, to group rooms as required, set EQ and volume levels etc. See attached mock-up screenshot that I’ve just created to show you just some of the many features/settings the App can use via the Sonos API. 

Once the instructions/settings have been constructed into the shortcut, it can be saved as a package, which can be made to run through a variety of triggers, including a schedule, a saved icon on the iDevice, or any HomeKit automation including powering on a light, activating a sensor etc.

It means you could perhaps put the shortcut icon on any/every iDevice and a simple click on the icon would setup/reinstate the Amps line-in/grouping/volume/EQ settings automatically - no more having to spend time configuring those settings again. Anyhow see attached ‘example’ screenshot.

I will just add I’m not affiliated with the Soro App, other than I use the App myself, but it does require the user to understand the basic workings of iOS shortcuts. 

Anyhow I think the App is worth exploring further and hope it perhaps helps you to address many of your needs mentioned in the first part of your opening post in this thread.. 
 

Badge +1

@TangoMe,

As you use iDevices, like iPad, perhaps take a look at the Soro App - I assume as a former developer you may understand the workings of iOS shortcuts. The Soro App will allow you to setup the Amp to use the line-in, to group rooms as required, set EQ and volume levels etc. See attached mock-up screenshot that I’ve just created to show you just some of the many features/settings the App can use via the Sonos API. 

That’s only a semi-solution, since I can do it, but it means getting my wife to do the same and convincing her to download ANY app she doesn’t need is tough. The only reason she ever eventually downloaded the Sonos app was she really wanted to watch a few episodes of Supernatural and I was going to be gone for the rest of the day and evening and it was the only way she could get the sound going.

Plus I have a friend who comes by to help with cleaning and she has an autistic person to care for. When he’s with her, he likes to just sit here and watch Emergency! on the big screen. I’m not going to be able to convince her to download the Sonos app for just my house, let alone, adding another app she’ll never use.

 

Badge +1

AutoPlay - IT WON’T WORK. I’m finding, now, that I have to keep going into the Sonos app and selecting Line In to get audio to work. I think it’s every time, but I may have forgotten a time or two when it worked without that, but I’m not sure. But I have it selected for the Amp and I don’t see other Autoplay options I can pick.

Here’s a series of screenshots I took trying to set AutoPlay:

I picked “System: and got this:
 

I scrolled down until I got to “House Great Room,” where the AMP is, and picked that and got to here:
 

If I pick Amp, all I can configure is wifi. I scroll down and see “Line-In” and it says it’s connected. I scroll down to Autoplay and pick it and get this:

I pick Autoplay Room and get this:

So Autopla is selected for this device

@TangoMe 

I’m not quite sure exactly what you’re trying to achieve, but if you are using the ‘Line-In Autoplay’ and its grouping options and want to keep that input as your Amp ‘default’, have you switched off ‘TV Autoplay’ in the Amp Home Theatre Settings too? That’s assuming you are using the HDMI-ARC Port on the Amp and don’t wish to have the different inputs conflicting? I’m just wondering if the HT Autoplay option is what’s taking away the focus, perhaps? Also if the Line-in Autoplay isn’t working for you then check the cable and perhaps also try increasing the line-in source level to a higher value. See if that ‘perhaps’ fixes things for you.

Badge +1

@TangoMe 

I’m not quite sure exactly what you’re trying to achieve, but if you are using the ‘Line-In Autoplay’ and its grouping options and want to keep that input as your Amp ‘default’, have you switched off ‘TV Autoplay’ in the Amp Home Theatre Settings too? That’s assuming you are using the HDMI-ARC Port on the Amp and don’t wish to have the different inputs conflicting? I’m just wondering if the HT Autoplay option is what’s taking away the focus, perhaps? Also if the Line-in Autoplay isn’t working for you then check the cable and perhaps also try increasing the line-in source level to a higher value. See if that ‘perhaps’ fixes things for you.

Thank you for the input. A lot of those questions are answered upthread. I wish I could use ARC, but can’t for a few reasons. I consider it a serious design flaw that the AMP can’t accept normal HDMI input and that there isn’t even an option, somewhere in settings, to allow it to use just straight HDMI for input. (@Corry P: is that something that could be considered or added - a setting somewhere to allow normal HDMI input without ARC? I seriously doubt I’m the only person it would benefit!)

Badge +1

I tried tagging you in the above reply with a question - apparently it didn’t work. The question is if it might be possible for Sonos to include a setting that could allow a user to allow normal HDMI without ARC on the AMP? It could even include a warning that there’s no promise it will work or there could be sync issues when using it. For many of us, running a short 2’ HDMI cable from a HDMI switcher or multiplier to the AMP would work well. With my previous setup, I had a tuner that took HDMI input for audio and it worked fine for a few years, before I changed my setup to eliminate components I stopped using.